android
Go Back   abi>>forums > MP3 Players By Brand > Cowon iAudio > Cowon J3

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-29-2012, 08:12 PM
zaphod_209 zaphod_209 is offline
Junior Member
 
Join Date: May 2012
Location: Atlanta
Posts: 6
Default New To J3, requesting help with transfering files and tags

FULL DISCLOUSURE: I used to own an iPod mini and an iPod nano. Please don't hold this against me.

Almost all of my music is in un-protected .aac format. When I drag and drop the files into my player, the transfer goes smoothly, but the tags and album art don't transfer over. When I browse by artist, then album, the tracks are displayed in alphabetic order, not in track order.

I can rip the music from my CDs into .mp3 format, but I'd rather not since I've got over 1200 songs.

Does anyone know of an easy fix for this?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 05-29-2012, 08:25 PM
El C's Avatar
El C El C is offline
Member
 
Join Date: Dec 2011
Location: Canada
Posts: 366
Default

Welcome to ABI.

The album art issue can most likely be solved by sorting your tracks by album and then have the cover art in a file called folder.jpg.

According to this thread, the track order issue is a known problem. Not sure if it's resolved.
__________________
Desktop: Objective2 > Audio Technica A900
Portable: Cowon D2+ > Headstage Arrow 3G > Phonak PFE 112 (grey filters + Comply tips)
Reply With Quote

  #3  
Old 05-29-2012, 09:03 PM
zaphod_209 zaphod_209 is offline
Junior Member
 
Join Date: May 2012
Location: Atlanta
Posts: 6
Default

Thanks for the info.

Looks like I'm doing this the hard way...
Reply With Quote

  #4  
Old 05-30-2012, 04:23 AM
Urne's Avatar
Urne Urne is offline
Member
 
Join Date: Nov 2010
Location: Denmark
Posts: 247
Default

zaphod_209, are you transferring your AAC files to the J3 through the MTP or MSC Protocol? It's hard for me to understand how copying the music to the J3 can wipe the tag data inside the music files.

I can suggest you try re-tag some of your AAC files with software such as MP3tag and see if that fixes your issue. If not, EL_C's approach may be the way to go.
Reply With Quote

  #5  
Old 05-30-2012, 08:22 AM
DSperber DSperber is offline
Senior Member
 
Join Date: Jun 2010
Location: Marina Del Rey, CA
Posts: 697
Default

As far as official J3 documentation, AAC is not an officially Cowon-supported music file format. But apparently is "does work".

I suspect you're on your own here.

There are certainly known reported issues with proper tag support for other supported formats (e.g. WMA), so secretly-supported AAC is probably questionable.

Reply With Quote

  #6  
Old 05-30-2012, 06:34 PM
zaphod_209 zaphod_209 is offline
Junior Member
 
Join Date: May 2012
Location: Atlanta
Posts: 6
Default

Quote:
Originally Posted by Urne View Post
zaphod_209, are you transferring your AAC files to the J3 through the MTP or MSC Protocol? It's hard for me to understand how copying the music to the J3 can wipe the tag data inside the music files.

I can suggest you try re-tag some of your AAC files with software such as MP3tag and see if that fixes your issue. If not, EL_C's approach may be the way to go.

I checked the settings and it's in MSC mode, but I'm not sure what that means.

The lyrics aren't showing up ether.

I'm using firmware version 2.23. I'm going to try and update it and see if that does anything.
Reply With Quote

  #7  
Old 05-30-2012, 07:08 PM
DSperber DSperber is offline
Senior Member
 
Join Date: Jun 2010
Location: Marina Del Rey, CA
Posts: 697
Default

Quote:
Originally Posted by Urne View Post
zaphod_209, are you transferring your AAC files to the J3 through the MTP or MSC Protocol? It's hard for me to understand how copying the music to the J3 can wipe the tag data inside the music files.
Loss of at least imbedded album art from tags while transferring music files to the J3 in MTP mode is a long-known problem.

See this thread on iaudiophile from back in 2010, which I myself confirmed (because it seemed so improbable, and yet it was true).

Firmware problem, obviously.

But again, any issues regarding the officially unsupported AAC file format will probably meet with deaf ears from Cowon even if reported.
Reply With Quote

  #8  
Old 05-30-2012, 07:15 PM
DSperber DSperber is offline
Senior Member
 
Join Date: Jun 2010
Location: Marina Del Rey, CA
Posts: 697
Default

Quote:
Originally Posted by El C View Post
The album art issue can most likely be solved by sorting your tracks by album and then have the cover art in a file called folder.jpg.
This is incorrect.

Unlike many Windows-based media player programs (e.g. Winamp), the J3 does NOT recognize "folder.jpg" as the external name of the album art image file to be used when collecting music files for a single album in a single physical folder... used specifically as a "default" when there is no overriding imbedded album art in the tag of the music file.

For the J3, you must use "cover.jpg" (not "folder.jpg") to accomplish this result.

Note that almost universally the Windows programs which support "folder.jpg" for this purpose also support "cover.jpg". Unfortunately, the J3 only supports "cover.jpg".
Reply With Quote

  #9  
Old 05-31-2012, 07:19 AM
El C's Avatar
El C El C is offline
Member
 
Join Date: Dec 2011
Location: Canada
Posts: 366
Default

Quote:
Originally Posted by DSperber View Post
This is incorrect.

Unlike many Windows-based media player programs (e.g. Winamp), the J3 does NOT recognize "folder.jpg" as the external name of the album art image file to be used when collecting music files for a single album in a single physical folder... used specifically as a "default" when there is no overriding imbedded album art in the tag of the music file.

For the J3, you must use "cover.jpg" (not "folder.jpg") to accomplish this result.

Note that almost universally the Windows programs which support "folder.jpg" for this purpose also support "cover.jpg". Unfortunately, the J3 only supports "cover.jpg".
Thanks for that heads up, I realized that folder.jpg wasn't working yesterday when I was transferring some files.
__________________
Desktop: Objective2 > Audio Technica A900
Portable: Cowon D2+ > Headstage Arrow 3G > Phonak PFE 112 (grey filters + Comply tips)
Reply With Quote

  #10  
Old 06-10-2012, 06:42 PM
zaphod_209 zaphod_209 is offline
Junior Member
 
Join Date: May 2012
Location: Atlanta
Posts: 6
Default

This is very strange and very infurating.

I'm using .mp3 format and I'm still having problems with the tags. The tags show up on my computer for the duplicates on the hard drive. The tags show up when I look at the files on the J3 using Windows.

For some reason that is beyond me (I'm about ready to pull my hair out on this one) the J3 will not read the tags for some of the files. When I browse by artist, a few of the songs will get filed into an album labeled "Unknown"
Reply With Quote

  #11  
Old 06-11-2012, 08:55 AM
kp-j3's Avatar
kp-j3 kp-j3 is offline
Member
 
Join Date: Nov 2011
Posts: 297
Default

What's the contributing artist set to?
__________________
Daily drivers - Cowon J3 32GB/64GB microSD, Sennheiser hd202s
Others - Cowon D2+ 8GB, Iaudio 7 8 & 16GB, Sandisk m260, Samsung yp-r0 8GB, SGP 5.0
Reply With Quote

  #12  
Old 06-11-2012, 09:01 PM
zaphod_209 zaphod_209 is offline
Junior Member
 
Join Date: May 2012
Location: Atlanta
Posts: 6
Default

Quote:
Originally Posted by kp-j3 View Post
What's the contributing artist set to?
Um...

That's an excellent question.

Some of the ones that were screwing up were cover songs such as "Viva Las Vegas" covered by The Dead Kennedys and "I Will Survive" covered by CAKE.

I'll look into it and get back to you.
Reply With Quote

  #13  
Old 06-23-2012, 05:01 AM
Ghisy Ghisy is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Default

Sometimes I have problems with tags. I found this little freeware program which will scan your files and tell you if they have a problem. One click and they're fixed! You can then tag them properly with your favorite piece of software.
Reply With Quote

  #14  
Old 06-23-2012, 05:40 AM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,239
Default

MP3Val wasn't designed to report this type of tag problem. MP3Val reports on problems with information in some types of MPEG frames that might prevent them from decoding properly. http://mp3val.sourceforge.net/docs/manual.html

A track numbering or ordering problem like this one wouldn't fall into what it would report or fix. Mp3Tag would be a better choice for trying to get the J3 to sort the files the way zaphod_209 prefers.
Reply With Quote

  #15  
Old 07-13-2012, 09:19 AM
Ghisy Ghisy is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Default

@skip252, odd, some of my files had tags and/or album art problems and Mp3Val fixed them.
Reply With Quote

  #16  
Old 07-13-2012, 06:14 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,239
Default

If MP3Val fixed those type problems it must be an undocumented feature. Saying it fixed "tags and/or album art problems" isn't very specific. What was the error message that was given and what did MP3Val report as being fixed?

If it does more than what's listed in the documentation that would be a plus. Until it can be specified what that is I still believe MP3Tag is the better option for the type tagging issues being dealt with here.

Mp3Tag has a consistent track record of being able to write or rewrite tags for MP3 files and is still in active development. I'd recommend that over an undocumented feature no one else knows about in a software that hasn't been updated in several years.
Reply With Quote

Reply

Tags
album art, noob, tags

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 09:56 PM.