android
  #1  
Old 11-20-2011, 03:46 PM
shiranui shiranui is offline
Junior Member
 
Join Date: Nov 2011
Posts: 1
Default H340 new battery does not hold charge

Hi,
I am the owner of a H340 which I had left for more than a year in its box after it started giving me some problems with its battery. I don't even remember what it was in the first place but the result was that the device wasn't powering up on its own nor did it seem to charge at all.

So I decided to order a new 1700mAh battery off Ebay to replace the old one, a process I had done before in the past once again with success.
(At this point I should also mention that I have lost the charger and I either charge my device via USB or using the external battery pack.)
When the new battery was installed I went to charge it with the external battery pack and as long as the battery pack was on, the device was working as normal, powering up and playing music, everything was okay. And it also seemed that it was charging as I was getting the charging icon.

As soon as I take the external battery pack off, the device dies.
I even left it all night to charge, but still no luck. The new battery doesn't seem to hold any charge.
Any ideas?
Is it a faulty battery? Shall I try my luck with a new one? Any chance I might have damaged the battery slot on the board itself?

Any help would be really appreciated
Reply With Quote

Advertisement [Remove Advertisement]

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:54 PM.