android
  #1  
Old 10-26-2011, 05:40 PM
Vidur Vidur is offline
Junior Member
 
Join Date: Oct 2011
Posts: 1
Default Clip+ ; battery low message at 45% - can't turn on.

Hi all,

I got myself a Clip+ this last weekend. I charged it to 100% and have been listening to it since. Today, my battery was at 50% but, it suddenly died without notice, despite the battery showing 50%.

I tried turning it back on and I kept getting a 'battery low' message. I did manage to turn it on for about 30 seconds and the battery indicator was empty, say for a diagonal line going through it.

Anyways, I plugged it in just now and the device window says its at 45%. My firmware is up to date (1.02.16) and I haven't loaded anything but music onto it. I should note that up until I got the low battery message, I'd only used it for about 6 hours total.

SO - anyone have any ideas why my Clip+ is dying, despite the battery not even being close to dead? Any ideas on how to fix it? Thanks,
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 10-26-2011, 07:44 PM
WalkGood's Avatar
WalkGood WalkGood is offline
Moderator
 
Join Date: Aug 2006
Location: FL
Posts: 12,579
Default

No fix for a bad battery AFAIK other than replacing it. If you just got it, have it replaced.
__________________
WalkGood,
Ramón

abi >> | Forum Rules | Glossary | Why Rockbox | FLAC or MP3? | irc
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 02:59 PM.