android
  #1  
Old 06-23-2011, 08:34 PM
AGS Lover AGS Lover is offline
Junior Member
 
Join Date: Jun 2011
Posts: 4
Default Music is Invisible in Files (Rockbox)

Hi everyone,

I downloaded Rockbox a couple of weeks ago, and when I try to add mp3 files to it (booting into the regular firmware to do so) I can't see the files on Rockbox in the Files > Music > Music folder. If I go into the Database menu I can see the files, just not with the rest of them in Music.

I visited a similar thread, and tried to update my database, but Rockbox never asked me to reboot. Something about clicking database after it was updated and then Rockbox would ask me to reboot?

I also tried initializing the database first. (This is in Settings > General Settings > Database.)

Thanks for your help
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 06-23-2011, 09:05 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,603
Default

Double check that you added them in MSC mode.
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #3  
Old 06-23-2011, 10:07 PM
AGS Lover AGS Lover is offline
Junior Member
 
Join Date: Jun 2011
Posts: 4
Default

It is in MSC mode.
Reply With Quote

  #4  
Old 06-23-2011, 10:44 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,603
Default

So you see the file in MSC mode, but its not there on the file system outside of USB mode?
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #5  
Old 06-24-2011, 07:32 PM
AGS Lover AGS Lover is offline
Junior Member
 
Join Date: Jun 2011
Posts: 4
Default

I see them on the computer when I boot into the original firmware and connect. I see them on the Sansa's file system when I boot it into original firmware. But I do not see it in the Sansa's file system when I boot into Rockbox. My computer doesn't see the mp3 player when it's in Rockbox, so I can't tell you if it is visible then.

As far as I know the mp3 player is always in MSC mode (I have not changed anything).
Reply With Quote

  #6  
Old 06-24-2011, 08:04 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,201
Default

After a firmware installation, which is what installing Rockbox is, the Sansa OF reverts to Autodetect. Autodetect uses MTP transfer as the default. If you did not go into the settings and reset that to MSC before you transferred your files they were transferred in MTP mode. The Rockbox file browser can't see files transferred in MTP. They would show in the database though.

I've experienced what you describe and my solutions was to remove all the files and reload them after I set the USB mode to MSC. No more ghost files after that.
Reply With Quote

  #7  
Old 06-24-2011, 09:18 PM
AGS Lover AGS Lover is offline
Junior Member
 
Join Date: Jun 2011
Posts: 4
Default

I see it now, thanks everyone :-)

Oh and I'm really happy with Rockbox. Sound quality is quite a bit better. Thanks for making it! :-D
Reply With Quote

  #8  
Old 06-24-2011, 10:16 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,201
Default

Glad things are working out now but the sound quality is actually the same both in the OF and Rockbox. The parametric equalizer is much more useful than the one Sansa provides but that's pretty much it. I understand it's it's easy get think there's a difference but a lot of testing says there isn't.

Actually that's a good thing. The Clip+ puts out a very good signal in the OF. Rockbox doing the same is just more to enjoy without worrying if you're getting the best a good player can provide.
Reply With Quote

Reply

Tags
hidden, invisible, mp3, rockbox, sansa

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 09:25 AM.