android
Prev Previous Post   Next Post Next
  #1  
Old 05-05-2011, 05:56 AM
variation variation is offline
Junior Member
 
Join Date: May 2011
Posts: 5
Default Is my Sansa Clip+ 2GB dead and if so what killed it?

I've used my Sansa Clip+ 2GB (Firmware 01.02.15) almost every day since I bought it a year ago. Last night I went for a 1 hour walk and my Sansa Clip+ worked properly. At night before I fell asleep I was using it and it suddenly stopped working, the screen went blank, and the device became unresponsive. I connected it to my wall USB charger and it showed no signs of life.

This morning I connected it to my PC and the screen went on but it doesn't look right: where I am supposed to see the track title all I see are 6 squares, a percentage sign, and then some strange symbol. The device is still unresponsive - only the screen is on, even after I disconnected it from my PC - and it's also worth noting that my PC did not detect the device's memory cards.

What I want to know is whether this thing reached the end of its natural life given the amount of use I have given it or whether the Bytecc USB charger which I bought at the mall a week ago for $5 likely contributed to its death.

Should I just forget about this thing and buy a new clip+ (or something newer and better) and never use the USB wall charger again?
Reply With Quote

Advertisement [Remove Advertisement]

 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 09:54 AM.