android
Go Back   abi>>forums > General Audio > Headphones

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 03-28-2011, 02:25 PM
dv8tor dv8tor is offline
Junior Member
 
Join Date: Jul 2009
Posts: 19
Default Fake SoundMagic PL-30s or Factory Defect?

I just purchased these a few days ago, but I have some major issues.

While I initially thought there could be no way anyone would want to fake the SoundMagic PL-30s, I have reason to believe the package I purchased is fake. Since SoundMagic is already a Chinese (Shenzhen-local) company that offers affordable products, I was under the impression they were cheap enough to purchase that no one would bother replicating them. Either that, or my IEMs had a factory defect.

I know the PL-30s have different sorts of packaging. Doing a quick Google search for "SoundMagic PL30 box" will bring up 3 different packaging designs already.

However, I happened to get the one below. This is also the packaging from the Amazon UK website.

I was quite satisfied with the packaging and contents for such an affordable product.

However, my problems started occurring and are listed as follows:

1. Upon opening the packaging, I noticed there was no User Manual and most PL30 owners on forums actually got one. I would think they needed to put a manual for the bass knob settings. Even basic IEMs without much features have manuals.

2. Next, I saw un-boxing videos and reviews and everyone got a cable winder in their package. My box contained no cable winder.

3. Initially testing the IEMs, (of course a lot would argue that burning-in would be proper first), but in my first listen, these IEMs just sounded downright terrible. The sound was so tinny and very mono, not producing the solid sound I had from my Creative EP 630s and newly purchased Klipsch Image S4's. It was like I purchased disposable $5, no-branded headphones. It was so bad that it ruined the music on my D2+. Whatever music I played was just wrong. There seemed to be something missing with the drivers.

4. Moving on to further testing my new IEMs, I tried tinkering with the bass knob and it wouldn't move at all. It was like as if it were just firmly placed on the earphones to serve an aesthetic, design purpose. There are two small dots indicating the setting of the bass, but the knob is unmovable.

5. Trying different ways and measures of twisting the knob, I came to one option of actually unscrewing or loosening the knob (since there was no manual, I created my own options). Anyways, I successfully loosened the knob and was able to turn it. However, it loosened up a tad too much and broke right off. I can't even place the knob back into the socket.

From this experience, I have had two conclusions. First, these may truly be fake due to the missing items in the packaging, substandard quality, and awful sound. However, they also could be a bad batch of factory defective production units. SoundMagic actually has a European website but the PL30s are non-existent on the site. SoundMagic has a Chinese website which even Google can't translate so I don't know what the heck is going on.

Anyways, from this bad experience I've had with SoundMagic, I will probably never be purchasing another item from them again. I will return these to the store/person I purchased these from and demand a refund.

If any of you other PL-30 owners have experienced this, please share your insights. I also wanted to post this as a warning for anyone who wants to purchase anything from SoundMagic in the future.
Reply With Quote

Advertisement [Remove Advertisement]

 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:07 PM.