android
  #1  
Old 03-05-2011, 08:55 PM
DTHCND DTHCND is offline
Junior Member
 
Join Date: Mar 2011
Posts: 2
Help Load Main Image Failed...

Hey, I'm trying to fix my friend's SanDisk Sansa e280. When ever he turns it on it says,
Quote:
Load main image failed
Switch to Recovery mode
I have a feeling it has to do with corrupt firmware but am not sure, nor do I have any experience with a Sansa. If it is corrupt firmware, how do I reinstall the firmware on his Sansa? If not, any ideas?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 03-05-2011, 09:09 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,444
Default

I used to use the instructions here to recover my e2xx series players. Use the 1.02.18A firmware when you get to that part. The ones newer than that are very buggy.

I'm a fan of Rockbox as you can see from my sig. I got that way because I never had to fix a e2xx series player once it was Rockboxed. Once you are able to get your friends player fixed*crosses fingers* and make sure the hardware is sound I'd look into that.

Good Luck
Reply With Quote

  #3  
Old 03-06-2011, 09:51 AM
DTHCND DTHCND is offline
Junior Member
 
Join Date: Mar 2011
Posts: 2
Default

Thanks! Worked perfectly! I'll look into Rockbox now...
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:16 PM.