android
  #1  
Old 11-07-2010, 04:51 PM
MimiFL MimiFL is offline
Junior Member
 
Join Date: Nov 2010
Posts: 4
Unhappy MicroSD card recognized by SE, not by XP

Hi all.

I've been reading threads in this forum for a while, but so far haven't found an answer to my problem, so would appreciate any help.

I have a Sansa Express that I just bought a SanDisk 2GB card for. I was pretty excited, but find that XP doesn't see the card at all. When I connect the SE via USB, all I see is 2 drives (drives, not folders): one with my music, and the other with a handful of system files. There's no "internal memory" or "expansion card" (though I think when I connect it at work, I see "internal memory" but not 100% sure).

What can I do to make XP recognize this card? I checked settings in SE and it said there was 1909MB left on the card and the firmware is 01.01.05A2.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 11-09-2010, 07:45 AM
MimiFL MimiFL is offline
Junior Member
 
Join Date: Nov 2010
Posts: 4
Default

Just to clarify, on my work PC, it does in fact appear as "Sansa Express" with Internal Memory and Expansion Card under it. At home, it appears as a regular drive with just a music folder. The only difference that I can see is SP 2 at home vs SP 3 at work.

Any idea how to make my home PC recognize this thing as a media device rather than a drive? I can't risk upgrading my home PC to SP3 (last time I tried updating it with regular MS patches, it crashed and I had to reinstall Windows entirely - not doing that again!)

Thanks.
Reply With Quote

  #3  
Old 11-09-2010, 01:16 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,646
Default

It sounds like you're in MSC mode at home and MTP mode at work. I would probably just use MSC mode (MTP sucks), but if you really want it updating your WMP may fix it.
Reply With Quote

  #4  
Old 11-10-2010, 07:46 AM
MimiFL MimiFL is offline
Junior Member
 
Join Date: Nov 2010
Posts: 4
Default

Well, whichever mode I'm in at home (MSC then?) is preventing me from seeing the expansion card, which is a problem because I want to add music to it.

I have WMP 9, would upgrading to 10 help?
Reply With Quote

  #5  
Old 11-12-2010, 11:08 AM
user452 user452 is offline
Junior Member
 
Join Date: Apr 2010
Posts: 3
Default

Uninstalling WMP will help.

Quote:
When I connect the Sansa Express via USB, all I see is 2 drives (drives, not folders): one with my music, and the other with a handful of system files. There's no "internal memory" or "expansion card"
You do not have a problem.
The first drive IS the internal memory.
The second drive is the "expansion card"
If you like, you can rename the drives, it won't interfere with using the Sansa Express

Create a folder on the second drive called "music", and put your music in there. Just like you see on the first drive.

You don't need to use WMP, you don't need it "recognised as a media device", you just copy&paste/drag&drop with explorer and it just works.

The ability to install the Sansa Express as a USB drive is what makes it great.
MTP is the one of the worse ideas I have ever heard, ALL media devices should appear as USB mass storage devices.
Reply With Quote

  #6  
Old 11-13-2010, 09:06 PM
MimiFL MimiFL is offline
Junior Member
 
Join Date: Nov 2010
Posts: 4
Default

Thanks for the reply. Before posting, I actually tried that, I created a music folder on the second drive and dragged one track in there. It seemed to work so I unplugged the sansa from the computer, and it said 'building database' then something about updating the card, which was fine.

The problem was that it then shut itself down. I tried turning it on several times, and got the same thing, turns on, tells me it's updating the databases, then turns off right away. I had to plug it back in, delete the music folder, and now it works fine again, but my card is empty. I don't see how to drag music to the card and have the thing stay on for more than a second... As it stands right now, I can either leave the card empty or put stuff on it and then not be able to use the player at all... I'm at a loss. Any ideas?
Reply With Quote

Reply

Tags
2gb, card, expansion, microsd, xp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:23 AM.