android
  #1  
Old 06-18-2010, 01:18 AM
RicemanDan RicemanDan is offline
Junior Member
 
Join Date: Jun 2010
Posts: 3
Default YHA Linux PC wiped my X1060!

Hi guys

I've posted/read up/researched and nobody has been able to help me with an error with my Sony player. I'm away travelling and really need help to recover my media, esp backed up pictures of Australia.

Upon using a YHA Linux machine in NZ, my X decided to partially format itself and all my music, videos and pictures (5gb of Australia) are no longer accessible. Everytime the unit is disconnected from a PC I get:

The device was not formatted correctly, please re-format via settings.

Obviously I never wanted to format in the first place, but now trying to recover somehow. I was pointed towards active @ partition recovery, but it and others do not recognise USB/flash drives as drives. All hardware such as C, D, DVD drives and memory card readers appear, but not anything connected via USB. What the hell can I do? Not sure if the player or the PC is to blame, but I'm not impressed!! Thought this was the ultimate drag and drop player/external harddrive combo!

Really need some help.

Thanks
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 06-18-2010, 04:27 AM
Ascariss's Avatar
Ascariss Ascariss is offline
Member
 
Join Date: Nov 2007
Location: Poland
Posts: 434
Default

have you tried resetting the device?
__________________
-Ascariss - Sony Crew
Reply With Quote

  #3  
Old 06-18-2010, 04:54 AM
RicemanDan RicemanDan is offline
Junior Member
 
Join Date: Jun 2010
Posts: 3
Default

Yes, I did try that, but no luck.

The drive also still reads as 2.9/30.1gb free/spare as if the files are still there, just not visible when I use it
Reply With Quote

  #4  
Old 06-18-2010, 06:42 AM
Szadzik Szadzik is offline
Junior Member
 
Join Date: Dec 2009
Posts: 75
Default

Search for a method of connecting it as a USB device, it is doable and I posted a tutorial some time ago.

When you get it connected as a USB mass storage and not MTP device you can try troubleshooting.
__________________
Present Rig:
HP IQ830UK, SE X1, Nikon D90; HTX-22HD + SKS-11, Sony X1060, AKG K450, Sennheiser HD555, ATH-ESW9

Used in the past: Rio Carbon, Creative Zen Vision M, Sony NWZ-A818
Just-a-Photograppher's Website
Reply With Quote

  #5  
Old 06-18-2010, 09:28 AM
RicemanDan RicemanDan is offline
Junior Member
 
Join Date: Jun 2010
Posts: 3
Default

Ahhh, thank you! That's the direction I needed. You can turn it into a drive by turning off MTP (media transfer tool) and turning on USB mass storage, via right clicking "my computer"/manage and then updating the driver/select from a specific location (advanced) of the device (found in portable devices). Now it is recognised as a drive and able to be scanned! See link for details:

http://eugeneboon.com/hello-world/

Great, thank you very much!

Last edited by RicemanDan; 06-18-2010 at 10:42 AM.
Reply With Quote

  #6  
Old 06-18-2010, 01:40 PM
Szadzik Szadzik is offline
Junior Member
 
Join Date: Dec 2009
Posts: 75
Default

Quote:
Originally Posted by RicemanDan View Post
Ahhh, thank you! That's the direction I needed. You can turn it into a drive by turning off MTP (media transfer tool) and turning on USB mass storage, via right clicking "my computer"/manage and then updating the driver/select from a specific location (advanced) of the device (found in portable devices). Now it is recognised as a drive and able to be scanned! See link for details:

http://eugeneboon.com/hello-world/

Great, thank you very much!
You're welcome.
__________________
Present Rig:
HP IQ830UK, SE X1, Nikon D90; HTX-22HD + SKS-11, Sony X1060, AKG K450, Sennheiser HD555, ATH-ESW9

Used in the past: Rio Carbon, Creative Zen Vision M, Sony NWZ-A818
Just-a-Photograppher's Website
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:53 PM.