android
  #1  
Old 03-25-2015, 11:14 PM
cyclopsdreamer cyclopsdreamer is offline
Junior Member
 
Join Date: Mar 2015
Location: New Mexico
Posts: 1
Default Mobiblu 1gb cube player stopped working

I have four Mobiblu cube players. Two black ones stopped functioning after working for some time. They do not come when connected to power or PC. They show up only under my computer's device manager as unknown devices. When I connected one of them a message read "player device class." I do have the disk for the players but it doesn't seem to help. The pink one functions but with difficulty, that is the buttons don't always function properly.While it comes on it won't always play tracks. However, if I push buttons repeatedly , sometimes it will play. My newest one is orange and works wonderfully so far. Can anyone offer advice on repairs or where to look? Thank you
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 03-26-2015, 06:52 AM
The DarkSide's Avatar
The DarkSide The DarkSide is offline
Ultra Senior Member
 
Join Date: Feb 2008
Location: Qns Vlg, NYC
Posts: 16,145
Default

Time to buy a new player, or four. Sansa clipzip.
Reply With Quote

  #3  
Old 06-15-2015, 09:42 PM
DECODE DECODE is offline
Junior Member
 
Join Date: Jun 2015
Posts: 2
Default

Take them appart, clean them. reassemble. Format them under windows. Wish you luck!

Last edited by DECODE; 06-15-2015 at 10:05 PM.
Reply With Quote

Reply

Tags
mobile cube

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 03:34 AM.