android
Go Back   abi>>forums > MP3 Players By Brand > SanDisk Sansa > Sansa Clip / Clip+ / Clip Zip

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-15-2010, 06:08 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default New original Clip v1 & v2 firmware 01.01.35 & 02.01.35

Original info from http://forums.sandisk.com/sansa/boar...3379&jump=true
Quote:
Sansa Clip Firmware 01.01.35 & 02.01.35 Release Notes
Thisnew firmware has various bug fixes, including key fixes listed below, as wellas enhancements. Upon completion of the firmware upgrade, the device will turnoff. Power on the device to complete theupgrade process. If the device does notinitiate or complete, slide up & hold the Power switch for 10 seconds toreset the device and then release and slide up again to restart.


Enhancements:
o No new enhancements

Bugs Fixed:

o Portuguese display error in the language menu
o OGG files crashing while fast-forwarding across track boundaries
o OGG track caused Player crash
o Dropouts on high bitrate flac files
o Chirp at end of mp3 file
o Device can't play FLAC with Padding removed & 440hz toneisn't audible
o Volume is increased to the maximum when FF or RW key is pressedwith volume operation simultaneously
o Device hangs in sequential operations of FM resume and channelsearch
o French Language: Info section shows wrong translation for Power
o Some Polish & Brazilian languages are not translatecorrectly.
o Some WAV files cannot be played

Known Issues:
  • Popping noise when changing the speed of podcast
  • EQ spectrum moves slowly when playing OGG contents that are 16KHz or below
  • Device in ON state will not be recognized by PS3 console when connected
  • Repeated songs in playlist does not playback properly
  • Playlist referencing content in Audiobook folder does not work
  • Icon of the device doesn’t display after standby or hibernate
V1 firmware http://mp3support.sandisk.com/firmware/test/clipv1.zip
V2 firmware http://mp3support.sandisk.com/firmware/test/clipv2.zip
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 03-15-2010, 06:14 PM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Good thing v1 Clip owners don't have to worry about any of that anymore. But still nice seeing the old Clips getting a bit of love, even if that firmware seems a bit disappointing and unnecessary after such a long time (exactly one year after the last update).

EDIT: Added them to the sticky firmware thread. Thanks Marvin!
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #3  
Old 03-15-2010, 06:26 PM
ultrauber's Avatar
ultrauber ultrauber is offline
Senior Member
 
Join Date: Jun 2009
Posts: 516
Default

Wow, they're still getting updates! It doesn't look like they'll be adding features, though, just bugfixes. Fine by me, but lets get some e200 updates! :P
__________________
Cowon S9 32GB > HiFiMan RE0 (RIP) | Sansa Clip+ 16GB (Rockbox) > Soundmagic PL20
If you have problems, try MSC mode, then google.com
Reply With Quote

  #4  
Old 03-15-2010, 07:01 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

It's good to see they haven't "Viewed" the old Clip yet. Irrelevant to me, since my clips are long gone, but still nice to see.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #5  
Old 03-15-2010, 07:43 PM
epithetless's Avatar
epithetless epithetless is offline
Ultra Senior Member
 
Join Date: Jul 2007
Location: Boston, Mass
Posts: 1,609
Default

Quote:
Originally Posted by dfkt View Post
Good thing v1 Clip owners don't have to worry about any of that anymore.
Agreed. Thank god for Rockbox when SanDisk's support is so "meh."
__________________
Rockbox Themes:
Sansa Fuze: XL Fuzed // Sansa Clip/Clip+: Cliplined
Reply With Quote

  #6  
Old 03-15-2010, 07:50 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,142
Default

They seem to have put some effort into this one. My V2 Clip now has ReplayGain and the EQ seems much better. Looking and listening around for other goodies now.
Reply With Quote

  #7  
Old 03-15-2010, 07:55 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by skip252 View Post
They seem to have put some effort into this one. My V2 Clip now has ReplayGain and the EQ seems much better. Looking and listening around for other goodies now.
I didn't expect that.....that's good news!
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #8  
Old 03-15-2010, 08:00 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,142
Default

Wonder if they worked on the pitch bug? No way for me to tell. I never was able to hear it before.
Reply With Quote

  #9  
Old 03-15-2010, 08:08 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by skip252 View Post
Wonder if they worked on the pitch bug? No way for me to tell. I never was able to hear it before.
Me either.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #10  
Old 03-15-2010, 08:42 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,584
Default

Quote:
Originally Posted by skip252 View Post
Wonder if they worked on the pitch bug? No way for me to tell. I never was able to hear it before.
I think they basically said they were never going to do anything about it, so probably not.
Reply With Quote

  #11  
Old 03-15-2010, 09:14 PM
funman funman is offline
Rockbox Developer
 
Join Date: Jul 2008
Posts: 161
Default

damned still no folder browsing..

oh, well, I'll just keep using rockbox
Reply With Quote

  #12  
Old 03-16-2010, 05:11 AM
bYOndo bYOndo is offline
Junior Member
 
Join Date: Dec 2008
Posts: 10
Default

Quote:
Originally Posted by saratoga View Post
I think they basically said they were never going to do anything about it, so probably not.
Oh....ehm... I can't believed it... the pitch issue has disappeared!!!
I wait for some other comfirms, but it's not a placebo effect: on my clip v2 8gb, playing a 440hz test tone in one hear and a vibrating diapason in the other, I can't hear _any_ difference now!
Another thing that can confirm it, it's that I can play my chromatic harp, while reproducing some Aebersold "play along" jazz tunes and now my harp is not out of tune (with previous firmwares it was just unplayable), yay!

I can confirm also that now it has replaygain feature (finally!) and, this can be placebo, first eq. band is moved down in frequency a little bit (less "muddy" bass band).

Oh thank you Sansa! Now I can wait for Rockbox with less hurry

Massimo
Reply With Quote

  #13  
Old 03-16-2010, 05:29 AM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Quote:
Originally Posted by skip252 View Post
They seem to have put some effort into this one. My V2 Clip now has ReplayGain and the EQ seems much better. Looking and listening around for other goodies now.
That is very weird. Why wouldn't they mention those big enhancements in the changelog, when they decide to list every tiny bug I've never encountered? Either way, that's great, and probably worth upgrading for v2 owners, IMO.

EDIT: Just loaded this firmware onto one of my v1 Clips, and it doesn't have Replaygain. I do notice however that the firmware is copyright 2008...
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #14  
Old 03-16-2010, 06:33 AM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Quote:
Originally Posted by bYOndo View Post
the pitch issue has disappeared!!!
They indeed seemed to improve it - also on the v1 Clip (I have no v2 Clip to test). Measurements are more precise than on older firmwares.

On older firmwares a 1000Hz tone played at 1007Hz, now it plays at 1001.5Hz. That's even better than the Clip+ which plays at 1003Hz. Same goes for the 500Hz test tone, which was 503Hz earlier, now it's at 501Hz.



__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #15  
Old 03-16-2010, 07:06 AM
bYOndo bYOndo is offline
Junior Member
 
Join Date: Dec 2008
Posts: 10
Default

Quote:
Originally Posted by dfkt View Post
They indeed seemed to improve it - also on the v1 Clip (I have no v2 Clip to test). Measurements are more precise than on older firmwares.

On older firmwares a 1000Hz tone played at 1007Hz, now it plays at 1001.5Hz. That's even better than the Clip+ which plays at 1003Hz. Same goes for the 500Hz test tone, which was 503Hz earlier, now it's at 501Hz.
For music rehearsal applications, like mine, that's just enough. So I'm happy

Massimo
Reply With Quote

  #16  
Old 03-16-2010, 06:52 PM
Mikerman Mikerman is offline
Ultra Senior Member
 
Join Date: Dec 2007
Posts: 2,424
Default

Wow. Nice to see a revised firmware! Although while bugfixes are nice, it would have been nice to see some actual developments, such as folder browsing (yep, I know, that probably is a dead issue ...).

Having said that, and based on the above, wow: a pitch fix! Perhaps not commented upon by SanDisk, given all the earlier discussion and positions staked out, including by SanDisk.
Reply With Quote

  #17  
Old 03-18-2010, 08:19 AM
Mantel Mantel is offline
Junior Member
 
Join Date: Mar 2010
Posts: 1
Default

Is the volume limiter gone now? I can't find volume at all in settings. Running V02.01.35F.

Nice an loud before the update!

[edit]Nevermind, found it was set to Europe, once it's set to Rest of World the volume option is back again[/edit]

Last edited by Mantel; 03-18-2010 at 08:36 AM.
Reply With Quote

  #18  
Old 03-18-2010, 08:55 AM
WalkGood's Avatar
WalkGood WalkGood is offline
Moderator
 
Join Date: Aug 2006
Location: FL
Posts: 12,579
Default

Quote:
Originally Posted by Mantel View Post
Is the volume limiter gone now? I can't find volume at all in settings. Running V02.01.35F.

Nice an loud before the update!

[edit]Nevermind, found it was set to Europe, once it's set to Rest of World the volume option is back again[/edit]
heh, I was going to say but noticed your edit.
__________________
WalkGood,
Ramón

abi >> | Forum Rules | Glossary | Why Rockbox | FLAC or MP3? | irc
Reply With Quote

  #19  
Old 03-18-2010, 10:12 AM
ip8g_345 ip8g_345 is offline
Junior Member
 
Join Date: Dec 2007
Posts: 83
Default screen goes off much faster during the charging (no PC connection) ?

I am not sure about it, but it looks like the screen goes off much faster during the charging (from wall charger). I've plugged the upgarded clip to USB wall charger and, after 10-15 seconds, screen was dark. I recall that before upgrade it stays on for a long time and it was one of the items on wish list. Does anybody else experienced it or I it's an upgrade-induced hallucination ?

They didn't mentioned it in the list of fixes, but pitch improvements wasn't listed there either.

If it going like that I am afraid I'll see folder browsing capabilities soon
Reply With Quote

  #20  
Old 03-21-2010, 10:34 PM
comi comi is offline
Junior Member
 
Join Date: Aug 2008
Posts: 3
Default

Anyone, please recommend this update or go to Rockbox instead?
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:44 AM.