android
  #1  
Old 02-09-2010, 06:11 PM
SirDigger SirDigger is offline
Junior Member
 
Join Date: Jul 2009
Posts: 26
Default Put albums on the s9 (again)

Today i put an album on my s9 but i forgot to embed the album art, so i deleted it (on the s9, not on my desktop) and put it on the s9 again with the album art. but now it doesn't recognize a single song in the folder, you can only see the folder on the s9 when you use the browser but the folder itself seems empty. i tried it with another album without changing anything (i deleted it and put the same on on the s9 again) and it's just the same. i found out that it works if i rename every single song, but i don't want to put senseless letters in between the songs names if i can avoid it. Is there any possibility to put the albums on the s9 again with the same names?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 02-09-2010, 06:14 PM
dfkt's Avatar
dfkt dfkt is offline
Ultra Senior Member
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Are you using MTP mode?
Reply With Quote

  #3  
Old 02-09-2010, 06:22 PM
SirDigger SirDigger is offline
Junior Member
 
Join Date: Jul 2009
Posts: 26
Default

yes im using mtp. but i've always used and it worked ok. should i try msc?
Reply With Quote

  #4  
Old 02-09-2010, 06:23 PM
dfkt's Avatar
dfkt dfkt is offline
Ultra Senior Member
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

That sounds definitely like a typical MTP flaw, indeed. If you don't have any DRM crippled subscription music you probably won't need MTP anyways. MSC is superior in almost every aspect.
Reply With Quote

  #5  
Old 02-10-2010, 08:49 AM
SirDigger SirDigger is offline
Junior Member
 
Join Date: Jul 2009
Posts: 26
Default

it's the same issue with both. yesterday it deteced ONE song of an entire album for some reason i don't know, i renamed evry single song but only one was detected. Whats was gone once from the s9 will never be detected again it seems. But if i remove some mp3 without tags and put it on it again, the s9 detects it. now i removed all the tags from the songs i wanted to put on it and it doesnt work!! I tried to rename the folder, the songs remove the tags but it won't change anything.

Last edited by SirDigger; 02-10-2010 at 09:45 AM.
Reply With Quote

  #6  
Old 02-10-2010, 12:09 PM
meetooman's Avatar
meetooman meetooman is offline
Member
 
Join Date: Oct 2009
Posts: 488
Default

From what I understood of the MTP specifications I have a theory to explain your problem. But as I don't know your player I can't verify it.

Understand that the MTP protocol tries to make some intelligent transfers to the contrary of the dumb MSC protocol. So if you go against its logic, you will get troubles.

Every object in MTP has an unique ID. An album is an objet, association of music files with all their respectives IDs.

Let's take an example. Suppose you have an old good Pḧil Collins' album. Your player can have a Face Value.alb association (abstract file in MTP wording):

Phil Collins "Face Value" ID:20
-------------------------------
1 - In the air tonight (ID:100)
2 - This must be love (ID:101)
...
-------------------------------

You see the album created on the device has the ID 20, the tracks would have file ID 100 to 112 in the example.

If you erase the files and put some new they will not get the same IDs!

Imagine you could have then:
1 - In the air tonight (ID:113)
2 - This must be love (ID:114)
...


and still:
Phil Collins "Face Value" ID:20
-------------------------------
1 - In the air tonight (ID:100)(file not found)
2 - This must be love (ID:101)(file not found)
...
-------------------------------

Your album file can't list its files anymore. Even if the songs are all back to the player, the files with ID 100 to 112 are deleted. Your album is now empty!

That's the reason why MTP is not made for drag and drop unless your player is a foolproof self re-indexer (like my Sony E430).

Conclusion if I am right:

  1. Check if your player has an "Album" folder and if there is a file with the name of your album there (like Face Value.alb). It must be recreated, listing the right new files.
  2. Use a good media manager with your device.

I Hope I helped you.
Reply With Quote

  #7  
Old 02-10-2010, 12:16 PM
SirDigger SirDigger is offline
Junior Member
 
Join Date: Jul 2009
Posts: 26
Default

Thx for your replies. The current situation is as follows:I found at what I've been using all the time has in fact been msc, not mtp so sorry for that. I could always just drag and drop the files in the s9, tagged them with mp3 tag before with a cover and the artists, title etc. and it has alway worked. Now it seems i can 1. not get any taggin to work with any file (no artist shows up, no cover etc. no matter how often i delete or rename it and 2. not get any flac files to work anymore.

But now the strangest thing: When i try MTP, i can get the flacs to work again, but again i can't see covers and all the other tag parts are gibberish japanese or chinese signs...
Reply With Quote

  #8  
Old 02-10-2010, 12:29 PM
dfkt's Avatar
dfkt dfkt is offline
Ultra Senior Member
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Did you hit the reset button? It sometimes works wonders. Other, more drastic, measures would be formatting the player and/or reinstalling the firmware.
Reply With Quote

  #9  
Old 02-10-2010, 12:31 PM
SirDigger SirDigger is offline
Junior Member
 
Join Date: Jul 2009
Posts: 26
Default

i did all the things you mentioned multiple times. nothing changed
Reply With Quote

  #10  
Old 02-10-2010, 06:38 PM
meetooman's Avatar
meetooman meetooman is offline
Member
 
Join Date: Oct 2009
Posts: 488
Default

The only explanation left is the source music corruption... Something happens during your process.
Don't you have some old files with known working tags backed-up somewhere to check this out?
Reply With Quote

  #11  
Old 02-11-2010, 12:28 AM
SirDigger SirDigger is offline
Junior Member
 
Join Date: Jul 2009
Posts: 26
Default

i got all the music i ever had on the s9 in a folder and nothing flac-based works anymore, even if i remove all the tags from the files. flacs only show up when put on the s9 in mtp and as said, the tags are totally gibberish signs then and there's no cover as well.
Seems like i have to get a new one, let's see wether amazon sends me one.

EDIT: after another firmware downgrade attempt, it decided to brick itself now. no font. It's still detected by my pc and i can put firmware on it and access any folder and it will even upgrade the firmware but won't start anymore no matter how often i format it.

Last edited by SirDigger; 02-11-2010 at 11:05 AM.
Reply With Quote

  #12  
Old 02-14-2010, 07:29 PM
RoloJam RoloJam is offline
Member
 
Join Date: Jul 2009
Location: Katy TX
Posts: 172
Default

Just wondering?
Are the songs playable off the S9, from your computer?
If not, maybe there is something wrong with the cord?

Just guessing on this.
Reply With Quote

  #13  
Old 02-21-2010, 12:52 PM
Andreas67 Andreas67 is offline
Junior Member
 
Join Date: Aug 2009
Posts: 1
Default

Hello,

I have also a question about cover art.

I save all covers as tag in the file and use MTP to transfer the music.

When I use MediaMonkey all work fine. When I use Songbird the cover don't work. I think the problem is, that Songbird transfer no alb-file to the S9. Is there a way to show cover without alb-file when I use MTP. When I use MSC cover work without alb-file, but I want to use MTP.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:57 PM.