android
  #1  
Old 02-07-2010, 12:26 AM
doomlordis doomlordis is offline
Junior Member
 
Join Date: Mar 2008
Posts: 46
Default Downgrading firmware

My wife kindly upgraded my p7 to 1.40 , I don't use eq so I am having the jumpy sound issues.
I have read through the posts here and in other places and managed to unhide the system partition.
My problem is that my p7 is a p7k and I can't find a hex for that model , they are all p7u.
Can anyone help?
Oh I noticed that if you set the eq to user and don't change any levels you get the same sound as with the normal setting, only issue is that volume does not increase above 30- weird..
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 02-07-2010, 03:17 AM
Dennis Hawks Dennis Hawks is offline
Junior Member
 
Join Date: Apr 2008
Posts: 22
Default

Quote:
My problem is that my p7 is a p7k and I can't find a hex for that model , they are all p7u.
It's actually the same. So use the hex-file you found, like 1.37?
Quote:
I noticed that if you set the eq to user and don't change any levels you get the same sound as with the normal setting, only issue is that volume does not increase above 30- weird..
That's normal - by design.
You may follow these directions:
http://anythingbutipod.com/forum/sho...9&postcount=11
And, yes, use RKLDSET.FLW file -it works like a switch for (un)hiding the partition.
Reply With Quote

  #3  
Old 02-07-2010, 02:28 PM
doomlordis doomlordis is offline
Junior Member
 
Join Date: Mar 2008
Posts: 46
Default

So if I have this right, I open the second partition , put the new firmware folders there and the renamed hex file, disconnect and restart?

Will this scrub my data?
Reply With Quote

  #4  
Old 02-08-2010, 01:22 AM
Dennis Hawks Dennis Hawks is offline
Junior Member
 
Join Date: Apr 2008
Posts: 22
Default

Nope. you just open the hidden partition, delete those existing folders, put the new folders, if you downloaded them from my link. Disconnect and restart, do not forget to remove RKLDSET.FLW after that.
It should not scrub your data.
Reply With Quote

  #5  
Old 02-08-2010, 02:59 AM
doomlordis doomlordis is offline
Junior Member
 
Join Date: Mar 2008
Posts: 46
Default

Thanks for the help Dennis, I tried that before but i didnt delete the existing folders, i just overwrote them. This left the player very buggy, videos would be ok but selecting music would crash the player.
Maybe i needed to delete them all. Will try tonight.

Thanks again.
Reply With Quote

  #6  
Old 02-09-2010, 06:10 AM
doomlordis doomlordis is offline
Junior Member
 
Join Date: Mar 2008
Posts: 46
Default

Nope , simply replacing the files in the partition with the ones in your zip file leaves the player unusable, just reboots when you select music.
Reply With Quote

  #7  
Old 02-10-2010, 03:39 AM
Dennis Hawks Dennis Hawks is offline
Junior Member
 
Join Date: Apr 2008
Posts: 22
Default

1. You may need to rebuild the database.
Or
2. Download 1.37 from http://www.iriverplus.com/update/fir...10/eng/P7U.HEX
and extract it with http://files.myopera.com/Dennis_Hawk...unband_ENG.zip
and replace the folders on your hidden partition with the extracted ones. Or delete them first.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 03:12 PM.