android
  #1  
Old 08-02-2009, 03:26 PM
Rastus Rastus is offline
Junior Member
 
Join Date: Aug 2009
Posts: 2
Default Buttons Stopped Working - Nomad Jukebox Zen Xtra 60Gb

I've got a Nomad Jukebox Zen Xtra 60Gb.
All silver buttons have stopped working. The scroll button will toggle up and down but will not respond to being pushed in. All other aspects of the Zen work perfectly.
I tried pushing the reset button with a paper clip and also removing the battery. Neither helped.

Anyone know how to fix this.

Thanks,
Rastus
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 08-04-2009, 10:12 AM
Albinoni's Avatar
Albinoni Albinoni is offline
Member
 
Join Date: Feb 2009
Location: Perth, Western Australia
Posts: 182
Default

Have you tried recovery mode/reload OS.

To get into this press the Play/Pause button and at the same time push the reset with a paper clip and wait 5 secs.
Reply With Quote

  #3  
Old 08-04-2009, 10:40 AM
Rastus Rastus is offline
Junior Member
 
Join Date: Aug 2009
Posts: 2
Default

Thanks for your reply.

I tried this. But my play/pause button does not work. That's my problem. The silver buttons don't respond. It's bizarre.

I wish the whole unit had died. Having everything work perfectly except the buttons is a real teaser.
Reply With Quote

  #4  
Old 10-12-2009, 03:21 AM
hanasdaddy hanasdaddy is offline
Junior Member
 
Join Date: Oct 2009
Posts: 1
Default

I have exactly same problem. Did you ever solve it? I'm considering re-installing firmware, but I've heard a lot of horror stories from this. Don't know what to do.
Reply With Quote

Reply

Tags
60gb, jukebox, nomad, xtra, zen

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 02:51 PM.