android
  #21  
Old 04-24-2009, 09:52 AM
Llorean Llorean is offline
Rockbox Developer
 
Join Date: Dec 2006
Posts: 397
Default

And if you'd read the whole thread you'd have realized it not only was reported upstream, but is fixed upstream now.
Reply With Quote

Advertisement [Remove Advertisement]

  #22  
Old 04-24-2009, 09:57 AM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,586
Default

How does ubuntu development work? Will this be pushed down in an update or do I have to wait 6 months for the next release for a fix?
Reply With Quote

  #23  
Old 04-25-2009, 03:13 PM
jacko jacko is offline
Junior Member
 
Join Date: Mar 2009
Posts: 7
Default rockbox usb with Linux problem

I have been running rockbox on my e260R, and it is working great with windows. I have installed a copy of Ubuntu Linux and am dual booting for the moment..... I can boot my Sansa in rockbox and plug in the USB in windows and the SDHC is detected and works great for xfering files. When I am in Ubuntu and plug the Sansa into the usb, I get nothing if I have booted the sansa in rockbox (not recognized). If I have booted the Sansa in the sansa software the system will recognize it, but will not recognize my 4gig SDHC card.
Is there a way to allow the Sansa to boot into rockbox and have it recognized by Linux so that I can have access to my SD card from linux?
I know I can boot into windows to load the sd card with files, but it kind of a pain to reboot just to copy to the sansa player.
Does anyone have an answer to this dilema?

I read the above,,,,, and it seems there is no real solution for 9.04 as of yet, huh?
Maybe we'll get a fix for this soon.

Last edited by jacko; 04-25-2009 at 03:43 PM.
Reply With Quote

  #24  
Old 04-25-2009, 03:46 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,586
Default

Well its fixed in the latest gphoto apparently, so I bet checking out and compiling that source code would fix it.

Otherwise, theres the workaround in the first and second posts of this thread.
Reply With Quote

  #25  
Old 04-25-2009, 09:50 PM
kugel's Avatar
kugel kugel is offline
Rockbox Developer
 
Join Date: Dec 2006
Location: Berlin, Germany
Posts: 1,153
Default

Quote:
Originally Posted by saratoga View Post
How does ubuntu development work? Will this be pushed down in an update or do I have to wait 6 months for the next release for a fix?
I think small bug fixes and security updates get merged, but not major updates or new releases of a software.
__________________
;;
Reply With Quote

  #26  
Old 04-30-2009, 05:30 AM
Anthony M Anthony M is offline
Junior Member
 
Join Date: Jan 2008
Posts: 1
Default

I am also running 9.04 and cannot connect to to my rockboxed e260
Reply With Quote

  #27  
Old 04-30-2009, 02:13 PM
Llorean Llorean is offline
Rockbox Developer
 
Join Date: Dec 2006
Posts: 397
Default

As we've said already in the thread - this is a problem with 9.04. It's fixed in the upstream software, and Ubuntu just needs to choose to update the version they're using.
Reply With Quote

  #28  
Old 05-03-2009, 08:02 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,586
Default

Checking out the latest libgphoto source from scratch did fix the problem for me. I can mount my e200 nicely in ubuntu again.

For reference:

1) get the source:
svn checkout https://gphoto.svn.sourceforge.net/svnroot/gphoto/trunk sourcefolder

2) install dependencies:
libusb dev package, CVS and libtool via the package manager in ubuntu

3) i cd'ed into libgphoto2 and followed the directions in the INSTALL file:
autoreconf --install --symlink
./configure --prefix=/usr/local
make
sudo make install


Then plugged in my sansa and it worked normally.
Reply With Quote

  #29  
Old 05-04-2009, 02:42 PM
kugel's Avatar
kugel kugel is offline
Rockbox Developer
 
Join Date: Dec 2006
Location: Berlin, Germany
Posts: 1,153
Default

The gphoto related packages are updated since yesterday or so, I guess the bug is fixed.
__________________
;;
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 11:34 AM.