android
  #1  
Old 03-01-2009, 08:38 PM
miesnerd miesnerd is offline
Junior Member
 
Join Date: Mar 2009
Posts: 7
Default Rockbox Giveth (and Ubuntu 9.04 Taketh away)

Actually, I've tried it on both Ubuntu (9.04) and Arch linux. Cant get either to recognize or mount the device. Ultimate goal is to throw rockbox on there and play around. I was able to get it into (i think? Recovery Mode) and set it to show up as a 16 MB flash device on my desktop, but that doesnt do any good as far as getting rockbox on there. Any suggestions?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 03-01-2009, 10:25 PM
sansa dude's Avatar
sansa dude sansa dude is offline
Junior Member
 
Join Date: Jan 2009
Posts: 12
Default

9.04 is out?? try 8.10 ubuntu it is probably a more stable release and you got the 16mb recovery console up on your machine and if you messed around in there by deleting files and other stuff then you will need to re add the files again
Reply With Quote

  #3  
Old 03-01-2009, 10:30 PM
miesnerd miesnerd is offline
Junior Member
 
Join Date: Mar 2009
Posts: 7
Default

9.04 isnt out, but it is stable (imo). Im running alpha 5. I usually try to grab the 4th and 5th alphas so I can report bugs. Regardless of what exact version im running, I cant see a reason that the sansa isnt mounting. Plus, I tried it in Arch and it didnt work there, either.

Forgot to mention I didnt mess with any of the files. When I got the recovery 16 mb flash drive to show, i tried to get the rockbox program to detect it, but with no avail.
Reply With Quote

  #4  
Old 03-01-2009, 10:49 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,646
Default

Quote:
Originally Posted by miesnerd View Post
Forgot to mention I didnt mess with any of the files. When I got the recovery 16 mb flash drive to show, i tried to get the rockbox program to detect it, but with no avail.
You need to be in MSC mode, not recovery mode. Doing almost anything in recovery mode will brick your device, so I do not recommend using it unless you must.

The obvious question is why are you in recovery mode? Does your Sansa not boot?
Reply With Quote

  #5  
Old 03-01-2009, 10:56 PM
miesnerd miesnerd is offline
Junior Member
 
Join Date: Mar 2009
Posts: 7
Default

Quote:
Originally Posted by saratoga View Post
You need to be in MSC mode, not recovery mode. Doing almost anything in recovery mode will brick your device, so I do not recommend using it unless you must.

The obvious question is why are you in recovery mode? Does your Sansa not boot?
Hey my bad. Its been in MSC mode. I was trying out recovery mode just playing around, since I couldnt get it to mount.
Reply With Quote

  #6  
Old 03-01-2009, 11:12 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,646
Default

Are you sure its in MSC mode and not Auto or MTP modes?
Reply With Quote

  #7  
Old 03-01-2009, 11:13 PM
miesnerd miesnerd is offline
Junior Member
 
Join Date: Mar 2009
Posts: 7
Default

Quote:
Originally Posted by saratoga View Post
Are you sure its in MSC mode and not Auto or MTP modes?
yeah, im certain. I dont know if this is connected or not, but for a long time, its had a database refresh fail problem. To restart the thing takes forever, and I could care less about the songs on there. If there was a way to just reset the whole freaking thing, wipe everything and go from there, I'd be game.
Reply With Quote

  #8  
Old 03-01-2009, 11:16 PM
miesnerd miesnerd is offline
Junior Member
 
Join Date: Mar 2009
Posts: 7
Default

and btw, i just did lsusb and here's what you might want to know, next:
Bus 003 Device 013: ID 0781:7421 SanDisk Corp. Sansa E200 series
Reply With Quote

  #9  
Old 03-01-2009, 11:33 PM
miesnerd miesnerd is offline
Junior Member
 
Join Date: Mar 2009
Posts: 7
Default

Okay, in looking @ other threads, I saw where other people were reporting the relevant output of dmesg. With that in mind, here is what is related to the sansa on startup:

[ 11.022607] scsi 6:0:0:0: Direct-Access SanDisk Sansa e250 PQ: 0 ANSI: 0
[ 11.028602] scsi 6:0:0:1: Direct-Access SanDisk Sansa e250 PQ: 0 ANSI: 0
[ 11.037674] usb-storage: device scan complete
[ 11.042995] scsi 7:0:0:0: Direct-Access DMI Ultra Disk Drive 1.21 PQ: 0 ANSI: 0
[ 11.043062] sd 6:0:0:0: [sdb] 3926016 512-byte hardware sectors: (2.01 GB/1.87 GiB)
[ 11.048597] sd 6:0:0:0: [sdb] Write Protect is off
[ 11.048601] sd 6:0:0:0: [sdb] Mode Sense: 45 00 00 00
[ 11.048604] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 11.066602] sd 6:0:0:0: [sdb] 3926016 512-byte hardware sectors: (2.01 GB/1.87 GiB)
[ 11.075701] sd 6:0:0:0: [sdb] Write Protect is off
[ 11.075707] sd 6:0:0:0: [sdb] Mode Sense: 45 00 00 00
[ 11.075710] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 11.075716] sdb: sdb1 sdb2
[ 11.101162] sd 6:0:0:0: [sdb] Attached SCSI removable disk
[ 11.102127] sd 6:0:0:0: Attached scsi generic sg2 type 0
[ 11.110714] sd 6:0:0:1: [sdc] Attached SCSI removable disk
[ 11.110789] sd 6:0:0:1: Attached scsi generic sg3 type 0
[ 11.120604] sd 7:0:0:0: [sdd] 156301488 512-byte hardware sectors: (80.0 GB/74.5 GiB)
[ 11.128576] sd 7:0:0:0: [sdd] Write Protect is off
[ 11.128579] sd 7:0:0:0: [sdd] Mode Sense: 0b 00 00 08
[ 11.128582] sd 7:0:0:0: [sdd] Assuming drive cache: write through
[ 11.134577] sd 7:0:0:0: [sdd] 156301488 512-byte hardware sectors: (80.0 GB/74.5 GiB)
[ 11.142621] sd 7:0:0:0: [sdd] Write Protect is off
[ 11.142623] sd 7:0:0:0: [sdd] Mode Sense: 0b 00 00 08
[ 11.142625] sd 7:0:0:0: [sdd] Assuming drive cache: write through
[ 11.142629] sdd: sdd1 sdd2 < >
[ 11.164747] sd 7:0:0:0: [sdd] Attached SCSI disk
[ 11.164820] sd 7:0:0:0: Attached scsi generic sg4 type 0
Reply With Quote

  #10  
Old 03-11-2009, 04:11 AM
miesnerd miesnerd is offline
Junior Member
 
Join Date: Mar 2009
Posts: 7
Default

im back, bringing this thread back from the dead as well.
I used a dirty windows computer to get rockbox on my sansa e250.
But guess what? All my music is on an ext3 formatted drive, which is connected-- you guessed it- to my desktop running ubuntu. So now I have rockbox and ubuntu, and im still needing a way to connect them. Any thoughts now?

Thanks in advance for any help.

Miesnerd
Reply With Quote

  #11  
Old 03-11-2009, 11:29 AM
Llorean Llorean is offline
Rockbox Developer
 
Join Date: Dec 2006
Posts: 397
Default

As this problem only seems to have happened to two people running 9.04 so far, maybe try using an 8.10 LiveCD or some other non-Alpha distro.
Reply With Quote

  #12  
Old 03-12-2009, 12:25 PM
esoleyman esoleyman is offline
Junior Member
 
Join Date: Dec 2007
Posts: 1
Default

Trying backing up /usr/share/hal/fdi/preprobe/10osvendor/20-libgphoto2.fdi and removing any references to your Sansa player. If that does not work, then move the file out of the 10osvendor directory and try plugging in the Sansa again.


Reply With Quote

  #13  
Old 04-18-2009, 11:03 PM
TurboRegal TurboRegal is offline
Junior Member
 
Join Date: Dec 2007
Posts: 1
Default

Just updated to 9.04 RC and also am having the problem of the Sansa not being recognized. It does show up in lsusb as above...

Edit: but deleting the libphoto file listed above DID make it work. Will that have any adverse effects on other USB devices??

Last edited by TurboRegal; 04-18-2009 at 11:11 PM.
Reply With Quote

  #14  
Old 04-22-2009, 05:47 PM
HankB HankB is offline
Junior Member
 
Join Date: Jan 2007
Posts: 98
Default

Add me to the list. I'm running 9.04RC on a new Eee PC 901 and it won;t mount my e280 (either Rockbox or the OF) Everything else we have running 8.10 does just fine. I even ran a 9.04RC live CD on a Thinkpad T42 and it did not mount the Sansa. It works fine on 8.10.





Looks like a problem with 9.04.

-hank
Reply With Quote

  #15  
Old 04-23-2009, 10:14 AM
HankB HankB is offline
Junior Member
 
Join Date: Jan 2007
Posts: 98
Default Rockbox Giveth (and Jaunty Taketh away)

Rockbox supports USB!

The latest Ubuntu release - Jaunty Jackalope (AKA 9.04) - breaks USB support for the Sansa e2xx.

With either Rockbox or OF/MSC, Jaunty does not mount the Sansa. I had absolutely no difficulty with this with earlier versions and I have confirmed this on two computers.

I did find that the OF/MTP is mounted and I can copy files to it. However, the files do not show up in the Rockbox file list. If I plug the Sansa/Rockbox in to a PC running an older version of Ubuntu (which does mount the Sansa) I do see the new files. So I'm puzzled. Rockbox sees the files while in USB mode, but not in play mode. Is this perhaps a bug?

Anyway, there's a thread on this at the Ubuntu forums so if you can add further information, please do so. http://ubuntuforums.org/showthread.php?t=1133066 (Closed at the moment, but I hope to get it moved to an active forum)

Edit - there's a work around for this problem in this bug report: https://bugs.launchpad.net/ubuntu/+bug/345916

thanks,
hank

Last edited by HankB; 04-23-2009 at 01:50 PM.
Reply With Quote

  #16  
Old 04-23-2009, 03:21 PM
kugel's Avatar
kugel kugel is offline
Rockbox Developer
 
Join Date: Dec 2006
Location: Berlin, Germany
Posts: 1,153
Default

You can work around this by deactivating HAL temporarily (). You may need to manually mount the sansa then though.
Code:
sudo /etc/init.d/hal stop
Do do that, connect your sansa, and type
Code:
dmesg
The last lines will tell you under which device file the sansa was connected
(the lines will contain something like [sdb] or so).

Then do:
Code:
sudo mkdir /media/sansa # this step is only needed once
sudo mount /dev/sdb /media/sansa -t vfat -o user,rw #if you don't have access, try appending ",gid=1000,uid=1000"
(text after #are comments by me)
Then you can move files onto it. To eject/unmount use
Code:
sudo umount /media/sansa
If you use other devices, you may need to re-enable hal. To do so:
Code:
sudo /etc/init.d/hal start
Btw, this is certainly a libgphoto or gnome bug. It treats the Sansa as it was in MTP mode even if it is in MSC.
__________________
;;
Reply With Quote

  #17  
Old 04-23-2009, 04:11 PM
HankB HankB is offline
Junior Member
 
Join Date: Jan 2007
Posts: 98
Default

Hi Kugel,
Thanks for the tips. That sounds like a good solution for minimizing impact on the system, but it is a lot of work! (I'm a lazy bastage. )

I renamed the offending .fdi file (described in the bug report) and that also fixes the problem. I suppose I've screwed up something else with that file missing. I'll have to keep that in mind if I find something else that doesn't work. All of my cameras use SD cards which I just plug in directly (and they still work fine.)

(BTW, thanks again for your work with your custom Rockbox build. I used it until I found it closed down and then switched to the official build.)

thanks,
hank
Reply With Quote

  #18  
Old 04-23-2009, 08:09 PM
kugel's Avatar
kugel kugel is offline
Rockbox Developer
 
Join Date: Dec 2006
Location: Berlin, Germany
Posts: 1,153
Default

However, from what I've read, the thing with the fdi file only helps temporarily (ie stops working after some days). And it didn't work at all for me.

Anyway, according to http://gphoto.svn.sourceforge.net/vi...&pathrev=12026 it seems like the issue is fixed in the upstream (SVN) version of libgphoto. Now ubuntu needs to merge it into the package repos and we'll all be happy again.
__________________
;;
Reply With Quote

  #19  
Old 04-23-2009, 08:54 PM
HankB HankB is offline
Junior Member
 
Join Date: Jan 2007
Posts: 98
Default

Quote:
Originally Posted by kugel View Post
However, from what I've read, the thing with the fdi file only helps temporarily (ie stops working after some days). And it didn't work at all for me.
I can understand not working at all. Either something works or it doesn't for any number of reasons. Likewise I suppose that there must be something that caused the fix stop working after a while. Otherwise that's just plain weird.

Anyway, if push comes to shove, I have 8.10 installed on an SD card that I can boot my Eee PC from and which provides reliable access to my Sansa.

-hank

Last edited by HankB; 04-23-2009 at 08:57 PM. Reason: clearer description
Reply With Quote

  #20  
Old 04-24-2009, 10:02 AM
Tri Nguyen Tri Nguyen is offline
Junior Member
 
Join Date: Dec 2007
Posts: 9
Default

It is caused by gphoto AFAIK, the best way to fix it is to file a report upstream.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:29 AM.