android
  #1  
Old 03-29-2009, 03:49 PM
MihoshiMarie MihoshiMarie is offline
Junior Member
 
Join Date: Sep 2007
Posts: 8
Default Sansa c240 won't turn on

I have a refurbished Sansa c240. I haven't used it in a while. Yesterday I wanted to remove everything on it and start over, but it wouldn't turn on. So I connected it to the computer thinking that it needs to be recharged. After three hours I disconnected it to see if it would turn on. It did not. I hooked it back up and left it overnight. I just disconnected it from the computer and it still will not turn on.

The computer recognizes it and the screen turns on normally when it is hooked up, but the moment I disconnect it, it turns off and won't turn on again.

I really don't want to buy another battery.

I just threw it against a wall, picked it up and hit the power button. It turned on. I have it hooked up to the computer now. It's always been weird like that...I think I got a bad player.

Last edited by MihoshiMarie; 03-29-2009 at 04:00 PM.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 03-29-2009, 05:57 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,351
Default

Yep... That's how I fix all my electronic equipment. Bang it with the bigger hammer.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:23 PM.