android
Go Back   abi>>forums > MP3 Players By Brand > SanDisk Sansa > Sansa e200 > Sansa e200 Firmware

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-20-2009, 10:18 PM
Buttons Buttons is offline
Junior Member
 
Join Date: Mar 2009
Posts: 2
Default I deleted my partitions (including the 16mb for FW), but I fixed it.

MY PURPOSE is to share a few experiences and observations I had while attempting to fix my Sansa e250 or e250r - I never did figure that out. I doubt I will visit these forums again, so I hope to leave some positive influence in return for the help I have received. Hopefully my comments will help someone in the future.

First. Up until about 2 hours ago, I though the Sansa e200 was infallible as far as the storage or memory was concerned. "If I mess up, the ROM will fix it for me." I was WRONG! I was using Linux Ubuntu (something you'll soon be familiar with if your going to fallow my suggestions), and noticed a hidden and smaller 16mb partition on my Sansa. I'm quite fearless about these sorts of things, so I imediately deleted both partitions with the intent of recreating a single partition. There was an error, and my Sansa was bricked.

Now, my suggestions to any in a similar situation:

http://fixmysansa.blogspot.com/
This is the definitive guide on the subject. I want to thank barskir (a member of these very forums) for creating such an excelent guide.

My Sansa was blank; no partitions! When I would use the lock/select button trick to get it into repair mode, the e200tool wouldn't work, it couldn't find the device. When I just started it up plainly, it would work. This latter changed.

Once I had some firmware in place (although it was the wrong firmware, and wouldn't actually work) THEN I had to do the repair mode trick, because otherwise the Sansa would say "Locked, Restarting." Then it would restart, and I would hold the select button, then I could get into repair mode. Also, the step to press the REC button seems to simply be a method of overwriting the lock switch. When I would NOT press the REC swtich, the e200tool would start to work, and then the Sansa would say "Locked, Restarting."

THE MOST IMPORTANT THING I WOULD ADD TO THE GUIDE is to try out different firmware files. I visited http://daniel.haxx.se/sansa/mi4.html and tried various files from there.

The guide told me to use BL_SD_BOARDSUPPORTSD.ROM, but that did nothing for me. The blue ring on the Sansa would flash, but it was still dead, and inaccessible. Then I tried BL_SD_boardSupportSD.btl, which was next to e250r and my screen lit up and I could finally access the special 16mb partition. (NOTE: The 16mb partition just re-appeared on its own. Like magic.)

Then my Sansa would say "load main image failed switch to recovery mode" every time I tried to power up. So instead of using the pp5022.mi4 file that I download from the e250r link. (http://daniel.haxx.se/sansa/mi4.html) I tried the file from the e200 (American) link.

Then I started working.

In short, try different button sequences on the Sansa. Your first goal is to get the e200tool working. (It is working properly when it says "Execution Started!") Then start trying different "BL files" (again http://daniel.haxx.se/sansa/mi4.html). Once the screen lights up and does something or anything, then you should try different mi4 files until you find one that works with your Sansa.

As far as the http://daniel.haxx.se goes, I would advise not fallowing the guides there, as they are experimental at best. It's a great source for files though.

I know it's a long post, but again, I wanted to dump my experiences and hope it will help someone in the future. I also wanted to make it clear that is is possible to recover from a deleted partition. I ran accross people who deleted their 16mb partition using Windows Safe Mode, or using MacOS, and I hope to help these people too.

Thanks again to barskir and the rest.
Reply With Quote

Advertisement [Remove Advertisement]

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:24 AM.