android
  #1  
Old 03-13-2009, 03:10 PM
camiller camiller is offline
Junior Member
 
Join Date: Mar 2009
Posts: 1
Default Strange behavior

This is going to take a bit of explaining.

Preliminaries:
Sansa Express 1GB w/ Sandisk 8GB microSDHC card
Windows XP SP2 + individual security updates
WMP 11


I was transferring a several big chunks of an audiobook to my express to the 8GB expansion card(SanDisk brand) and about half way through the transfer fails and windows acts like the player was disconnected. So I unplug it from the USB, wait for it to boot, turn it off and plug it back in. Only the internal memory shows up, after several additional attempts, resets, etc. I decide the card is corupted. I try updating the firmware to 01.01.12A to see if it can read it, or at least format it, no luck.(Side rant, why can't this thing format the card ) Since windows won't see it in the express and I don't have another SDHC reader I have a buddy format the card in his phone (a blackberry) and now it is working again. Since the internal memory got wiped with the firmware upgrade I load some books on the internal memory.

Fast forward a couple days, I plug the Express back into the computer and navigate to the folder where my audio books are. I keep different books in different folders within a "Audiobooks" folder. I go to folder "X", but I see the files that should be in folder "Y". OK I think, perhaps I was a little sloppy and put them in the wrong folders so I go to "Y" and see the same files. I know I did not transfer the same books twice. I especially know I did not create the same playlist twice! I dig arround in the file structure but can't find the files that should be in "X" anywhere. I know they are there because they play just fine but for some reason windows can't see them. Which of course means I can't delete them either. So I format the internal memory via the Expresses settings menu and start loading up data and again I get to a point where two different folders look like they are pointing to the same set of files.

Since the new odd behavior has mostly only shown up on the internal memory I am suspecting the 01-01-12A firmware is a bit buggy. Is it possible to downgrade? is there a location to aquire the old firmware?

Thanks
Reply With Quote

Advertisement [Remove Advertisement]

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 02:14 PM.