android
  #1  
Old 01-30-2009, 11:59 PM
DaftMike DaftMike is offline
Junior Member
 
Join Date: Jan 2009
Posts: 5
Default Rockbox wont install on e260

Hey guys Im having a really annoying problem

Im trying to install Rockbox on my Sansa e260 and after I do the automatic install and boot up my Sansa I get the error

Can't load rockbox.mi4
File not found
Can't load rockbox.e200
File not found

I dont have a v2, and Ive already downgraded the firmware to see if that would help but it doesnt.

Any suggestions?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 01-31-2009, 12:06 AM
advcomp2019's Avatar
advcomp2019 advcomp2019 is offline
Ultra Senior Member
 
Join Date: Jun 2007
Posts: 4,838
Default

Did you put the .rockbox folder in the right area? Did you use MSC mode? did you use the Rockbox Utility?
__________________
Please don't PM me with questions that can be answered in a forum thread.
Headphones: JVC FX66B
Main Players: 4GB Sansa Clip+, 8GB Sansa Fuze, Sansa e280R with Rockbox
Backup Players: 8GB Sansa View, 2GB Sansa Clip
Reply With Quote

  #3  
Old 01-31-2009, 12:09 AM
DaftMike DaftMike is offline
Junior Member
 
Join Date: Jan 2009
Posts: 5
Default

I put it in MSC and I used the Rockbox Utility to automatically install it.
Reply With Quote

  #4  
Old 01-31-2009, 12:13 AM
advcomp2019's Avatar
advcomp2019 advcomp2019 is offline
Ultra Senior Member
 
Join Date: Jun 2007
Posts: 4,838
Default

Then it should work.

Do the ultimate fix and try it again please?
__________________
Please don't PM me with questions that can be answered in a forum thread.
Headphones: JVC FX66B
Main Players: 4GB Sansa Clip+, 8GB Sansa Fuze, Sansa e280R with Rockbox
Backup Players: 8GB Sansa View, 2GB Sansa Clip
Reply With Quote

  #5  
Old 01-31-2009, 12:32 AM
DaftMike DaftMike is offline
Junior Member
 
Join Date: Jan 2009
Posts: 5
Default

If the Ultimate Fix is the one where you put it in recovery mode and reinstall the original firmware, Ive done that several times.

If not, can you link me to it?

also, when I am automatically installing it, the drive dissapears from my finder window
Reply With Quote

  #6  
Old 01-31-2009, 12:36 AM
advcomp2019's Avatar
advcomp2019 advcomp2019 is offline
Ultra Senior Member
 
Join Date: Jun 2007
Posts: 4,838
Default

Yes, that is the one. It should work since it works on other peoples.

What OS do you have?
__________________
Please don't PM me with questions that can be answered in a forum thread.
Headphones: JVC FX66B
Main Players: 4GB Sansa Clip+, 8GB Sansa Fuze, Sansa e280R with Rockbox
Backup Players: 8GB Sansa View, 2GB Sansa Clip
Reply With Quote

  #7  
Old 01-31-2009, 01:51 AM
DaftMike DaftMike is offline
Junior Member
 
Join Date: Jan 2009
Posts: 5
Default

Quote:
Originally Posted by advcomp2019 View Post
Yes, that is the one. It should work since it works on other peoples.

What OS do you have?
OSX 10.5.5

Does it have something to do with the fact that my Sansa, for some reason, says "Writing" even if it isnt?
Reply With Quote

  #8  
Old 01-31-2009, 02:53 AM
advcomp2019's Avatar
advcomp2019 advcomp2019 is offline
Ultra Senior Member
 
Join Date: Jun 2007
Posts: 4,838
Default

Nope, that is a known bug with the e200 firmware.

I am not sure what is going on myself.
__________________
Please don't PM me with questions that can be answered in a forum thread.
Headphones: JVC FX66B
Main Players: 4GB Sansa Clip+, 8GB Sansa Fuze, Sansa e280R with Rockbox
Backup Players: 8GB Sansa View, 2GB Sansa Clip
Reply With Quote

  #9  
Old 01-31-2009, 11:53 AM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,617
Default

I think theres some bug with installing from OSX:

"(os x) Complete / Small Install is not working correctly for Sansa / Apple players: bootloader installation unmounts the player (required), but the build gets installed before the system can remount the player. You need to use the separate installs from the "Installation" tab for now."

(From the rbutil page)

Sounds like you just need to separately install the bootloader and rockbox until that bug is fixed.
Reply With Quote

  #10  
Old 02-01-2009, 07:42 PM
DaftMike DaftMike is offline
Junior Member
 
Join Date: Jan 2009
Posts: 5
Default

Fixed it!

Saratoga was right

But, you must make sure to download the bootloader second, and Rockbox first.
Reply With Quote

  #11  
Old 02-03-2009, 11:56 AM
gebal's Avatar
gebal gebal is offline
Senior Member
 
Join Date: Sep 2007
Location: Near Liverpool, UK
Posts: 604
Default

I'm being faced by the same problem (in that I cant load rockbox onto my e260), except mine is that I 'cant get permission to install the bootloader'. running vista
any help?
Reply With Quote

  #12  
Old 02-03-2009, 03:17 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,617
Default

Quote:
Originally Posted by gebal View Post
I'm being faced by the same problem (in that I cant load rockbox onto my e260), except mine is that I 'cant get permission to install the bootloader'. running vista
any help?
So basically a completely unrelated problem. Random guess: run as administrator.
Reply With Quote

  #13  
Old 02-25-2009, 08:37 AM
Mattah127 Mattah127 is offline
Junior Member
 
Join Date: Feb 2009
Posts: 1
Default

I have the same problem . I have a sansa e280 and everytime I followed directions to in stall he rockbox a message come up saying:"Don't detect sansa". I even made sure I had it in the right drive. "Auto detect". It still doesnt recognize the the sansa. Can you send me specific...specific directions on how to do this. I even tried to follow directions from people on youtube...but doesnt work. What could I be doing wrong?
Reply With Quote

  #14  
Old 02-25-2009, 09:21 AM
sansaguy's Avatar
sansaguy sansaguy is offline
Senior Member
 
Join Date: Jan 2008
Location: Canada
Posts: 675
Default

Quote:
Originally Posted by Mattah127 View Post
I have the same problem . I have a sansa e280 and everytime I followed directions to in stall he rockbox a message come up saying:"Don't detect sansa". I even made sure I had it in the right drive. "Auto detect". It still doesnt recognize the the sansa. Can you send me specific...specific directions on how to do this. I even tried to follow directions from people on youtube...but doesnt work. What could I be doing wrong?
put the player in MSC mode and do a manual install ...(download build from Rockbox.org, unzip to the root dir of your players drive (ex: D:\), then download and install the bootloader (Sansapatcher). Disconnect the player from computer and if everything is done correctly it should then boot into Rockbox.
__________________
How I Roll:
Sansa e250v1 Rockboxed refurb
16GB microSDHC
Sansa e260v1 Rockboxed 8GB microsdhc
Sansa Fuze 8GB 16GB microSDHC
Reply With Quote

  #15  
Old 02-28-2009, 01:44 PM
steinburger1109's Avatar
steinburger1109 steinburger1109 is offline
Ultra Senior Member
 
Join Date: Feb 2009
Location: Naperville, Illinois
Posts: 2,456
Default

i'm having the same problem, but i haven't tried downgrading the sansa firmware. how could i find the files for the earlier firmware?
Reply With Quote

  #16  
Old 02-28-2009, 02:06 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,617
Default

Quote:
Originally Posted by steinburger1109 View Post
i'm having the same problem, but i haven't tried downgrading the sansa firmware. how could i find the files for the earlier firmware?
I don't think changing firmware versions will help. The only thing the firmware actually has to do is have MSC mode, and I think all e200v1 firmwares have that. Otherwise the firmware is irrelevant to the install process.
Reply With Quote

  #17  
Old 02-28-2009, 06:11 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,617
Default

Theres an updated installer here that you could try as well:

http://forums.rockbox.org/index.php?...seen#msg145712
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:24 PM.