android
  #481  
Old 11-19-2009, 03:53 PM
bonchien bonchien is offline
Junior Member
 
Join Date: Nov 2009
Posts: 1
Default

I installed the newest rockbox buffering playback v2.7 on my Clip today following TedB's instructions in post #434 (http://www.anythingbutipod.com/forum/showpost.php?p=405919&postcount=434). It seems to be working very well. No crashes. The only issue I've found is that I cannot stop playback on some audio files and I have to shut off the player. I can pause them, but can't stop them at times. The problem seems intermittent. I'm not sure if it's the rockbox port, the switch on the Clip or user error.

p.s. Thanks for all the development work. This is great being able to bookmark stopping points in audio book files.

Last edited by bonchien; 11-19-2009 at 05:19 PM. Reason: clarifying
Reply With Quote

Advertisement [Remove Advertisement]

  #482  
Old 11-20-2009, 09:35 AM
ytsejam1138's Avatar
ytsejam1138 ytsejam1138 is offline
Junior Member
 
Join Date: Oct 2008
Location: Orlando, FL
Posts: 22
Default

Quote:
Originally Posted by saratoga View Post
Hopefully last version of the patch before we release for the Clip V1:

http://duke.edu/~mgg6/rockbox/buffering_playback_v2.7z
I'm still having the problem with the FM radio locking up as soon as I click on it. I'm using the above .rockbox and the latest bootloader that dfkt has posted: r23321-091023-1.1.32a-dual_boot.zip
Reply With Quote

  #483  
Old 11-20-2009, 10:17 AM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,608
Default

Quote:
Originally Posted by ytsejam1138 View Post
I'm still having the problem with the FM radio locking up as soon as I click on it. I'm using the above .rockbox and the latest bootloader that dfkt has posted: r23321-091023-1.1.32a-dual_boot.zip
This patch doesn't change anything about the radio, it fixes deadlocks during audio playback.
Reply With Quote

  #484  
Old 11-21-2009, 11:13 AM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,608
Default

Patch is committed and the clip becomes supported whenever the website gets refreshed.
Reply With Quote

  #485  
Old 11-21-2009, 03:25 PM
Kenaneu Kenaneu is offline
Member
 
Join Date: Aug 2007
Posts: 124
Default

Very, very awesome!

Reply With Quote

  #486  
Old 11-21-2009, 05:45 PM
epithetless's Avatar
epithetless epithetless is offline
Ultra Senior Member
 
Join Date: Jul 2007
Location: Boston, Mass
Posts: 1,610
Default

Quote:
Originally Posted by saratoga View Post
Patch is committed and the clip becomes supported whenever the website gets refreshed.
Sweet! Thanks for all your hard work!
__________________
Rockbox Themes:
Sansa Fuze: XL Fuzed // Sansa Clip/Clip+: Cliplined
Reply With Quote

  #487  
Old 11-21-2009, 07:34 PM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Saratoga, I'm going insane... I've gotten my old 1GB Clip out - for testing if it suffers from the same data abort and undefined instructions errors as my current 2GB Clip. Needless to say, this one is working perfectly fine with your newest build.

I've formatted my 2GB Clip the same way as the old 1GB one, put the same audio files in the same folders on both, used the same bootloader on both, and used both with default settings (no .cfg, no WPS). - The 1GB works fine, the 2GB crashes.

The thing is, the 2GB one works fine with your older logging builds, or any SVN build before them. It just won't work with any newer build, be it yours or from SVN. Do you have any ideas?
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #488  
Old 11-21-2009, 08:01 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,608
Default

You could do a binary search for the SVN version that breaks playback on your 2GB clip. That might give some clues about whats going wrong.

The v2 logging build is r22873, while the first build you said didn't work was r23293. That'd be no more then 9 iterations to find the exact version that broke playback for you.

Although if I had to guess I'd say r23001 or r23088 are the most obvious clip related changes in between those two builds.
Reply With Quote

  #489  
Old 11-21-2009, 08:07 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,608
Default

Actually if its a disk driver issue, maybe I can save you some time:

http://duke.edu/~mgg6/rockbox/clip_with_test_disk.7z

This build should have the test disk plugin enabled. You could run it for a while and see if you get disk errors.
Reply With Quote

  #490  
Old 11-22-2009, 06:15 AM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Thanks for that build, Saratoga. It also crashes within seconds during playback. Same data aborts at around 3020F4D4, or a black screen and reboot. What does this mean - in what way is my 2GB Clip broken?
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #491  
Old 11-22-2009, 10:45 AM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,608
Default

Playback won't work on that build either, but can you run the test_disk plugin?
Reply With Quote

  #492  
Old 11-22-2009, 11:15 AM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Oh of course, plugin means plugin - sorry for the confusion.

I ran both tests of the test_disk plugin twice, all passes went well.

EDIT: Ran both tests a few more times. All seems fine, no errors.
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #493  
Old 11-22-2009, 01:36 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,608
Default

Then I'm not really sure. I guess your best bet is to try a binary search of rockbox versions until you find the one that broke playback.
Reply With Quote

  #494  
Old 11-22-2009, 01:40 PM
WalkGood's Avatar
WalkGood WalkGood is offline
Moderator
 
Join Date: Aug 2006
Location: FL
Posts: 12,579
Default

saratoga,

FYI as I said in earlier post, the new build works fine on my 1gb, but tested on #1's 2gb and after the rockbox logo screen his froze immediately, which is strange as the older build worked fine. Tried twice and but he had to run, so I'll try it again later. Or let us know if you guys find out anything, thanks.
__________________
WalkGood,
Ramón

abi >> | Forum Rules | Glossary | Why Rockbox | FLAC or MP3? | irc
Reply With Quote

  #495  
Old 11-22-2009, 01:44 PM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Quote:
Originally Posted by saratoga View Post
Then I'm not really sure. I guess your best bet is to try a binary search of rockbox versions until you find the one that broke playback.
I was afraid of that... did that whole tedious shtick already once. Ah well, I'll be back with more info.
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #496  
Old 11-22-2009, 01:59 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,608
Default

dfkt:

funman apparently found another bug that I can't get to happen on my player, so they'll be more fixes coming. I'm not sure if its related to the problems reported here. If you're busy this week you could wait a couple days and see if newer versions work any better.
Reply With Quote

  #497  
Old 11-23-2009, 02:39 PM
atarilynx atarilynx is offline
Junior Member
 
Join Date: May 2009
Posts: 3
Default

Thanks for all your hard work on this. My 4Gb clip really loves the latest build, Saratoga. I played using that build until my battery ran down...something that never happened with previous ones.

THANKS!
Reply With Quote

  #498  
Old 11-23-2009, 03:44 PM
creep creep is offline
Junior Member
 
Join Date: Aug 2009
Location: Paper Street
Posts: 22
Default

It seems like I'm really lucky with build r23293M-091024. This one works almost flawless for me, I had no crash in days, heck, even weeks! Guys, this is so awesome. This tiny device with such a great sound, Replay Gain, scrobbling and so much more... Damn, just pure awesomeness! Thanks for this fine software!

There's just one thing that makes me curious. Depending on use I switch the music on my device between relatively high bitrate files for quiet environments and "lousy" encoded ogg files (q-1.0) for "casual muzak for the subway". Well, with the Rockbox firmware I can't use this Vorbis present and I'd like to know why. Is there a way to play back (very) low bitrate Vorbis or does Rockbox just not decode them bacause this is not implemented?

Well, still one thing I have on mind: THUMBS UP!
Reply With Quote

  #499  
Old 11-23-2009, 04:31 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,608
Default

Vorbis decoding works fine on the clip, though you should update to a build with less broken playback on the clip.
Reply With Quote

  #500  
Old 11-24-2009, 12:57 PM
funman funman is offline
Rockbox Developer
 
Join Date: Jul 2008
Posts: 161
Default

Last builds still cause problems, and the patch that was aimed at solving them still doesn't work (tested on c200v2 which crashes much more than Clipv1), so stable release still isn't for tomorrow.

Sorry folks, I hope some of you can enjoy a bit of stable playback anyway
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 10:55 AM.