android
  #41  
Old 01-20-2007, 04:58 PM
RwO RwO is offline
Junior Member
 
Join Date: Jan 2007
Location: Romania
Posts: 2
Default

Got the same problem, cause I didn`t bother to read the ENTIRE topic, only the first couple of posts . Fortunately for me, I`m still able to return my m240 to the store, and they should replace it with another one, cause it`s been less then 24 hours since I bought it.
Guess, no more firmware upgrades for me
Reply With Quote

Advertisement [Remove Advertisement]

  #42  
Old 02-02-2007, 08:09 PM
willmans willmans is offline
Junior Member
 
Join Date: Feb 2007
Posts: 11
Default

I had the 2.2.3E firmware on a m240 but somehow it screwed up when I tried the hack. First I edited the system file, then I launched the updater and updated but after it said complete, the player restarted and the last song played showed on the display... So I browsed to it and saw a sansam200.rom file in root. I checked for a fm radio option in the menu but I found none. So I opened the system file again, and it was saying 2.2.3E!! I edited and tried updating again but the updater ended with an error saying something about visualbasic runtime. OK? Nothing happened with the player so I unplugged the usb cable and then it went dead. Now it wont even power up, and windows doesn't recognize it. So what might have caused this? I think it was the Sansa Auto Updater that I had running in the background all the time that screwed it, because I read here that it changes the version in the system file. That must be why it didn't update with the rom file that was put there by the other program, sdmx3-iv001.exe. Fortunately I still have warranty left so i will exchange it for a new one. I just hope I get one with 2.2.3E so i can hack it the proper way WITHOUT the sansa auto updater running (if now that was causing the problem)... Anyone with similar experiences?
Reply With Quote

  #43  
Old 02-24-2007, 09:08 AM
natural natural is offline
Junior Member
 
Join Date: Feb 2007
Location: Kiev, Ukraine
Posts: 2
Default

hi all
in the neighbor topic Bong said that:
"The firmware version numbering can be decoded like this: h.n.nx where 'h' is the hardware revision (1, 2 or 3), 'n.n' is the firmware version, and x is the market it's made for (A for Americas, E for Europe and P for Asia)"
and I think it's true because the FirmWares takes from different directories.
just take a look at the adress, where FWs download from, and everything will get obviously.
Code:
http://ca1.storage.flashcp.com/sansa2/Firmware/M200/4/A/PACKAGE/
so, now it gets clear why those who changed first digit in the "firmware version" made damage to their players.
maybe someone, who has one of new hardware revision players will try to change the real firmware version.

+ I have one problem: there is no 'SYS_CONF.DNC' on my player in MSC mode.
there is 'version.sdk' which contain:
Code:
#DO NOT EDIT OR REMOVE THIS FILE

Product: m2X0
FW: V4.1.08E
Region: Americas
PS: sorry about my english
Reply With Quote

  #44  
Old 03-28-2007, 02:32 PM
MPTHREE MPTHREE is offline
Junior Member
 
Join Date: Mar 2007
Posts: 2
Default

Thanks,
worked well for me with the v2 hardware. Had a few scares along the way after running the firmware update download; maybe I didn't give it enough time to restart :/ but it sorted itself out eventually.
I then went on to upgrade the firmware using the usual updater and applied the font fix mentioned in the other thread and everything is now working well!

First impressions of the FM radio are that it works pretty well for a small portable device.

Thanks again for the info!
Reply With Quote

  #45  
Old 04-19-2007, 10:46 AM
Kyriarxos Kyriarxos is offline
Junior Member
 
Join Date: Apr 2007
Posts: 2
Cool Success on m250 with 2.2.3E

Hi to all,

Another succesfully activated FM on m250 with 2.2.3E firmware version, only by [-!-exactly-!-] following the steps mentioned above !! Just can't update to 2.2.5A, but not really an issue...

Many thanks,

This forum rules !!!
Reply With Quote

  #46  
Old 04-20-2007, 06:56 AM
jelleoelle jelleoelle is offline
Junior Member
 
Join Date: Apr 2007
Posts: 1
Default

For the people who wrecket their players, try out is there might be a recovery mode for the mp3 player.

On my Sansa E130 I had to update from firmware 1.xxx to 2.xxx, since it makes it boot faster, and to do that you had to boot the player into recovery mode, after wich the updater would let you put whatever firmware on it.

The method on that player to do that was the following (from http://www.livedigitally.com/?p=277 ):
Quote:
Simply with device turned off, push and hold menu button and plug in the USB cord while still holding the menu button pushed. After a few seconds (5-15) the computer says that found a device in recovery mode.
For your computer to use the recovery mode you might have to install a specific usb driver. For that this might help (from same link as above):
Quote:
The key is to get the SigmaTel STMP3500 recovery mode driver installed. (I got mine from the mass storage drivers install of Creative’s Muvo TX FM’s support page, which apparently uses the same main processor).
Again from the same url, if your player won't even start up, try this:
Quote:
Remove the battery for 5 min, after this time is up, hold the power button for 10 sec. Hook the sandisk to your computer without the batter. Regardless of the result, remove it and put a ‘new battery’ in. It should work now.
This problem can be related to a dead batter, which causes one of capacitors to disregard the battery change. Therefore, the power-cycle above is needed to get it to work again.
Maybe some of these steps could be used to revive your players.
Reply With Quote

  #47  
Old 05-02-2007, 12:50 PM
delirium22 delirium22 is offline
Junior Member
 
Join Date: May 2007
Posts: 1
Default

Just got my M250 (4.X.X), updated it to V4.1.08E with the Sandisk updater.

Changed my version.sdk to:

Code:
#DO NOT EDIT OR REMOVE THIS FILE
Product: m2X0
FW: V4.0.45A
Region: Americas
Rebooted M250 and ran updater again, it told me it found an update for my device. Update without a problem and FM is working now, haven't found any bugs...
Reply With Quote

  #48  
Old 05-10-2007, 10:20 AM
GrimReaper GrimReaper is offline
Junior Member
 
Join Date: May 2007
Posts: 12
Default

Didn't work on my Sansa m240 V4.1.08E.
Now I have V4.1.08A, I have FM radio in main menu, but there is no sound.
Reply With Quote

  #49  
Old 05-20-2007, 03:29 AM
NicoBakker NicoBakker is offline
Junior Member
 
Join Date: May 2007
Posts: 1
Question updater crashed

Quote:
Originally Posted by delirium22 View Post
Just got my M250 (4.X.X), updated it to V4.1.08E with the Sandisk updater.

Changed my version.sdk to:

Code:
#DO NOT EDIT OR REMOVE THIS FILE
Product: m2X0
FW: V4.0.45A
Region: Americas
Rebooted M250 and ran updater again, it told me it found an update for my device. Update without a problem and FM is working now, haven't found any bugs...

I tryed to do this on my player. The FW was V4.0.44E when i bought it.
I updated to V4.1.08E - no problem, changed the text in notepad to V4.0.45A

The updater told me it found a new update, but crashed when trying to update. The firmware was not changed in player.

what is wrong ?

Jerry
Reply With Quote

  #50  
Old 05-25-2007, 03:17 PM
htguy htguy is offline
Junior Member
 
Join Date: May 2007
Posts: 30
Default

I just bought an m230 original firmware 4.0.44E, updated to 4.1.08E with Sandisk Updater. Edited the version.sdk as per above and ran Sandisk Updater again.

Now I have working FM-radio, everything else seems good so far.
Reply With Quote

  #51  
Old 05-27-2007, 07:32 AM
willmans willmans is offline
Junior Member
 
Join Date: Feb 2007
Posts: 11
Default

Has anyone got the american harp firmware (3.X.XA)?
I think the sansa updater program reads the usb hardware id to get the firmware version, so is there anyway to fool it into thinking its a 3.0.6A player connected?

On my euopean player with 3.2.8E the id is 078174000328 and on my v2.2.3 player
which got bricked it was 078174000223
Reply With Quote

  #52  
Old 06-04-2007, 03:54 AM
natural natural is offline
Junior Member
 
Join Date: Feb 2007
Location: Kiev, Ukraine
Posts: 2
Smile

Quote:
Originally Posted by delirium22 View Post
Changed my version.sdk to:

Code:
#DO NOT EDIT OR REMOVE THIS FILE
Product: m2X0
FW: V4.0.45A
Region: Americas
Rebooted M250 and ran updater again, it told me it found an update for my device. Update without a problem and FM is working now, haven't found any bugs...
I did the same thing with my m250, everything works, FM is not so good as expected, but it's quite acceptable.
Reply With Quote

  #53  
Old 06-07-2007, 12:45 AM
NOKIA_LMT NOKIA_LMT is offline
Junior Member
 
Join Date: Jun 2007
Posts: 1
Exclamation M250 (FW 2.3.8E) radio ?

Hello Dear all!

It's my first post on this forum...

Yesterday I bought my Sansa m250 (with European firmware 3.2.8E, unfortunately) and starting to look how to change it's firmware to the American version. The main goal is to unlock hidden FM-radio on my device.

Searching through the Internet I found your's forum and this topic. (By the way, your forum is the best!!! )

After reading this thread I understand that there is BIG problem to change the firmware version 3.2.8E (which I have) to any other version (I may kill my device )

Is there is something new about the problem? I already found posts about european firmware version 4.x.xE which is upgradable to american equivalent. Have tried to upgrade my device to firmware 4.x.xE using Sansa Update Manager, but with no luck - it's reports that my version (3.2.8E) is current and there is no updates available at this time... Very strange and dissapointing...

So... If you have time, can you please describe how to make firmware upgrade in my case? Thanks for all beforehand!

P.S. Sorry for my english....
Reply With Quote

  #54  
Old 06-08-2007, 06:21 PM
willmans willmans is offline
Junior Member
 
Join Date: Feb 2007
Posts: 11
Default

I have been trying to hack the v3 players but I think that there are no updates for v3 players on sandisk servers. What I did was that I used WinHex to edit the values in the RAM for SansaUpdater. I edited from 3.2.8E to 3.0.5A, it showed up in the updater window, but it did not find any updates. When I typed 2.0.0A it found the latest v2 american update.

Try it yourself, download winhex and then go ram edit after sansaupdater has been launched, select sansaupdater and primary memory, and then just search for the firmware you have on your player and edit it out on all places in the memory! Then just try to update and it should say what you typed in!
Reply With Quote

  #55  
Old 06-09-2007, 03:46 AM
YogiCK's Avatar
YogiCK YogiCK is offline
Junior Member
 
Join Date: Jan 2007
Posts: 7
Default

If someone will find american 3.x.x software on http://ca1.storage.flashcp.com, it will be very good.
Reply With Quote

  #56  
Old 06-09-2007, 08:46 AM
willmans willmans is offline
Junior Member
 
Join Date: Feb 2007
Posts: 11
Default

Quote:
Originally Posted by YogiCK View Post
If someone will find american 3.x.x software on http://ca1.storage.flashcp.com, it will be very good.
But there is no "3" directory on their servers.

theres
http://ca1.storage.flashcp.com/sansa...0/1/A/PACKAGE/
http://ca1.storage.flashcp.com/sansa...0/2/A/PACKAGE/
and
http://ca1.storage.flashcp.com/sansa...0/4/A/PACKAGE/

but if you try to enter http://ca1.storage.flashcp.com/sansa...0/3/A/PACKAGE/
it indicates that there is no such folder..
Reply With Quote

  #57  
Old 09-17-2007, 08:05 AM
Saalistaja Saalistaja is offline
Junior Member
 
Join Date: Sep 2007
Posts: 2
Default Doesn't work with my unit

Quote:
Originally Posted by GrimReaper View Post
Didn't work on my Sansa m240 V4.1.08E.
Now I have V4.1.08A, I have FM radio in main menu, but there is no sound.
I have had exactly the same experience with my m250, originally V4.1.07E reflashed to V4.1.08A. Maybe newer or at least some manufacturing batches don't physically have the FM radio feature anymore.
Reply With Quote

  #58  
Old 10-01-2007, 06:43 AM
dejjones dejjones is offline
Junior Member
 
Join Date: Sep 2007
Posts: 1
Default

I have just followed the instructions, as above, with a new m240 version V4.1.08E; changed the version.sdk to V4.1.045A, updated with updater to V4.1.08A, everything seemed to work, FM Radio in menus etc. but no sound. If anyone has found the answer to this I would be grateful.
Reply With Quote

  #59  
Old 12-01-2007, 09:29 AM
Marsbar Marsbar is offline
Junior Member
 
Join Date: Dec 2007
Posts: 2
Default

Quote:
Originally Posted by dejjones View Post
I have just followed the instructions, as above, with a new m240 version V4.1.08E; changed the version.sdk to V4.1.045A, updated with updater to V4.1.08A, everything seemed to work, FM Radio in menus etc. but no sound. If anyone has found the answer to this I would be grateful.
I tried the same (assuming you meant V4.0.45A) with an M250 and have the same result - MP3 plays fine but the radio is just silent. Perhaps the latest european versions have the aerial disconnected? Scanning for stations gets no results so it's not just that the radio is muted.
Reply With Quote

  #60  
Old 12-02-2007, 06:03 AM
Marsbar Marsbar is offline
Junior Member
 
Join Date: Dec 2007
Posts: 2
Lightbulb

Quote:
Originally Posted by Marsbar View Post
Perhaps the latest european versions have the aerial disconnected? Scanning for stations gets no results so it's not just that the radio is muted.
Just occurred to me: this is a Christmas present so I haven't taken out the supplied headphones etc - just squeezed the player through a small opening in the blister pack. Does the FM radio only work with the supplied headphones? Are either of you other guys who have the same problem using the supplied phones?
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:06 PM.