android
Prev Previous Post   Next Post Next
  #1  
Old 06-12-2008, 05:47 PM
newfilter newfilter is offline
Junior Member
 
Join Date: Jun 2008
Posts: 1
Default Strange Behavior

My Zen Sleek is 3 years old but has not really been used too much until this past year. About two weeks ago this weird thing started happening, when I'd pust the buttons on the front, they would light up but kind of flicker, and while they were flickering I could hear static in sync with the flicker. The battery would charge normally and when the buttons were not lit up everything sounded and worked fine. Now yesterday the flickering stopped and the player worked fine, today all seemed good... UNTIL I went to turn it off, realized I had locked the buttons so I slid the lock to the off position and BOOM the lights flickered and the whole screen went blank, strange though THE POWER IS ON, the light on the power button is lit, the front buttons are dark, but the power seems to be ON. No change if I plug the charger into the AC or into the USB on the computer. I tried pushing the reset and no change.

Any chance that it is just a dead battery? If the battery is dead why would the light on top be on like the power is on? I could change the battery but hate to buy a 30 dollar battery and then have to throw the damn player out!

ANY HELP IS APPRECIATED.
Reply With Quote

Advertisement [Remove Advertisement]

 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 09:16 AM.