android
  #1  
Old 02-06-2008, 01:23 AM
FestinaXL FestinaXL is offline
Junior Member
 
Join Date: Feb 2008
Posts: 5
Default Zen Touch/Xtra Legacy OS Driver Support

Has somebody experience with the Zen Touch and the old Windows2000 ?
I have bought a used Player without Installation CD.
Windows 2000 recognizes the player but the drivers from the Creative Labs HP can't be used.
With Gnomad2 on Ubuntu Linux i can access the player without problems.

On a Windows XP i have the same problem.....
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 02-06-2008, 03:55 AM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

For Legacy Windows support (Windows 98/ME/2000), try this driver from Creative.

For Windows XP, try updating to Service Pack 2, then updating WMP10 to WMP11.
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #3  
Old 02-06-2008, 07:10 AM
FestinaXL FestinaXL is offline
Junior Member
 
Join Date: Feb 2008
Posts: 5
Default

As described, i tried the drivers from Creative without success !
So I've decided to try to downgrade the firmware to 1.0.3.....
I've reloaded the player-firmware.

Now firmware 0.0.10 is shown. The player is recognized by OS (Win98,Win2000,Win XP) if I plug it into an USB-port, but matching drivers can't be found by the OS.
Reply With Quote

  #4  
Old 02-06-2008, 03:21 PM
FestinaXL FestinaXL is offline
Junior Member
 
Join Date: Feb 2008
Posts: 5
Default

...after a couple of hours with removing/installing i can connect my Zen Touch with the driver (MCP) named above . I can access it on Win2000 with WMP9.

Now I've to update the Firmware....but the available Firmware-Upgrade-Files "ZenTouchUpgrade_1_00_06.exe" etc. reports "Your player is not connected"....WMP9 says it is connected ?!?!

Any suggestions ......
Reply With Quote

  #5  
Old 02-06-2008, 11:48 PM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

Unfortunately, you need to have Windows XP or Vista to update firmware.
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #6  
Old 04-08-2008, 09:15 AM
BobbyRS's Avatar
BobbyRS BobbyRS is offline
Ultra Senior Member
 
Join Date: Oct 2007
Location: USA
Posts: 6,575
Default

I saw this on Creative's forum a while back.....

Here is the easiest solution for legacy OS's (Windows 98/ME/2000):

1. Download the drivers from here or here with support for MTP

2. Unpack & Install MTP9x-2k.EXE

3. Choose ctpdmtp.inf & click right mouse button & select Install

4. Restart Windows

5. When Windows has booted up again plug your ZEN Touch in to a USB port, if it askes for a driver please refer it to the ctpdmtp.inf file.
__________________
.
~Light travels faster than sound, which is why some people appear to be bright until they speak~

Zen FAQ

Last edited by BobbyRS; 06-08-2008 at 11:04 AM.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 10:05 AM.