android
  #1  
Old 12-19-2007, 11:04 PM
AndrewJ's Avatar
AndrewJ AndrewJ is offline
Member
 
Join Date: Dec 2006
Location: Mi Komfee Chaire
Posts: 161
Default Battery and Lag Issues

I've had my e260 for 3 months now and have recently aquired an e250 for my bro for 5 bucks. I love rockbox it's amazing but I've had these issues for around a month or so now.

I use normal Rockbox unmodified except for themes. I have had problems with lag while playing songs and using the database.

1 While playing songs I hit next and it will take around 1-4 seconds before the next song starts, the other song plays away until that time then switches immediately to the song I moved to like 4 seconds ago. (that was confusing)

2 When I try to resume a song that is paused somethimes it wont start back up!

3 And my battery will die at what rockbox indicates as around 25-30%

These issues make for a problematic rockbox experience. I hope someone will be able to help! There always is someone to help!

Thanks,
Andrew
__________________
"Bother," said Pooh, as he chambered another round...

Last edited by AndrewJ; 12-19-2007 at 11:14 PM. Reason: make it easier to read :D
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 12-19-2007, 11:29 PM
digerati1338's Avatar
digerati1338 digerati1338 is offline
Member
 
Join Date: Apr 2007
Location: Aurora, CO
Posts: 337
Default

I noticed these issues when I updated my digibuild from about a month ago to current SVN. I hadn't updated it because of the album art commit.

Anyway, after I updated I immediately noticed a slow down. Maybe people that have been updating more frequently wouldn't have noticed it because it took place over a long time. Anyway, check out the difference between these two builds:

http://e200.digerati1338.googlepages...2007-10-30.zip

http://e200.digerati1338.googlepages...2007-12-16.zip

The one from 10-30 is noticeably faster than the one from 12-16. Not sure what's going on, but it must be in svn because I don't have any patches applied that would cause that. Hopefully the devs can get some optimizations or figure out what's causing the slow-downs. It wouldn't be the AA commit, unless the commit was way different than the patch, because the patch is on my old build too.
__________________
Rockbox digibuild
Player: SanDisk Sansa e200
Firmware: Rockbox digibuild
Reply With Quote

  #3  
Old 12-20-2007, 12:09 AM
epithetless's Avatar
epithetless epithetless is offline
Ultra Senior Member
 
Join Date: Jul 2007
Location: Boston, Mass
Posts: 1,617
Default

digerati1338, have you alerted any of the devs over on the Rockbox site/tracker/IRC about the evident slowdowns? I suspect they must be aware of the issue, but it can't hurt to bring up (unless I've just missed the discussion of it on my perusals through their site, in which case you'll likely be berated for your efforts...)
Reply With Quote

  #4  
Old 12-20-2007, 07:56 PM
AndrewJ's Avatar
AndrewJ AndrewJ is offline
Member
 
Join Date: Dec 2006
Location: Mi Komfee Chaire
Posts: 161
Default

Thanks for that info, I hope the Rockbox guys can fix this!
__________________
"Bother," said Pooh, as he chambered another round...
Reply With Quote

  #5  
Old 01-25-2008, 07:01 PM
drkgeek's Avatar
drkgeek drkgeek is offline
Junior Member
 
Join Date: Jan 2008
Location: Camas, WA
Posts: 38
Default

I'm having this problem right now... exactly the same.
Reply With Quote

  #6  
Old 01-25-2008, 07:36 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Yes, Rockbox at present is slower than before due to changes in SVN (Viewports, Album Art, etc). It is a known problem. Please be patient while the kinks are being worked out. Please note that what we are using is developmental code. There is no real release for the e200 series.

Charles
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 02:46 AM.