android
  #41  
Old 12-27-2007, 05:12 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,611
Default

I should ask him but insofar as Samsung France does not create firmwares I don't think he has got the source code lol
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

Advertisement [Remove Advertisement]

  #42  
Old 12-30-2007, 08:11 AM
fde fde is offline
Junior Member
 
Join Date: Dec 2007
Posts: 20
Default

Still no solution? I'm a bit desperate ; I had a look on thousands of web sites - even in German and Italian - but nobody seems to find a way of installing this UMS firmware. That's really frustrating, especially because I'm sure the trick is not so complicated, and the T10 is one of the only Samsung players on which the "classical" solution doesn't work.
Reply With Quote

  #43  
Old 12-30-2007, 09:24 AM
shinobi00 shinobi00 is offline
Member
 
Join Date: Apr 2007
Posts: 274
Default

yeah tis a shame no one has figured it out yet. I can't even try that hex edit trick lebellium discovered because I've updated to the newest firmware version.
Reply With Quote

  #44  
Old 12-31-2007, 02:44 PM
Rush Rush is offline
Junior Member
 
Join Date: Dec 2007
Posts: 11
Default

I got an email from Samsung saying , "At this time there is no plan to release a UMS firmware". I wish they would give us the option though.
Reply With Quote

  #45  
Old 12-31-2007, 09:17 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,611
Default

lol you really think that Samsung will help you?
They don't want european and american customers to upgrade in korean firmware. That's why firmwares are different in every country and that upgrade in UMS is not possible. If they really wanted, they could allow anybody to install a korean firmware. There is no technical difficulty
That belongs to the Samsung's (bad) policy.
As I'm in closed touch with a guy who works at Samsung France, I know some internal secrets I can't tell you but trust me: Korea is sometimes like the USA (sorry guys, I speak about your government, not about you directly): they like imperialism and want to dominate the world.
For instance, in France we got MTP players only because Samsung has developped a music webstore with WMA DRM.
Before it does exist, we didn't have MTP players but UMS players....
Samsung Korea does not allow its subsidiary companies to make decisions. Samsung France and Samsung USA, for example, have no rights. They only have to do what Korea wants. Only Samsung Korea creates firmwares for all countries and so and so forth...
But I can't tell you more sorry lol
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

  #46  
Old 01-01-2008, 11:33 AM
robind robind is offline
Junior Member
 
Join Date: Dec 2007
Location: Paris
Posts: 8
Exclamation for crazy-minded testers

* warning : use at your own risk ( and i REALLY mean it) *

Hi all, here is a hand-edited version of the firmware MSC v1.55 for T10.
It may be possible to load it on T10 MTP devices, BUT I DID NOT TRY IT MYSELF.

http://rapidshare.com/files/80506204...r_MTP.zip.html

Feedbacks are welcome, but remember, use it at your OWN risk and your T10 may be damaged and/or warranty be voided.
Reply With Quote

  #47  
Old 01-01-2008, 12:42 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,611
Default

what did you change exactly?
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

  #48  
Old 01-01-2008, 03:20 PM
robind robind is offline
Junior Member
 
Join Date: Dec 2007
Location: Paris
Posts: 8
Default

@lebellium :
- at address 0x28, the zone code was set to '0' (=MTP).
- the ROM contains 2 CRC fields (addresses 0x10 and 0x18), which were updated.

If the ROM is modified but the CRC values are not updated, it causes the firmware image to be considered as 'invalid'.

Nevertheless, there may be more validity checks that I am not aware of.
Reply With Quote

  #49  
Old 01-01-2008, 04:37 PM
allama allama is offline
Junior Member
 
Join Date: Jan 2008
Posts: 9
Talking It Works!!!!!

Robind, you are the great hacker. I tried your firm and it works. I put the two files in the root and I disconnected the usb. Then I switch on and the actualization screen appeared. The screen only was a little moment, after, it shutdown. When i switched on again, the player worked ok. But when i plug the usb cord ... the pc detected the removable usb disk and i can dragīnīdrop files directly without drivers...
**When I actualize the firmware to 1.55 version , the two files was deleted, but now only the t10j.rom was deleted. Delete the other file manually.
Thank you very much, Robind
Reply With Quote

  #50  
Old 01-01-2008, 04:42 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,611
Default

Really?!!!
The T10 is now UMS?
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

  #51  
Old 01-01-2008, 04:47 PM
fde fde is offline
Junior Member
 
Join Date: Dec 2007
Posts: 20
Default

Yesssss, it works! Thank you so much robind! I'm a happy man
Reply With Quote

  #52  
Old 01-01-2008, 04:54 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,611
Default

fde, ready to make a tutorial on generationmp3 please?^^
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

  #53  
Old 01-01-2008, 05:08 PM
fde fde is offline
Junior Member
 
Join Date: Dec 2007
Posts: 20
Default

No, finally it doesn't work that well ; my player doesn't recognize the videos neither the pictures anymore. That's really strange... I don't know the reason, but I'm thinking really hard (especially to make my player work as well as before!).
Reply With Quote

  #54  
Old 01-01-2008, 05:18 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,611
Default

Ah that's a pity...

But to make your player work, try to upgrade again with a not-modified firmware
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

  #55  
Old 01-01-2008, 05:33 PM
allama allama is offline
Junior Member
 
Join Date: Jan 2008
Posts: 9
Default

Ok, I had the same problem. Copy all files and folders from your samsung to a backup folder in your pc. Format the removable drive (fast format). Disconnect the usb cord.
When you power up, the folders structure is created again. Then copy your videos from backup to video folder and the photo files to the pictures folder. Then disconnect the usb. Voila, the player runs again...
I hope this help you. (This is my experience... I donīt know if your player do the same that mine...)
Reply With Quote

  #56  
Old 01-01-2008, 05:40 PM
fde fde is offline
Junior Member
 
Join Date: Dec 2007
Posts: 20
Default

Ok, thanks allama! I'll try that.

EDIT: Yes it works! Thanks! I'm so happy! This year has a great beginning!
Reply With Quote

  #57  
Old 01-01-2008, 05:43 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,611
Default

I didn't all understand.
Once the player is formated, the structure is created again but is it still in 1.55UMS or do you have to reinstall the 1.55 MTP?
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

  #58  
Old 01-01-2008, 05:51 PM
fde fde is offline
Junior Member
 
Join Date: Dec 2007
Posts: 20
Default

No, it's UMS and it works perfectly! I don't really know why, but so far this player seemed so strange that it does not surprise me at all!

@robind: Could you tell me how to update the CRC fields? I'd like to know, in order to explain it on other forums.
Reply With Quote

  #59  
Old 01-01-2008, 05:52 PM
allama allama is offline
Junior Member
 
Join Date: Jan 2008
Posts: 9
Default

I posted the steps i did. I think that only with move the files to computer, disconnect, connect and reload the files into the player is enough. The player, when you disconnect refresh the library.
I saved the entire removable unit to a folder in the pc, then format the removable unit (the player). Disconnect, power on the player, wait a seconds, connect again and copy the image, video and audio again in the player folders. Disconnect and it runs.
Reply With Quote

  #60  
Old 01-01-2008, 05:53 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,611
Default

But normaly when you format your player, you need to reinstall a firmware if you want your player to run again.
So that's so strange it remains 1.55UMS once you formated the player
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

Reply

Tags
firmware, msc, t10, ums

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 02:34 AM.