android
  #1  
Old 09-05-2007, 07:39 AM
josse ramos josse ramos is offline
Junior Member
 
Join Date: Sep 2007
Posts: 2
Default SE display dead!

My new SE 2GB screen is dead! In the first few days it was OK, but now after 5 or 6 days without using the SE the screen does not light up, and is not visible any more. Any help would be greatly appreciated.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 09-06-2007, 02:26 PM
josse ramos josse ramos is offline
Junior Member
 
Join Date: Sep 2007
Posts: 2
Default

No replies? Come on people, no one would have a hint of what is happening? Should I RMA the unit?
Reply With Quote

  #3  
Old 09-06-2007, 03:21 PM
RCM's Avatar
RCM RCM is offline
Ultra Senior Member
 
Join Date: Mar 2007
Location: I'm not telling
Posts: 1,549
Default

Quote:
Originally Posted by josse ramos View Post
No replies? Come on people, no one would have a hint of what is happening? Should I RMA the unit?
Yes, you should
__________________
Sansa View 16GB (DEAD)
Sony Walkman NWZ-S544 (DEAD has a mind of it's own and don't feel like fixing it!)
Zune HD 32GB (Retired)
Samsung Galaxy tab 2 7.0
Motorola Droid razr m
Reply With Quote

  #4  
Old 04-10-2008, 08:41 AM
edoovel edoovel is offline
Junior Member
 
Join Date: Apr 2008
Posts: 21
Default

Try to perform hard reset.
Reply With Quote

  #5  
Old 05-16-2008, 03:11 AM
daveyostrow daveyostrow is offline
Junior Member
 
Join Date: Jun 2007
Posts: 9
Default

i have the same problem, reset does nothing. right when the light turns on the screen kind of light up, but then nothing. it was working fine, set on the table, then the display just stopped working! i feel like its trying to work but something is off like a connector... or did these screens just die?

are all sansa products poorly made? i assumed otherwise.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:57 AM.