android
  #1  
Old 05-26-2007, 02:50 PM
jimmyboy418 jimmyboy418 is offline
Junior Member
 
Join Date: May 2007
Posts: 4
Default My Nano Plus is Dead!

Hello!

I'm new to this forum but I have a problem. I have a Creative Zen Nano Plus 512MB that is dead after a year of good serive. I was attempting to update the firmware, as suggested by Creative, prior to upgrading Windows Media Player to Version 11. I downloaded the required .exe from Creative's site, hooked up my Nano per on-screen instructions and immediately the Nano was dead.

Changed batteries, tried re-loading the drivers, tried un-installing all Creative files and re-loading from the install disc that came with the device, even sent Help! Help! emails to Creative but still have a Nano Plus that will not turn on. (Creative told me I am SOL because the unit is a year old)

Anyone have any ideas to fix this?

Jimmyboy
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 05-26-2007, 06:42 PM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

Try this:
  1. Take the battery out of the player.
  2. Press and hold the Play/Pause button.
  3. While holding the Play/Pause button, plug it into the computer.
  4. Continue holding the Play/Pause button for ten seconds, until Windows brings up the "Found New Hardware" dialog (Player Recovery Device).
  5. Allow Windows to install the driver, then attempt to reload the firmware.
Be particularly sure that the firmware you are trying to load is the correct firmware for your particular device.
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #3  
Old 05-27-2007, 10:42 AM
jimmyboy418 jimmyboy418 is offline
Junior Member
 
Join Date: May 2007
Posts: 4
Unhappy Nano Plus Still Dead

Thanks for the quick reply to my problem. I followed your instructions and yes, Windows recognized the player (w/o battery), asked if I wanted to install a driver and then did it.

Alas, the player still will not power on and Creative software cannot see the player when connected to the computer.

Help?
Reply With Quote

  #4  
Old 05-27-2007, 12:16 PM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

I'm afraid I'm out of ideas. As you can see in my sig, I have a MuVo N200, which is, for all intents and purposes, a Nano with a different name. Unfortunately, I'm afraid your player might very well be dead.
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #5  
Old 05-29-2007, 05:02 PM
DoctorM DoctorM is offline
Junior Member
 
Join Date: Jul 2006
Posts: 44
Default

Wait, did you attempt to reload the firmware after installing the driver?

If Windows recognized the player you should have been able to flash it.
Reply With Quote

  #6  
Old 06-04-2007, 03:45 PM
jimmyboy418 jimmyboy418 is offline
Junior Member
 
Join Date: May 2007
Posts: 4
Angry

When attached to the computer (with the battery out of the player) Windows recognizes the player as a storage device, which is fine, but that's all. I tried to re-load the driver with the player off (and with the battery out, as suggested) but nothing happens afterward. No sign of life when connected by USB to the computer and no sign of life when disconnected and the battery re-installed. I tried holding down different combinations of keys on the player to see if that would bring it to life, but no.

Truth is, I like that little Nano. Strange how you miss such a small piece of non-essential entertainment technology when it will not work.
Reply With Quote

  #7  
Old 06-10-2007, 08:03 AM
jimmyboy418 jimmyboy418 is offline
Junior Member
 
Join Date: May 2007
Posts: 4
Default

If it is true that my Nano Plus 512 is dead, what then would be your suggested replacement for this player? (given the following criteria)

A small player, close to the size of the Nano Plus 512, but with, say, 1 MB, with FM built in, operating on AAA battery/batteries and with organizer software similar to that offered by Creative. I do not need it to be a video player. Small size is key.
Reply With Quote

  #8  
Old 06-10-2007, 12:14 PM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

Well, the only Creative players I know of that run on removable AAA batteries are of the MuVo/Nano line. The MuVo V100 sounds promising; it has up to 2GB of memory, and supposedly supports lyric display.

Another player worth considering is a Zen V+. It doesn't run on disposable batteries, though; rather, it uses a rechargeable pack.
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #9  
Old 10-27-2007, 09:52 AM
boodles07 boodles07 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 14
Default new player

One suggestion that I have, it will not fix your old player, is to buy your new player whatever it be at Walmart. I really do not care much for Walmart but we bought my wifes ze v plus there and added three year replacement on top of the Creative warranty to make it 4 years, no questions asked....and it was cheap, like $20 or so??
Just a thought....you know these little electronic components are susceptible to failure so it is worth it..
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:17 PM.