android
  #101  
Old 08-03-2007, 03:45 PM
digerati1338's Avatar
digerati1338 digerati1338 is offline
Member
 
Join Date: Apr 2007
Location: Aurora, CO
Posts: 337
Default

With the new month, I discovered a bug in the digibuild updater. It does not seem to decrement the month. I think this is a simple logic problem. I'll try to fix that soon.
__________________
Rockbox digibuild
Player: SanDisk Sansa e200
Firmware: Rockbox digibuild

Advertisement [Remove Advertisement]

  #102  
Old 08-04-2007, 09:09 PM
PookiePrancer's Avatar
PookiePrancer PookiePrancer is offline
Junior Member
 
Join Date: Jul 2006
Posts: 88
Default Hey!

Your last build fixed the "album art not showing up in all AA themes" problem. Thanks!

  #103  
Old 08-05-2007, 12:13 AM
digerati1338's Avatar
digerati1338 digerati1338 is offline
Member
 
Join Date: Apr 2007
Location: Aurora, CO
Posts: 337
Default

I'm starting to get busy with school stuff, but I'll try to keep the builds going. Instead of updates almost every other day, I think I'll try to do one per weekend, and more if there are major developments during the week.

Glad it worked for you.
__________________
Rockbox digibuild
Player: SanDisk Sansa e200
Firmware: Rockbox digibuild

  #104  
Old 08-11-2007, 02:57 PM
pienose pienose is offline
Member
 
Join Date: Mar 2007
Posts: 358
Default

I have to say this is by far my favourite type of rockbox, well done!

  #105  
Old 08-11-2007, 05:03 PM
tofuSCHNITZEL tofuSCHNITZEL is offline
Junior Member
 
Join Date: Aug 2007
Posts: 1
Default

could you build in this into the digibuild please?:
http://www.rockbox.org/tracker/task/...string=runtime


greez

  #106  
Old 08-11-2007, 10:38 PM
digerati1338's Avatar
digerati1338 digerati1338 is offline
Member
 
Join Date: Apr 2007
Location: Aurora, CO
Posts: 337
Default

Ya, I will. I had considered it before, but didn't know if anyone would actually use it. I will do a build tomorrow.

Unless anyone objects, I plan on removing some of the iPhone patches and the iPhone WPS. It is cool eyecandy, but I haven't found it to be very useable, and it is a pain in the @$$ to get working properly. I think the album art rettumpack looks just as good. or DockPod.
__________________
Rockbox digibuild
Player: SanDisk Sansa e200
Firmware: Rockbox digibuild

  #107  
Old 08-12-2007, 05:01 AM
pienose pienose is offline
Member
 
Join Date: Mar 2007
Posts: 358
Default

would it be possible to have a pictures menu on the main rockbox menu that worked the same way as the videos one?

  #108  
Old 08-12-2007, 03:41 PM
digerati1338's Avatar
digerati1338 digerati1338 is offline
Member
 
Join Date: Apr 2007
Location: Aurora, CO
Posts: 337
Default

Quote:
Originally Posted by pienose View Post
would it be possible to have a pictures menu on the main rockbox menu that worked the same way as the videos one?
Probably; I also want to try to re-order the main menu. I'll look into making a patch for that before I start my build.
__________________
Rockbox digibuild
Player: SanDisk Sansa e200
Firmware: Rockbox digibuild

  #109  
Old 08-12-2007, 04:00 PM
pienose pienose is offline
Member
 
Join Date: Mar 2007
Posts: 358
Default

yes I think a re-order would be good to, something like-

-files
-database
-now playing
-photo
-videos
-recording
-recent bookmarks
-playlist
-settings
-plugins
-system

would be good

  #110  
Old 08-12-2007, 11:03 PM
digerati1338's Avatar
digerati1338 digerati1338 is offline
Member
 
Join Date: Apr 2007
Location: Aurora, CO
Posts: 337
Default

I think I have successfully modified the main menu. It looked good in the sim. Right now, I have something like:

-Now Playing
-Database
-Playlist (Many people use playlists on shuffle as primary music source)
-FM
-Plugins
-Files
-Rec
-Settings
-System

I tried grouping music related things at the top, then going down to more system-related functions. I didn't include videos or photo menu in that, but I plan to. Right now that patch is out of sync.

I think the build will have to wait till tomorrow, since it is late for me here.
__________________
Rockbox digibuild
Player: SanDisk Sansa e200
Firmware: Rockbox digibuild

  #111  
Old 08-14-2007, 04:53 PM
pienose pienose is offline
Member
 
Join Date: Mar 2007
Posts: 358
Default

Hello? when is 'tomorrow' going to come?

and yes, that menu looks good, I will update soon (can't be assed right now!)

  #112  
Old 08-14-2007, 10:49 PM
digerati1338's Avatar
digerati1338 digerati1338 is offline
Member
 
Join Date: Apr 2007
Location: Aurora, CO
Posts: 337
Default

Sorry that took so long; I'm starting to get busy with school again.

Quite a few changes for the new build:
-Custom digibuild main menu re-ordering as above (finally got it working, a sim bug that was recently fixed had me thinking I somehow broke the scrolling by doing that, but it works fine)
-iPhone WPS and patches removed (IMHO not worth the trouble).
-calendar patch added
-pong upgrade added

I will do a custom version of the video/photo menu patch in the next few days (don't quote me on that) that will work with my custom menu patch.
__________________
Rockbox digibuild
Player: SanDisk Sansa e200
Firmware: Rockbox digibuild

  #113  
Old 08-15-2007, 06:53 AM
pienose pienose is offline
Member
 
Join Date: Mar 2007
Posts: 358
Default

when I update to the new build, I loose all of my settings can this be avoided (the auto updater does not work)

  #114  
Old 08-15-2007, 07:38 PM
digerati1338's Avatar
digerati1338 digerati1338 is offline
Member
 
Join Date: Apr 2007
Location: Aurora, CO
Posts: 337
Default

The auto updater does not work if there is no build for the current month, since there seems to be a logic problem in the month decrement that I have not resolved.

I don't know why you lost your settings, but I think a similar thing happened to me. I'll look into it. It could be the config file being overwritten...
__________________
Rockbox digibuild
Player: SanDisk Sansa e200
Firmware: Rockbox digibuild

  #115  
Old 08-15-2007, 11:05 PM
digerati1338's Avatar
digerati1338 digerati1338 is offline
Member
 
Join Date: Apr 2007
Location: Aurora, CO
Posts: 337
Default

I'm running make on a new build right now. This one has a video and photo menu that work correctly with the rearranged menu I did. It also has scrolling margins again; I re-synced that patch to SVN. Enjoy!

Hopefully I can fix that updater batch file tomorrow.
__________________
Rockbox digibuild
Player: SanDisk Sansa e200
Firmware: Rockbox digibuild

  #116  
Old 08-16-2007, 07:00 AM
pienose pienose is offline
Member
 
Join Date: Mar 2007
Posts: 358
Default

Ok this new build is a bit dogie... none of the settings work and when ever I try to enter the file vewer or photos or videos or whatever it said 'filetype array full' then 'prev to abort'

wtf?

I have had to go back to a preveous build, luckily I had it in my re-cycle bin

  #117  
Old 08-16-2007, 07:32 AM
chrisjs162216 chrisjs162216 is offline
Ultra Senior Member
 
Join Date: Oct 2006
Location: Somewhere
Posts: 1,515
Default

Quote:
Originally Posted by pienose View Post
'filetype array full'
My build had that for a few days - it should be around 128, but maybe some svn update caused problems.

Digi - IIRC you already know this, but just to make sure, it's in apps/filetypes.c

  #118  
Old 08-16-2007, 07:57 AM
pienose pienose is offline
Member
 
Join Date: Mar 2007
Posts: 358
Default

alot of other stuff didn't work eather, like the database-it would not display the names of stuff. I recomend that people stay on the build they are on now, new one ist seir mucked up (sos for to words of german there)

  #119  
Old 08-16-2007, 07:39 PM
digerati1338's Avatar
digerati1338 digerati1338 is offline
Member
 
Join Date: Apr 2007
Location: Aurora, CO
Posts: 337
Default

This new one isn't working for me either. I'm going to try isolating the problem later tonight. That might take a while on my slow computer... I will let you guys know when I get a good one done, and I'll make sure to do some testing on it this time.

Also FYI - I keep all of my builds archived on the website. Just go to my website and go to the changelog, and change the date in the filename. A couple might not work because I may have removed them cuz they were bad, or because I'm nearing my space limit.
__________________
Rockbox digibuild
Player: SanDisk Sansa e200
Firmware: Rockbox digibuild

  #120  
Old 08-23-2007, 02:20 AM
poco153's Avatar
poco153 poco153 is offline
Junior Member
 
Join Date: Mar 2007
Posts: 9
Default

I've been having a strange sort of problem with the last 3 or 4 builds: When I copy the .rockbox folder over the old one and reboot the player, I cannot read any of the text or options on the menus. It appears to be black text on a solid black background. I can see the icons and presumably select things and navigate the menus blindly, and the player responds when I select things. I usually end up having to completely delete the .rockbox folder and copy the newest build, thus losing all of my modifications.

Has anybody else had this problem?
__________________
Zune 80 - Zune Premium Earphones
Sansa Clip 2GB - Sennheiser MX90

Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:35 AM.