android
  #1961  
Old 01-22-2008, 02:17 AM
WakDooD's Avatar
WakDooD WakDooD is offline
Junior Member
 
Join Date: Jul 2007
Posts: 39
Default

cpchan,
After installing your latest build (January), whenever the backlight turns off, nothing seems to turn it back on. However, the sansa is still running and key presses still have the desired effect. Was FS#8400 added to the build, and if so, which key will turn on the backlight? I have tried all of them, and so far the only way to turn on the backlight again is to restart the sansa.

edit. also, i've noticed that the Backlight during plugin option has disappeared

ps. thanks for finally releasing a new build

pps. woot first post xD

Advertisement [Remove Advertisement]

  #1962  
Old 01-22-2008, 03:29 AM
Songokuu's Avatar
Songokuu Songokuu is offline
Junior Member
 
Join Date: Jun 2007
Location: Bielsko-Biala, Poland
Posts: 89
Default

Yey it's here...a new biuld. Thanks Charles.

Small questions:
Is it posible to change any old WPS into Viewport by only cfg file?
Can you (If you have time ) make a version of your build without Viewport, because there is lot of cool old WPS (and lot of people use them). This Viewport just started and I think it will be some time before new Viewport WPS will come out.

  #1963  
Old 01-22-2008, 08:56 AM
isanggon isanggon is offline
Junior Member
 
Join Date: Aug 2007
Posts: 81
Default

Hi, cpchan.

I tested your build shortly, and I found a few problem.
Multifont didn't applied to recording screen. And Histogram in recording menu, it didn't work now.

Thanks for a new build

  #1964  
Old 01-22-2008, 10:33 AM
disorganizer disorganizer is offline
Member
 
Join Date: Jun 2007
Posts: 141
Default

Quote:
Originally Posted by Songokuu View Post
and I think it will be some time before new Viewport WPS will come out.

well, there are already wps's with viewport, and all new wps's will be viewport anyways.

also, feel free to convert and post any old wps.
__________________
my wps's for rockboxed sansa-E:
normal with viewports
maxed out AA with viewports

  #1965  
Old 01-22-2008, 03:19 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by WakDooD View Post
After installing your latest build (January), whenever the backlight turns off, nothing seems to turn it back on. However, the sansa is still running and key presses still have the desired effect.
Strange, it works fine here. Can you try a clean insatllation?

Quote:
Was FS#8400 added to the build, and if so, which key will turn on the backlight? I have tried all of them, and so far the only way to turn on the backlight again is to restart the sansa.
No, I haven't added that one yet. I am still deciding.

Quote:
edit. also, i've noticed that the Backlight during plugin option has disappeared
I don't have my e280 with me right now. I might have forgotten to apply that patch . I will look into it tonight.

Charles

  #1966  
Old 01-22-2008, 03:22 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by isanggon View Post
I tested your build shortly, and I found a few problem.
Multifont didn't applied to recording screen.
Yes, I forgot to change the font. It will be in the next build.

Quote:
And Histogram in recording menu, it didn't work now.
I will look into that. I might have done something wrong with I resynced REP (recording enhancement pack).

Charles

  #1967  
Old 01-22-2008, 03:35 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by Songokuu View Post
Is it posible to change any old WPS into Viewport by only cfg file?
Depending on the patches the old theme depends on, it might be a stright forward job to convert the theme to viewports or impossible at the moment.

Quote:
Can you (If you have time ) make a version of your build without Viewport, because there is lot of cool old WPS (and lot of people use them).
It will be a nightmare to resync those patches since they are no longer in development (their tracker pages on flyspray have actually been closed) with the changes in Rockbox. However, I will upload the old builds tonight and keep them around for a while.

Quote:
This Viewport just started and I think it will be some time before new Viewport WPS will come out.
Actually you are wrong on this. Most of Viewports have been committed to SVN and any new themes can use it, where as the old complex themes relies on unofficial and out of date patches that will never be committed.

Charles

  #1968  
Old 01-22-2008, 03:54 PM
WakDooD's Avatar
WakDooD WakDooD is offline
Junior Member
 
Join Date: Jul 2007
Posts: 39
Default

Quote:
Originally Posted by cpchan View Post
Strange, it works fine here. Can you try a clean insatllation?
Yes, even after a clean installation the backlight still has the same problem.

It appears that when I set the brightness of the LCD to 1, the backlight will not turn on after fading. However, any setting higher than that will allow the backlight to function normally.

Also, I've noticed that when i turn Hold on then off, the backlight seems to periodically flash (btw, i've set backlight to turn off completely when hold is on. before the update, turning hold off would automatically turn on the backlight).

Again, if the brightness is set to anything higher than 1, the backlight functions normally

Perhaps there is something wrong with my config? I'm going to try resetting my config. (I have to hold rec while i'm booting RB right?)

Yes, there was something wrong with my config, although this still poses a problem for the people who like to keep their brightness settings at 1 (namely, me). Please look into this if possible...

Thanks,
WakDooD

ps. please look into the Backlight during plugin problem, thanks

pps. i've already done a clean installation twice, so please don't reply with "try a clean installation" xD

  #1969  
Old 01-22-2008, 04:18 PM
AimLXJ's Avatar
AimLXJ AimLXJ is offline
Junior Member
 
Join Date: May 2007
Posts: 65
Default

Yea I have the same problem with the back light too, I had my brightness set to 1 but now I guess 2 will work for me.

  #1970  
Old 01-22-2008, 05:20 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by WakDooD View Post
It appears that when I set the brightness of the LCD to 1, the backlight will not turn on after fading. However, anything setting higher than that will allow the backlight to function normally.
Ah, thanks for the info- I have mine set higher. I believe the problem is with the LCD Dimmer patch. I had problems with timeout setting to a really low value before.

Quote:
ps. please look into the Backlight during plugin problem, thanks
I will readd the patch tonight.

Charles

P.S.: For future reference. What we mean by a clean/fresh installation is to delete the ".rockbox" directory first and then reinstalling.

  #1971  
Old 01-22-2008, 05:52 PM
WakDooD's Avatar
WakDooD WakDooD is offline
Junior Member
 
Join Date: Jul 2007
Posts: 39
Default

Quote:
Originally Posted by cpchan View Post
P.S.: For future reference. What we mean by a clean/fresh installation is to delete the ".rockbox" directory first and then reinstalling.
Ahhhhh, my bad... thanks for elaborating
Also, thanks for readding the Backlight during Plugin patch

  #1972  
Old 01-22-2008, 06:38 PM
Songokuu's Avatar
Songokuu Songokuu is offline
Junior Member
 
Join Date: Jun 2007
Location: Bielsko-Biala, Poland
Posts: 89
Default

When I was saying:
"This Viewport just started and I think it will be some time before new Viewport WPS will come out."
I was thinking about Viewports that will be popular and satisfy most of people (I dont know how to tell you what I was really ment my english vocabulary is still missing some words (grammar too!)
I know there are already some cool looking Viewports...I like "Cleaner" look.
It would be great if someone can make somekind of tutorial about how to change old WPS into Viewport. I know it's sometimes not that simple...or is it?

Anyway I will put your newest build on to my sansa and just wait for Viewport that will replece "sector" or "cowon" WPS

Thanks again Charles it was worth waiting...

  #1973  
Old 01-22-2008, 07:11 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by Songokuu View Post
It would be great if someone can make somekind of tutorial about how to change old WPS into Viewport. I know it's sometimes not that simple...or is it?
Maybe the wps authors on this site can look into this.

Quote:
Anyway I will put your newest build on to my sansa and just wait for Viewport that will replece "sector" or "cowon" WPS
Don't know about sector, but Cowon works fine- I am using it:

cowon.jpg

Quote:
Thanks again Charles it was worth waiting...
No problem.

Charles

  #1974  
Old 01-22-2008, 07:59 PM
epithetless's Avatar
epithetless epithetless is offline
Ultra Senior Member
 
Join Date: Jul 2007
Location: Boston, Mass
Posts: 1,609
Default

Quote:
Originally Posted by cpchan View Post
Please do not upgrade if you plan to use a theme that does not support Viewports.
For the sake of clarification: Old themes that didn't rely on any of those fancy CustomLine, Multifont, or Scrolling Margins patches (i.e. ones that operated just fine in pre-Viewports official builds) should still work correctly in your new builds -- isn't that right? I know the RB devs intended for newer builds to be backwards-compatible with WPS' that weren't patch-dependent...

  #1975  
Old 01-22-2008, 08:15 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by epithetless View Post
For the sake of clarification: Old themes that didn't rely on any of those fancy CustomLine, Multifont, or Scrolling Margins patches (i.e. ones that operated just fine in pre-Viewports official builds) should still work correctly in your new builds -- isn't that right? I know the RB devs intended for newer builds to be backwards-compatible with WPS' that weren't patch-dependent...
Yes, I should be clearer. The only themes that won't work are the ones that depends on those unofficial patches.

Charles

  #1976  
Old 01-23-2008, 05:09 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by isanggon View Post
HMultifont didn't applied to recording screen.
The font is fixed in the recording screen.

Charles

  #1977  
Old 01-23-2008, 05:11 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by WakDooD View Post
also, i've noticed that the Backlight during plugin option has disappeared.
Fixed in the new build.

Charles

  #1978  
Old 01-23-2008, 05:12 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default New Essential Update

I have just uploaded new builds that increase the battery life substantially.

Charles

  #1979  
Old 01-23-2008, 06:30 AM
Songokuu's Avatar
Songokuu Songokuu is offline
Junior Member
 
Join Date: Jun 2007
Location: Bielsko-Biala, Poland
Posts: 89
Default

Quote:
Originally Posted by cpchan View Post
Yes, I should be clearer. The only themes that won't work are the ones that depends on those unofficial patches.
Ok, now it's clear

Two builds in 2 days...you are THE MAN Charles

  #1980  
Old 01-23-2008, 10:54 AM
Benjamin_L Benjamin_L is offline
Junior Member
 
Join Date: Jun 2007
Posts: 22
Default

note to self: look first then ask

Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 03:28 AM.