android
  #981  
Old 07-27-2007, 01:06 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by steviep View Post
The issue with the scroll wheel skipping to the top/bottom seems to just be on your build and not the current build on the rockbox site. Any idea what patch could be causing it?
What do you mean by skipping to the top and bottom? Please explain further. I have no trouble controlling the scrollwheel.

Charles

Advertisement [Remove Advertisement]

  #982  
Old 07-27-2007, 01:20 AM
USS Sovereign NCC-73811's Avatar
USS Sovereign NCC-73811 USS Sovereign NCC-73811 is offline
Member
 
Join Date: May 2007
Location: Starfleet Academy, San Francisco
Posts: 256
Default

Yeah same here; if your move the wheel too quickly or "flick" the wheel up or down, the menu will scroll to a menu's end corresponding to that direction.

  #983  
Old 07-27-2007, 01:44 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by wayland View Post
the recently added section of the database is always empty (apart from a random option) for me is this normal?
I don't use that section, however I fixed it. It will be in the next build.

Quote:
also if i select random in recently added i get a divide by zero error
Bad error handling in the patch. This is because the list is empty.

Charles

  #984  
Old 07-27-2007, 02:08 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by steviep View Post
The issue with the scroll wheel skipping to the top/bottom seems to just be on your build and not the current build on the rockbox site. Any idea what patch could be causing it?
Are you talking about this behaviour here:

http://www.rockbox.org/tracker/task/7451

? If you are, it is part of SVN already. I really like it.

Charles

  #985  
Old 07-27-2007, 02:30 AM
A.z's Avatar
A.z A.z is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Israel
Posts: 1,349
Default

yes its annoying to me too, how i can disable it?
__________________
You got that rainbow feel...
But the rainbow has a beard

My Last.fm

  #986  
Old 07-27-2007, 02:42 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by kockroach View Post
Regardless, I will be more than happy to test out a special build for you.
Can you first try my latest build. If you still have problems try this one here:

http://www.anythingbutipod.com/forum...&postcount=395

and report back.

Charles

  #987  
Old 07-27-2007, 02:46 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by whitestar View Post
I currently have your build without the Dc Bias Patch and all Is well, how do I upgrade to your current build almost daily without having to Install this Troublesome Patch.
Can you try my current build and see if you still have problems? If so, try this one here:

http://www.anythingbutipod.com/forum...&postcount=395

If my latest build doesn't work for you and the one without dc-bias does, I will revert the patch.

Charles

  #988  
Old 07-27-2007, 02:49 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by A.z View Post
yes its annoying to me too, how i can disable it?
There is no way to disable it right now. Submit a feature request at the Rockbox site. However, you should try it for a while. You might like it after you get used to it.

Charles

  #989  
Old 07-27-2007, 03:33 AM
stuibb stuibb is offline
Junior Member
 
Join Date: May 2007
Posts: 45
Default

Any chance you could sync with the SVN again?,

A small bugfix that I want synced just after you built yours. No rush though I can wait for the next SVN sync.

  #990  
Old 07-27-2007, 06:44 AM
dzr dzr is offline
Junior Member
 
Join Date: Oct 2006
Posts: 77
Default

A follow up with the radio disappearing act.

I still have the odd issue with the radio disappearing. Radio comes back with a clean install -- I then redo the database and reboot and it disappears. I erase the database and radio comes back. Sometimes it stays once or twice after I redo the database.... and then disappears. (But again, the database doesn't seem to fully initialize with one reboot most of the time either).

This happens with base Rockbox and I posted a msg there... I just wanted to follow up here as well.


I still do have ghost database listings (even if I re-install) and get Data Abort 01F0061C if I select one.

Thanks again!

  #991  
Old 07-27-2007, 06:56 AM
Songokuu's Avatar
Songokuu Songokuu is offline
Junior Member
 
Join Date: Jun 2007
Location: Bielsko-Biala, Poland
Posts: 89
Default

I download your new build and when I play Elephant Dream it plays but I can't stop it and buttons on sansa don't reacting, only wheel lights up whent i turn it but nothing else and i have to shut down with 20 sek. press.

  #992  
Old 07-27-2007, 09:16 AM
kockroach kockroach is offline
Junior Member
 
Join Date: Dec 2006
Posts: 56
Default

Quote:
Originally Posted by cpchan View Post
Can you first try my latest build. If you still have problems try this one here:

http://www.anythingbutipod.com/forum...&postcount=395

and report back.

Charles
Hey Charles,

So I tried your most recent build, and the one referenced above. I still have the problem with both. However, I tried some things. With all of the different builds, I cleaned out my .Rockbox folder each time I switched versions. There were no problems when using the default WPS of Rockbox.

I found that a certain WPS brings about the problem. This WPS uses custom fonts, list positions, text positions and Album art. I wonder if this one is too complex, and as such, causes overload on the CPU.

I also tried an Album art WPS (DockPodAA) that doesn't use the customline, multifont and list patch commands, it only uses Album art. This WPS doesn't have a problem.

So, I don't see a need for that special build, right now. It appears that complex WPSes might be the issue.

Thanks!
~kockroach

  #993  
Old 07-27-2007, 10:03 AM
jgo435 jgo435 is offline
Junior Member
 
Join Date: Sep 2006
Posts: 44
Default

Would it be possible for you to change "multifont_complete-20070713.patch" to "multifont_complete-20070719.patch"?

  #994  
Old 07-27-2007, 10:42 AM
chrisjs162216 chrisjs162216 is offline
Ultra Senior Member
 
Join Date: Oct 2006
Location: Somewhere
Posts: 1,515
Default

Quote:
Originally Posted by jgo435 View Post
Would it be possible for you to change "multifont_complete-20070713.patch" to "multifont_complete-20070719.patch"?
It won't change anything - the only difference between those files is one is more sync'd then the other, which, unless an svn change caused the multifont patch to no longer work, wouldn't have any affect on the build.

  #995  
Old 07-27-2007, 11:16 AM
jgo435 jgo435 is offline
Junior Member
 
Join Date: Sep 2006
Posts: 44
Default

Quote:
Originally Posted by chrisjs162216 View Post
It won't change anything - the only difference between those files is one is more sync'd then the other, which, unless an svn change caused the multifont patch to no longer work, wouldn't have any affect on the build.
I wanted it changed because of the syncing. In your build the text scrolls fine, but in this one if the cursor is over a line that needs to scroll, it scrolls halfway down the screen.

  #996  
Old 07-27-2007, 11:38 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by Songokuu View Post
I download your new build and when I play Elephant Dream it plays but I can't stop it and buttons on sansa don't reacting, only wheel lights up whent i turn it but nothing else and i have to shut down with 20 sek. press.
Strange, I can stop my videos with the "Power" button (short press) or from the context menu (Select button).

Anyone else having problems?

Charles

  #997  
Old 07-27-2007, 11:47 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by jgo435 View Post
I wanted it changed because of the syncing. In your build the text scrolls fine, but in this one if the cursor is over a line that needs to scroll, it scrolls halfway down the screen.
I plan on fixing the scrolling issue and a few UI bugs introduced by the wps patches within the next couple of days.

Charles

  #998  
Old 07-27-2007, 11:53 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by kockroach View Post
I found that a certain WPS brings about the problem. This WPS uses custom fonts, list positions, text positions and Album art. I wonder if this one is too complex, and as such, causes overload on the CPU.
It is a combination of that and you using a CPU intensive codec. Unfortunately, the Rockbox developers have only figured out how to use one core in the device. The second one is idle right now.

Charles

  #999  
Old 07-27-2007, 12:05 PM
steviep's Avatar
steviep steviep is offline
Member
 
Join Date: Jun 2006
Posts: 229
Default

Quote:
Originally Posted by cpchan View Post
Are you talking about this behaviour here:

http://www.rockbox.org/tracker/task/7451

? If you are, it is part of SVN already. I really like it.

Charles
.....maybe im confused.....i downloaded the latest build from http://build.rockbox.org/ and it doesnt flick all the way to the top/bottom when you spin the scroll wheel too fast. i do notice that it does accelerate fast when the wheel is spun fast but it doesnt just skip to the top/bottom of the database. The skipping just seems to happen in your build

  #1000  
Old 07-27-2007, 12:09 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by steviep View Post
.....maybe im confused.....i downloaded the latest build from http://build.rockbox.org/ and it doesnt flick all the way to the top/bottom when you spin the scroll wheel too fast.
This is because there is a slow down in that build due to "Frequency Scaling" being enabled again. This happened after I did my latest build.

Charles

Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 03:03 AM.