android
  #1981  
Old 01-23-2008, 10:58 AM
isanggon isanggon is offline
Junior Member
 
Join Date: Aug 2007
Posts: 81
Default

Thanks, cpchan.

I tested today's build.
Multifont works perfect! And device-disable patch is so good.
But re-added backlight-plugin patch works so strange. The patch turns off my e280's backlight while using plugin. Is this problem happens only for me?

Advertisement [Remove Advertisement]

  #1982  
Old 01-23-2008, 11:49 AM
ricocarlos ricocarlos is offline
Junior Member
 
Join Date: Oct 2006
Posts: 52
Default superb build

Excellent. I am so looking forward to more battery time. Thanks again, sir.

  #1983  
Old 01-23-2008, 02:01 PM
epithetless's Avatar
epithetless epithetless is offline
Ultra Senior Member
 
Join Date: Jul 2007
Location: Boston, Mass
Posts: 1,610
Default

Quote:
Originally Posted by cpchan View Post
I have just uploaded new builds that increase the battery life substantially.
Awesome. Do you happen to know if this new battery-saving patch is slated to be included in official builds?

  #1984  
Old 01-23-2008, 02:04 PM
Benjamin_L Benjamin_L is offline
Junior Member
 
Join Date: Jun 2007
Posts: 22
Default

I'd guess so, would make sense

  #1985  
Old 01-23-2008, 02:06 PM
major_works's Avatar
major_works major_works is offline
Member
 
Join Date: Jun 2006
Posts: 256
Default

It seems as though it's still undergoing testing and refinement. But once the developers are satisfied that it works as advertised without compromising performance, I'm sure it'll be committed.

  #1986  
Old 01-23-2008, 05:00 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by isanggon View Post
But re-added backlight-plugin patch works so strange. The patch turns off my e280's backlight while using plugin. Is this problem happens only for me?
You are correct. I reverting a patch in the build before this due to this problem- now I remember it was this one. I fixed sncviewer to keep the backlight on in the previous build, but I don't want to go through all the plugin for this- I have to look through the code in the patch and see what needs to be changed.

Charles

  #1987  
Old 01-23-2008, 05:01 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by epithetless View Post
Awesome. Do you happen to know if this new battery-saving patch is slated to be included in official builds?
It will be once it is complete and well tested. Look forward to more battery life in the final patch.

Charles

  #1988  
Old 01-24-2008, 04:54 AM
dRdoS7 dRdoS7 is offline
Junior Member
 
Join Date: Jul 2007
Posts: 8
Default

Hi,

I've tried the Rockbox forum but that's not available ATM, so I thought I'd ask here.

I've been using these cpchan builds for a couple of months and they're OK. I just loaded the latest one, but when I connected to my PC it locked up.

I thought I should just go back to the standard Rockbox build, so I used rbutilqt-1.0.3pre to uninstall and re-install the loader & Rockbox. But that locks up as well.

Is anybody else having this problem?

This is what I have :

Sansa E200 01.02.20P
Rockbox r1653-080124

I haven't put cpchan back on yet.

Thanks,

dRdoS7.

Edit: Have gone back to original Rockbox from 15-11-2007, and that's OK when connected to PC. I did a search for "USB lock-up" but couldn't find anything.

Last edited by dRdoS7; 01-24-2008 at 05:42 AM. Reason: Update

  #1989  
Old 01-24-2008, 05:27 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default Please help testing the "Device Disable" Patch

Hello all:

Although I have included the "Device Disable" patch in my builds, however, in order to test this patch properly and have the devs improve upon it, it must be tested in isolation. Therefore I request that you consider downloading the test build referenced in this thread:

http://forums.rockbox.org/index.php?topic=14904.0

test it out and provide some feedback as new versions come out.

Thank you for your cooperation.

Charles

  #1990  
Old 01-24-2008, 05:41 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by dRdoS7 View Post
I've been using these cpchan builds for a couple of months and they're OK. I just loaded the latest one, but when I connected to my PC it locked up.
I have no problems at all. Which Operating System are you using? Can you provide more details such as any error dialogs popping up, etc on the computer. Also are there any error messages on the device?

Charles

  #1991  
Old 01-24-2008, 05:50 AM
Songokuu's Avatar
Songokuu Songokuu is offline
Junior Member
 
Join Date: Jun 2007
Location: Bielsko-Biala, Poland
Posts: 89
Default

I would like to be a part in testing this "better batery life plugin", but could you Charles explain for normal Rockbox@e280 user like me how can I help?
I know I have to use special Rockbox (Device Disable Testing Build) build and then what? Should I just play some music files and make then loop so the sansa will be working until battery runs out? After that send a reply about how long it last?

  #1992  
Old 01-24-2008, 06:05 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by Songokuu View Post
I would like to be a part in testing this "better batery life plugin", but could you Charles explain for normal Rockbox@e280 user like me how can I help?
I know I have to use special Rockbox (Device Disable Testing Build) build and then what? Should I just play some music files and make then loop so the sansa will be working until battery runs out? After that send a reply about how long it last?
You need to run the "Battery Benchmark" plugin on a full charge before doing anything. Here are the details:

http://www.rockbox.org/twiki/bin/vie...tteryBenchmark

Charles

  #1993  
Old 01-24-2008, 07:30 AM
Jeton's Avatar
Jeton Jeton is offline
Member
 
Join Date: Dec 2006
Location: Sėrmnovė, Macedonia
Posts: 326
Default

When i set to YES the (Backlight while in Plugin), and then i open a .txt file the light goes out after 1sec. When i set to NO, the backlight acts normally (as defined in seconds in the Backlight option).

I don't know if the Dim Backlight or the Backlight while in Plugin are causing the problem.

Anyone else experiencing this?

  #1994  
Old 01-24-2008, 08:31 AM
Songokuu's Avatar
Songokuu Songokuu is offline
Junior Member
 
Join Date: Jun 2007
Location: Bielsko-Biala, Poland
Posts: 89
Default

Quote:
You need to run the "Battery Benchmark" plugin on a full charge before doing anything.
But on this special build or I just can use yours?

  #1995  
Old 01-24-2008, 01:18 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by Jeton View Post
I don't know if the Dim Backlight or the Backlight while in Plugin are causing the problem.
It is the "Backlight while in plugin" patch. Something changed in SVN that makes this patch not working. I need to take some time to debug and fix it.

Charles

  #1996  
Old 01-24-2008, 01:21 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by Songokuu View Post
But on this special build or I just can use yours?
Do it in the test build.

Charles

  #1997  
Old 01-24-2008, 02:48 PM
dRdoS7 dRdoS7 is offline
Junior Member
 
Join Date: Jul 2007
Posts: 8
Default

Hi,

Sorry, I should have been clearer: my Sansa locks up, not my PC. The scroll wheel lights up and I have to remove the battery to switch it off.

dRdoS7

Last edited by dRdoS7; 01-24-2008 at 02:49 PM. Reason: spelling

  #1998  
Old 01-24-2008, 02:53 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by dRdoS7 View Post
Sorry, I should have been clearer: my Sansa locks up, not my PC. The scroll wheel lights up and I have to remove the battery to switch it off.
Have you tried doing a hard shutdown (hold down the power button for 15-20 seconds)?

Charles

  #1999  
Old 01-24-2008, 03:31 PM
strobeyprobey strobeyprobey is offline
Junior Member
 
Join Date: Sep 2007
Posts: 1
Default

My e280 was similarly locking up, but it is not locking up. You need to hold the select (center button) down while plugging in the Sansa to disable the not-yet-working USB driver.

(If I forgot to hold to the select button down, holding the power button for 20-30 seconds did work for me to shut it down)

Good luck.

cpchan, Thanks for a great build!

  #2000  
Old 01-24-2008, 08:10 PM
Nemesis02 Nemesis02 is offline
Junior Member
 
Join Date: Nov 2007
Posts: 12
Default

The new viewport patches seems to be causing massive slow downs in the e200 series. Maybe cause there's not enough processing power to support it, or there's a problem with the sync.

Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:35 PM.