android
Go Back   abi>>forums > MP3 Players By Brand > SanDisk Sansa > Sansa e200 > Sansa e200 Rockbox

Reply
 
Thread Tools Search this Thread Display Modes
  #41  
Old 03-16-2007, 05:53 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by capo327 View Post
Well the source file worked for me when I wrote my own mencoder command.
So, continue using it. I can't really say anything about videolan since I have never used it before. I use mplayer/mencoder too. However, I know that vidoelan use avcodec also.

Quote:
The thing is, the video's kind of blocky and out of sync with the audio.
Is it blocky in mplayer?

Quote:
I'm not sure if it's because I used a bad setting or if it's rockbox's fault, though I assume it's mine.
From what I know syncing haven't been optimized yet. You should enable "Limit FPS" and "Skip Frames" in Rockbox.

I
Quote:
t also says here that the res automatically resizes to 220x176, so I just used that instead.
Yes, but why waste space on a flash player with larger files?

Charles

UPDATE: I just noticed that you specify/change the output framerate to 25 FPS with -ofps 25 in your mencoder command. So try adding fps=25 as specified in the comments in the batch file and see if it works.
Reply With Quote

Advertisement [Remove Advertisement]

  #42  
Old 03-16-2007, 06:06 PM
capo327's Avatar
capo327 capo327 is offline
Junior Member
 
Join Date: Sep 2006
Posts: 37
Default

How do I edit the fps in the batch file?

Also, in my mencoder command I noticed I put a low video bitrate, so I thought I'd change it to the suggested bitrate of 469 and see if that'd change the blockiness, but now the video won't work. Might that be the problem?

EDIT: I just added FPS=25 in their statement like you said, and I change the res to 224x176, and it works now. Thanks for the help, dude.
Reply With Quote

  #43  
Old 03-16-2007, 06:30 PM
testdasi's Avatar
testdasi testdasi is offline
Member
 
Join Date: Oct 2006
Location: Providence, RI
Posts: 432
Default

mencoder <input> -of mpeg -oac lavc -lavcopts acodec=mp2:abitrate=192 -af resample=44100:0:0 -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=<bitrate> -vf scale,harddup -ofps 25 -zoom -xy <the width> -o <filename>.mpg

1. abitrate=128 is good enough.
2. vbitrate=256 is good enough (I encoded my Dead Or Alive in 256 and there was no problem whatsoever, the pictures quality was not bad)
3. to avoid "blockiness", do not enter anything at scale and enter 220 to replace <the width>. When you watch the video, you will notice a small distorted band at the bottom. It's because the video and the screen has different ratio and the plugin makes no attempt of resizing the video. Attempting to change the ratio (by defining scale) causes "blockiness".
Reply With Quote

  #44  
Old 03-16-2007, 06:38 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by capo327 View Post
How do I edit the fps in the batch file?
According to the comment, it looks like you should change:

"C:\Progra~1\VideoLAN\VLC\vlc.exe" %1 --sout=#transcode{vcodec=mp2v,vb=%VIDBR%,width=%WIDT H%,height=%HEIGHT%,acodec=mp3,ab=%AUDBR%,samplerat e=44100,audio-sync}:std{access=file,mux=ps,url=%1.mpg} vlc:quit

to

"C:\Progra~1\VideoLAN\VLC\vlc.exe" %1 --sout=#transcode{vcodec=mp2v,vb=%VIDBR%,width=%WIDT H%,height=%HEIGHT%,acodec=mp3,ab=%AUDBR%,samplerat e=44100,audio-sync,fps=25}:std{access=file,mux=ps,url=%1.mpg} vlc:quit

(sorry about the formating, but I have no control over it). If this work, maybe this should be the default in the script.

Quote:
Also, in my mencoder command I noticed I put a low video bitrate, so I thought I'd change it to the suggested bitrate of 469 and see if that'd change the blockiness, but now the video won't work. Might that be the problem?
Interesting the video bitrate set in the script is actually 600. I guess you can try lowering it to see if it works.

Charles
Reply With Quote

  #45  
Old 03-16-2007, 06:51 PM
capo327's Avatar
capo327 capo327 is offline
Junior Member
 
Join Date: Sep 2006
Posts: 37
Default

Thank, both of you guys. I did what you said, Testdasi, and it works now. The mencoder output is smaller than the vlc output, so I'll be using that mencoder command for now on. Thanks, people.
Reply With Quote

  #46  
Old 03-16-2007, 06:55 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by capo327 View Post
I just added FPS=25 in their statement like you said, and I change the res to 224x176, and it works now.
Can you test the attached batch files to see if they work for the people who want to use VLC? I have lowered the vid bitrate to the recommended one and add fps=25.

Quote:
Thanks for the help, dude.
No problem.

Charles
Attached Files
File Type: zip transcode_batch_files_reprise.zip (2.1 KB, 22 views)
Reply With Quote

  #47  
Old 03-16-2007, 07:19 PM
capo327's Avatar
capo327 capo327 is offline
Junior Member
 
Join Date: Sep 2006
Posts: 37
Default

Quote:
Originally Posted by cpchan View Post
Can you test the attached batch files to see if they work for the people who want to use VLC? I have lowered the vid bitrate to the recommended one and add fps=25.
Yeah, they're perfect! Great job.
Reply With Quote

  #48  
Old 03-16-2007, 07:24 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by capo327 View Post
Yeah, they're perfect! Great job.
Great. I will clean some stuff up, make a mencoder version for both Windows and Linux over the weekend and upload them to the programs forum.

Charles
Reply With Quote

  #49  
Old 03-16-2007, 09:05 PM
testdasi's Avatar
testdasi testdasi is offline
Member
 
Join Date: Oct 2006
Location: Providence, RI
Posts: 432
Default

Quote:
Originally Posted by testdasi View Post
mencoder <input> -of mpeg -oac lavc -lavcopts acodec=mp2:abitrate=192 -af resample=44100:0:0 -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=<bitrate> -vf scale,harddup -ofps 25 -zoom -xy <the width> -o <filename>.mpg

1. abitrate=128 is good enough.
2. vbitrate=256 is good enough (I encoded my Dead Or Alive in 256 and there was no problem whatsoever, the pictures quality was not bad)
3. to avoid "blockiness", do not enter anything at scale and enter 220 to replace <the width>. When you watch the video, you will notice a small distorted band at the bottom. It's because the video and the screen has different ratio and the plugin makes no attempt of resizing the video. Attempting to change the ratio (by defining scale) causes "blockiness".
I allso forgot one thing.
4. -ofps 12 will greatly reduce file size with no noticable effect because the video output is at about 12 fps anyway.
Reply With Quote

  #50  
Old 03-16-2007, 09:18 PM
oregon oregon is offline
Senior Member
 
Join Date: Nov 2006
Location: Oregon
Posts: 530
Default

Quote:
Originally Posted by cpchan View Post
I fixed it for you. There are 2 batch files in the archive: one for standard res and one for wide screen. Please test them out.

Charles
Thank you! This works, is easy, and reduces reduces the files to less than 1/8 of the AVI source file. The video and audio are off-sync, but I know this is a problem with Rockbox, not the conversion. I've enable skip-frames, and this helps alot, is there anything else I can do?
Reply With Quote

  #51  
Old 03-16-2007, 10:51 PM
testdasi's Avatar
testdasi testdasi is offline
Member
 
Join Date: Oct 2006
Location: Providence, RI
Posts: 432
Default

Now think of it. I think the main factor that almost eliminate off-sync-ness in my videos was the 12 fps.
Reply With Quote

  #52  
Old 03-16-2007, 11:15 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by testdasi View Post
Now think of it. I think the main factor that almost eliminate off-sync-ness in my videos was the 12 fps.
Most likely, because it doesn't have to drop frames. Have you tried 15 fps to see if the video is slightly smoother?

Charles
Reply With Quote

  #53  
Old 03-16-2007, 11:20 PM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by oregon View Post
I've enable skip-frames, and this helps alot, is there anything else I can do?
Try this batch file to see if it will play and if the sync is better.

Charles
Attached Files
File Type: zip VLC-transcode_standard.zip (1.0 KB, 11 views)
Reply With Quote

  #54  
Old 03-16-2007, 11:36 PM
testdasi's Avatar
testdasi testdasi is offline
Member
 
Join Date: Oct 2006
Location: Providence, RI
Posts: 432
Default

I did. I turned on the option to show frame rate and no matter what frame rate I tried, it's always played at about 12 fps (11.xx fps). So the player can't go beyond 12 fps, why waste disc space by encoding it at above 12 fps?
Reply With Quote

  #55  
Old 03-17-2007, 12:00 AM
cpchan's Avatar
cpchan cpchan is offline
Ultra Senior Member
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 2,012
Default

Quote:
Originally Posted by testdasi View Post
So the player can't go beyond 12 fps, why waste disc space by encoding it at above 12 fps?
Interesting because according to the performance chart here
it is suppose to be 15 fps for the Sansa 200 series.

Charles
Reply With Quote

  #56  
Old 03-17-2007, 09:27 AM
Zwack Zwack is offline
Junior Member
 
Join Date: Dec 2006
Location: Oregon, USA
Posts: 73
Default

So the Sansa is supposed to be capable of displaying 15 fps, but only shows 12 under rockbox... Did anyone consider that this might be a performance issue with Rockbox that may be resolved later. If it's capable of 15fps in native firmware then it's a software difference and things wil improve... but if everyone converts to 12fps then they'll never know if it has improved.

Z.
Reply With Quote

  #57  
Old 03-17-2007, 09:28 AM
testdasi's Avatar
testdasi testdasi is offline
Member
 
Join Date: Oct 2006
Location: Providence, RI
Posts: 432
Default

I convert on a file by file basis. After finish watching, I delete them. So I may test it out every month or so to see if it's better at 15 fps. But what's wrong with 12 fps? It's watchable.
Reply With Quote

  #58  
Old 03-17-2007, 11:23 AM
Llorean Llorean is offline
Rockbox Developer
 
Join Date: Dec 2006
Posts: 397
Default

That performance chart is based on actual number: Framerates people have actual gotten.

It's not "How the Sansa Performs" but "How Rockbox performs on the Sansa."

On suggestion: Try lowering the bitrate on your files, as this can allow higher framerates in some cases.
Reply With Quote

  #59  
Old 11-09-2007, 12:25 AM
JCFantasy23's Avatar
JCFantasy23 JCFantasy23 is offline
Member
 
Join Date: Aug 2006
Posts: 187
Default

I use WinFF, works flawlessly for me so far.
__________________
Sansa e240 - Rockboxed
Zen V (2gb)
My Last.fm Media Monkey Fanatic
Reply With Quote

  #60  
Old 07-09-2008, 09:19 AM
wilpb14 wilpb14 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 1
Default

definately WinFF. its free and includes really userfriendly conversion methods for any device.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 12:25 AM.