android
  #61  
Old 04-15-2007, 05:45 PM
Raptor44 Raptor44 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 5
Default disk check

Can you disk check in MTP mode somehow? I synced my songs in MSC mode, but some of them won't play. There's a popup that comes up that says "sync to renew subscription songs." I don't quite understand when you say to secure them and whatever else the steps are. Could you help me understand what to do so that I can listen to my music. (when I sync my songs in MTP mode, my mp3 player turns off, but when I synced them in MCP mode, some of them played instead of just restarting my player. On the other hand now that popup comes up.) If I do follow your steps will I still be able to listen to the music that is blocked right now with the popup? I'd love to know!

Last edited by Raptor44; 04-15-2007 at 09:19 PM.
Reply With Quote

Advertisement [Remove Advertisement]

  #62  
Old 04-16-2007, 12:09 PM
kennyj kennyj is offline
Member
 
Join Date: Feb 2007
Posts: 303
Default

Raptor: Follow the instructions that muffinzrock provided in MSC mode, at the very least. You can't do a chkdsk in MTP because for chkdsk to work, Windows needs to have it mounted as a drive.

Realistically, you might find that your life will be easier if you just reformat in MSC mode, then format it again in MTP. This should resolve your issues - usually, reformatting in MSC fixes 90% of issues where MTP crashes the player, and reformatting in MTP is the quickest/easiest way to resolve licensing issues.

Your problems with the sync error, however, are likely just because you didn't sync the protected files in MTP mode. That's kind of a requirement.
Reply With Quote

  #63  
Old 04-17-2007, 04:01 PM
Mjdgard Mjdgard is offline
Junior Member
 
Join Date: Jun 2006
Posts: 3
Default

I try to follow the instructions. However, I am unable to downgrade my Sansa.
When I run the Sansa downgrader linked on the first post I receive the following message: "Your device is connected in Recovery mode. Please click next [...]" --next--> "Error: The downloaded Image is not compatible with the connected device."

Anyone knows what this means and how I can fix it? I have an E player with modded A firmware & dualboot rockbox.

Thanks.
Reply With Quote

  #64  
Old 04-17-2007, 04:33 PM
muffinzrock's Avatar
muffinzrock muffinzrock is offline
Senior Member
 
Join Date: Jan 2007
Location: in a muffin. duh. xD
Posts: 637
Default

Quote:
Originally Posted by Mjdgard View Post
I have an E player with modded A firmware
thats why. heres a link to the older european and american firmware:
http://zefie.com/files/PMP/sansa/e200/firmware/1.00.12/
use 7zip (www.7-zip.com) to extract the files.

also, the downgrade firmware step is optional.
__________________
view my ultimate fix...or download as plain text for reference
my star wars theme (updated 29/Mar/07)
Switchfoot and Relient K are THE BEST!!
Reply With Quote

  #65  
Old 04-17-2007, 07:35 PM
dav512 dav512 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 3
Default Help Please

hey i couldn't do this
(Run this to downgrade the firmware (NON-R PLAYERS ONLY):
http://www.sandisk.com/Assets/File/D...fw01.00.12.exe )

i ran the program and it said ( ERROR application failed to read the version details)
it sucks because my sansa player just refreshes when i turn it on and it always stops refreshing in the same place and i turn it off and turn it off again and it just KEEPS DOING THE SAME THING AAAAAAA PLEASE HELP!!!!!!
Reply With Quote

  #66  
Old 04-17-2007, 08:05 PM
muffinzrock's Avatar
muffinzrock muffinzrock is offline
Senior Member
 
Join Date: Jan 2007
Location: in a muffin. duh. xD
Posts: 637
Default

welcome aboard the U.S.S ABi (lol)
try manually installing the firmware from this link:
http://zefie.com/files/PMP/sansa/e200/firmware/1.00.12/
and like i said above, use 7zip to extract.
__________________
view my ultimate fix...or download as plain text for reference
my star wars theme (updated 29/Mar/07)
Switchfoot and Relient K are THE BEST!!
Reply With Quote

  #67  
Old 04-17-2007, 08:19 PM
dav512 dav512 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 3
Default

yea i tried this but when it starts up it starts up normally then when it says Refresh Database and it doing that but then it stops not even a quarter way of the loading bar... WHAT DO I DO ITS DRIVING ME CRAZIE i think i have a currupt file ive already tried what was said above... what do i do
Reply With Quote

  #68  
Old 04-21-2007, 07:56 AM
muffinzrock's Avatar
muffinzrock muffinzrock is offline
Senior Member
 
Join Date: Jan 2007
Location: in a muffin. duh. xD
Posts: 637
Default

try the fix again, if it doesnt work, try the one in slaughter's sig
__________________
view my ultimate fix...or download as plain text for reference
my star wars theme (updated 29/Mar/07)
Switchfoot and Relient K are THE BEST!!
Reply With Quote

  #69  
Old 04-29-2007, 02:57 PM
hoanglong hoanglong is offline
Junior Member
 
Join Date: Jan 2007
Posts: 3
Default

i already am using 1.02.15A firmware does this fix the refresh database bug everytime the player does system restart?

thanks in advance
Reply With Quote

  #70  
Old 04-30-2007, 05:05 PM
muffinzrock's Avatar
muffinzrock muffinzrock is offline
Senior Member
 
Join Date: Jan 2007
Location: in a muffin. duh. xD
Posts: 637
Default

there's a refresh database bug?
__________________
view my ultimate fix...or download as plain text for reference
my star wars theme (updated 29/Mar/07)
Switchfoot and Relient K are THE BEST!!
Reply With Quote

  #71  
Old 04-30-2007, 05:19 PM
kennyj kennyj is offline
Member
 
Join Date: Feb 2007
Posts: 303
Default

There isn't.

hoanglong: It is normal for the player to do this when it is in MSC/Rhapsody mode. If it does this at other times, you have a problem and probably need to reformat.
Reply With Quote

  #72  
Old 04-30-2007, 10:50 PM
Ponch Ponch is offline
Junior Member
 
Join Date: Nov 2006
Posts: 7
Default

Thank you SO MUCH! I have had my Sansa for MONTHS now and could not for the life of me get it to update the firmware! YOU ROCK!!!
Reply With Quote

  #73  
Old 05-02-2007, 04:47 PM
muffinzrock's Avatar
muffinzrock muffinzrock is offline
Senior Member
 
Join Date: Jan 2007
Location: in a muffin. duh. xD
Posts: 637
Default

no prob!
BTW, RCM made a program that carries out these steps automatically. its pretty cool.
__________________
view my ultimate fix...or download as plain text for reference
my star wars theme (updated 29/Mar/07)
Switchfoot and Relient K are THE BEST!!
Reply With Quote

  #74  
Old 05-02-2007, 04:57 PM
tlr3 tlr3 is offline
Junior Member
 
Join Date: Dec 2006
Posts: 8
Default

yay!

this fix has managed to correct a couple of silly little problems on my sansa:

1. getting rid of a song that windows can't see as being on there even though the player does.

2. getting the player to see some songs that windows can see but it can't.

it may very well have fixed other things, but for the record, it seems to fix those. . .

thanks!

tom
Reply With Quote

  #75  
Old 05-02-2007, 11:11 PM
RCM's Avatar
RCM RCM is offline
Ultra Senior Member
 
Join Date: Mar 2007
Location: I'm not telling
Posts: 1,549
Default

Thanks muffinz I did one for the R series too look in the post I'm surprised it's not stickied or anything
__________________
Sansa View 16GB (DEAD)
Sony Walkman NWZ-S544 (DEAD has a mind of it's own and don't feel like fixing it!)
Zune HD 32GB (Retired)
Samsung Galaxy tab 2 7.0
Motorola Droid razr m
Reply With Quote

  #76  
Old 05-04-2007, 04:49 PM
muffinzrock's Avatar
muffinzrock muffinzrock is offline
Senior Member
 
Join Date: Jan 2007
Location: in a muffin. duh. xD
Posts: 637
Default

sweet- nice job, man!
__________________
view my ultimate fix...or download as plain text for reference
my star wars theme (updated 29/Mar/07)
Switchfoot and Relient K are THE BEST!!
Reply With Quote

  #77  
Old 05-09-2007, 09:45 PM
Xia Xia is offline
Junior Member
 
Join Date: Oct 2006
Posts: 25
Question

Ok...stupid question time.
I started the process in the OP. I got to this point:
"Run this to downgrade the firmware (NON-R PLAYERS ONLY):"

I started running that program that they said to run, 'Sansa e200 Series Firmware Updater', and it is showing me this screen:

WARNING
If you choose to format this device, all data and information will be erased!
Please press next to upgrade the device.

Then the choices are:
Yes I want to format drive
or
No I do not want to format drive



What do I do now? The original post says "DO NOT FORMAT FROM YOUR COMPUTER IN RECOVERY MODE" so do I choose 'no'? Or does this not count as formatting from computer in recovery mode, or what?
Reply With Quote

  #78  
Old 05-09-2007, 10:49 PM
RCM's Avatar
RCM RCM is offline
Ultra Senior Member
 
Join Date: Mar 2007
Location: I'm not telling
Posts: 1,549
Default

Use my program if you are nervous about it, it will copy a special file to the player to format it
__________________
Sansa View 16GB (DEAD)
Sony Walkman NWZ-S544 (DEAD has a mind of it's own and don't feel like fixing it!)
Zune HD 32GB (Retired)
Samsung Galaxy tab 2 7.0
Motorola Droid razr m
Reply With Quote

  #79  
Old 05-10-2007, 12:03 AM
Xia Xia is offline
Junior Member
 
Join Date: Oct 2006
Posts: 25
Default

Ok I got past the problem I had but I am still confused.

The instructions say to add the files "Add this firmware either normally in MSC mode, or in recovery mode if necessary." and "unzip it, and drag-and-drop the .rom and .mi4 to the 16MB thing." BUT it is in MSC Mode so there is no 16MB thing to add this into...so what do I do?

Anyway when I did the first part about downgrading the firmware, the player now works again so do I really need to do this next step that will force-format the player, or can I just leave it alone and download the newest firmware then put my music back on?
Reply With Quote

  #80  
Old 05-10-2007, 12:44 PM
Gibbo Gibbo is offline
Junior Member
 
Join Date: May 2007
Posts: 21
Default

in the end, problem solved by taking the battery out and leaving it out for about 10 minutes. I've now done the ultimate fix - panic over, and I'll leave him positive feedback so it all ends happily.

Thanks all for your help, I'm sure I'll stick around on here now

Bought an e270 off eBay thinking I'd got a bargain at 60.

Arrived in the post today, I turned it on and it was about halfway charged.

Then after playing with it for only about 2 minutes the screen slowly faded to blue with 2 black vertical lines going down the left hand side of the screen. I did the recovery (10 second hold down on shutdown) which turned the player off.
I then tried to turn it on again but it's just a black screen with the scrollwheel lit up blue. Holding the shutdown button now does nothing.

Turned it off by opening the back up, taking battery out - putting battery back in but no matter what I do nothing is happening on the screen

I've tried connecting it to computer and everything but nothing seems to work.

Come unstuck at the first step of the ultimate fix
"enter recovery mode. if you dont know how to, you just need to put the hold switch on so you see orange, hold down the record button and turn the player on. keep holding the record button until you see:
Welcome to recovery mode"

The screen just remains black, no backlight or anything comes on, only the colour on the scrollwheel comes on as soon as i hook it up to the computer and press the on/off button. Nothing happens by holding down the REC button when turning on either

Last edited by Gibbo; 05-10-2007 at 01:36 PM.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:39 PM.