android
  #1  
Old 01-16-2014, 07:51 PM
al3rd al3rd is offline
Junior Member
 
Join Date: May 2010
Location: Manila, Philippines
Posts: 59
Help Custom WPS: CabbieV2 Need Help

Good Day!

Im editing my wps to support unicode formats as I edited it and run it on the simulator the album year doesn't appear nicely (see photos)



the question is do i have to remove the album year? or align the wps layout?? or is it possible to change the fonts of album year (only) ?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 01-16-2014, 08:01 PM
epithetless's Avatar
epithetless epithetless is offline
Ultra Senior Member
 
Join Date: Jul 2007
Location: Boston, Mass
Posts: 1,610
Default

I can't give you detailed solution without really digging into the WPS file and spending more time on this than I should, but it looks to me like the viewport (i.e. "display window with invisible boundaries") for that section of text is too short to accommodate the final line containing the year now that you're using a larger font. You should be able to fix it by increasing the Y coordinate for the viewport, effectively making it taller. Take a look at the CustomWPS wiki for more info on the viewport syntax.
__________________
Rockbox Themes:
Sansa Fuze: XL Fuzed // Sansa Clip/Clip+: Cliplined
Reply With Quote

  #3  
Old 01-16-2014, 08:27 PM
al3rd al3rd is offline
Junior Member
 
Join Date: May 2010
Location: Manila, Philippines
Posts: 59
Default

Sir may I ask what string in this code i need to adjust ???

Track Info - Album Art
%ax%Vl(a,51,09,-,34,2)
%s%al%?it<%it|%fn>
%s%al%?ia<%ia|%?d(2)<%d(2)|%(root%)>>
%s%al%?id<%id|%?d(1)<%d(1)|%(root%)>>
%s%al%?iy<%iy>
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 02:38 PM.