android
Go Back   abi>>forums > MP3 Players By Brand > Cowon iAudio > Cowon Z2

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 06-01-2013, 05:16 AM
Vinny-Vidi-Vici Vinny-Vidi-Vici is offline
Junior Member
 
Join Date: Nov 2012
Posts: 4
Help Z2 Dead battery, startup issues prevent access to home screen

Okay, so about maybe an hour ago, my Z2 just did a long vibrate before turning off. It was face-down on my desk, so I don't know if it was just playing without my knowing since yesterday evening.

It wouldn't turn on after it shut off, so I assumed it was a dead battery. I plugged it into my computer, no response, so I plugged the USB cord to an adapter and just plugged it in the outlet. Success! It went to the start-up screen...and then I hit the dead end.

I don't know what's going on, but the screen just says
p l e n u e
c o w o n

And what happens instead of the fancy startup animation with all the letters, is that the "plenue/cowon" logo will just keep blinking, striking a black line in random places on the text every other blink.

I figured it just didn't have enough juice to power up, so I let it sit on the charger, but I didn't like that it kept blinking. No transition to even a "charging battery" icon or something (I have never had the battery die on me before so I don't know what happens when it does. I've had the Z2 freeze and randomly start up on the rarity, but nothing else.)

If it's removed from the charger when the text is off, the Z2 just stays off. If it's removed when the text is on the screen, the text will stay, but then a gradient-effect happens in the background and the lower part of the display just starts turning green and then grey-ish, stretching into the top part. Didn't like that, so I just hit the power button and it shut off.

Nothing happened while it wasn't in use; it stayed on my desk for the rest of the evening, so I just wanted to see if I was the only one this happened to or if this is expected when the Z2 dies. I just don't want to try letting it sit on the charger for a while without knowing what the blinking is about or whether or not it is corrupting the hardware and all my content on the Z2.

I can't use the warranty if it's not a dead battery because I cracked the screen around January/February, so the warranty is voided.

Any thoughts? Should I let it sit on the charger and see what happens or should I just get ready to buy a new one?

EDIT: Never mind! It started up. I let it sit on the charger one more time and didn't touch it. It's on now!

Last edited by Vinny-Vidi-Vici; 06-01-2013 at 05:44 AM. Reason: issue solved
Reply With Quote

Advertisement [Remove Advertisement]

 

Tags
battery issue, cowon z2, startup problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:05 PM.