android
Prev Previous Post   Next Post Next
  #1  
Old 03-13-2013, 12:00 PM
lurker212 lurker212 is offline
Junior Member
 
Join Date: May 2012
Posts: 2
Exclamation Archos 43 Unexpectedly Stops Working

I've had this great device for a year now when it all of a sudden just stopped yesterday. The device was around 35% still when it was last fully on; 4 hours later when trying to turn it on -it didn't. I was not doing anything differently. The player is mostly used for music, Words With Friends & a weather app.

I have tried the following:

I have held the power button for a good 5 minutes.

I held down the power and +volume, and even held down the power and -volume, to try to do the RESET like the manual suggests. Held for good 5 minutes to try to get the RESET screen to show.

The device is not read by USB being plugged into a computer, so, I have plugged in with a USB charging adapter via a wall plugin for close to 12 hours. Still nothing. I have gotten no response from it. No light or anything.

Can anything be done? Is it dead? Is there a way to get the music & files back? Just really not sure what to do here.

Any suggestions are welcome!
Reply With Quote

Advertisement [Remove Advertisement]

 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:25 PM.