android
  #1  
Old 11-13-2012, 08:33 PM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default YP-R0 - Stuck/Freeze/Reboot during boot

I recently discover that some lots of YP-R0 are having some boot issue.
This appen with all ROMs (Official, ModFirm, LightROM and all other minor modifications), and it's probably caused by a defective NAND chip. These freezes are caused by a Kernel Panic while inserting the NAND Samsung module wmr.ko.
Probably there are some bad sectors in NAND, and they cause random freezes or reboot during startup.
If the bad sectors are in the bootloader and in the kernel partition the player won't never boot up, but it only stuck on "Samsung" logo or Linux penguin (in case of any modded ROM is installed). In this case you could only try to reflash with the "flash cable".
If the bad sectors are on cramfs or in other partitions (media0, media1) the player will stuck on Samsung/Linux logo for about 15 seconds, then it will reboot automatically until it can correct all bad sectors found.


Cases of damaged YP-R0:
YP-R0 CB/XER , S/N 1U0Z969____ , Ver: 8Gb.
YP-R0 JEP/EDC, S/N 1U1SA12____ , Ver: 16Gb.
YP-R0 JCB/EDC, S/N 1U1V911____ , Ver: 8Gb.

At the moment it seems that YP-R0 with serial number starting with "1U" could have a defective chip.


This thread is for informational and statistical purposes only. If you are also having this kind of issues, please, report here the details of your YP-R0 as above.

EDIT:

Update 20121209:
The 1U0Z969____ player is back to work after some random power on and reset.

Update 20121227:
The 1U1SA12____ player is definitely dead after an ECC error during flash with ATK tool.



tags: defective r0 nand wmr serial 1U freeze bootloader stuck samsung linux logo penguin

Last edited by VanniX; 12-27-2012 at 08:25 AM.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 11-22-2012, 03:56 PM
Lorenz092 Lorenz092 is offline
Member
 
Join Date: Jan 2011
Location: Italy
Posts: 449
Default

Mine has never had such problems so far (and I must say flashing had been like drinking water for this player xD)...

Some more info:

YP-R0 JES/EDC, S/N 1RXSB____, 16GB Silver

NO rockbox flickering
NO bad flash
NO original...
...VERY "customized" during past year so far haha ;D
__________________
Check out my modded firmware both for YP-R0 and YP-R1!!!
** DONATE ** -> https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=K658CHJKX2X8C
NOTE: if you want to donate for Rockbox itself and not my work, go to their website!!
Reply With Quote

  #3  
Old 11-24-2012, 07:01 AM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default

Also mine are both 1R, and I've never had any problems.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 10:50 PM.