android
  #1  
Old 10-15-2012, 07:20 AM
ubernoob ubernoob is offline
Junior Member
 
Join Date: Mar 2011
Posts: 4
Default Has anyone had their Z2 apart?

A couple of days ago I came off my bike and landed on my Z2, after getting up I noticed there was no sound so I switched it off but it refused to switch back on.

It was low on battery so I plugged it into the car charger and noticed the light on the charger flickering so I removed the lead and the Z2 started to get quite warm. It kept getting hotter until the battery presumably ran flat.

I have had a look at the board and it looks as if a couple of components have been hot and it seems at least one diode has shorted.

Should I bother sending this thing off for repair or is it most likely toast?
I'm not hugely worried as it wasn't a very good player and I am now wondering if I can fit a SSD to my old Toshiba S60.

Thanks gents.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 10-30-2012, 06:58 PM
ubernoob ubernoob is offline
Junior Member
 
Join Date: Mar 2011
Posts: 4
Default

I got it apart but it seems it's fried, a couple of bits have shorted and have heat damage.

What to buy next?
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:25 AM.