android
  #1  
Old 02-23-2011, 11:49 PM
leavenfish leavenfish is offline
Junior Member
 
Join Date: Feb 2010
Posts: 48
Default Hidden Music on My Clip +

I store music by Album on my Clip+.
I do this by opening My Documents where the Albums are stored. Then I go to My Computer on the desktop, open it. Then I click on the Sansa Clip+ icon, then Internal memory. I then drag and drop albums into the Music folder in the clip+'s internal memory.

Question: I also delete the albums I do not want to have on the Clip+ by accessing the music folder on the clip via My Computer, and I right click my mouse and hit delete...and the Album disappears. It seems to free up space on the Clip + so that I can load more albums.

I no longer see the album in the Music folder on the Clip+. However, when I go walking and listen to the Clip+....all the 'deleted' albums, are still there...and I can play them. How do I get rid of them? What am I doing wrong?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 02-24-2011, 12:05 AM
esanthosh's Avatar
esanthosh esanthosh is offline
Member
 
Join Date: Oct 2009
Location: India
Posts: 207
Default

Any chance you used MTP mode for transfer in the past?
Reply With Quote

  #3  
Old 02-24-2011, 10:16 PM
leavenfish leavenfish is offline
Junior Member
 
Join Date: Feb 2010
Posts: 48
Default

Quote:
Originally Posted by esanthosh View Post
Any chance you used MTP mode for transfer in the past?
Honestly I don't know. I've never synchronized, just dragged and dropped as I mention above. I may not have mentioned that I rip them using Windows Media Player. I'd just like to remove some old albums and am not sure how to.

I don't even see a setting for MSC or MTP. Now, I use both Clip's and Clip +'s and one Fuze which does have a MicroSD card.

Just spent a bit searching the site for MTP vs MSC...still not finding an answer.
Reply With Quote

  #4  
Old 02-24-2011, 10:22 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

In the settings menu, look for USB mode. If you've not been aware of its existence, then your player is most likely in "Auto-defect" mode, as I call it....so it defaults to MTP if it can, but sometimes goes into an MSC type mode.

Your best bet is to remove all music from the player, with your computer.....disconnect it, then go to the USB menu and select MSC, and then reload your player. Instead of "internal memory" you will just see the other folders....music, podcasts, videos, recordings, etc. Drag and drop will be a snap, and when you delete tunes, they will be gone, not just hidden.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #5  
Old 02-26-2011, 12:22 AM
leavenfish leavenfish is offline
Junior Member
 
Join Date: Feb 2010
Posts: 48
Default

Quote:
Originally Posted by Marvin the Martian View Post
In the settings menu, look for USB mode. If you've not been aware of its existence, then your player is most likely in "Auto-defect" mode, as I call it....so it defaults to MTP if it can, but sometimes goes into an MSC type mode.

Your best bet is to remove all music from the player, with your computer.....disconnect it, then go to the USB menu and select MSC, and then reload your player. Instead of "internal memory" you will just see the other folders....music, podcasts, videos, recordings, etc. Drag and drop will be a snap, and when you delete tunes, they will be gone, not just hidden.
You da man! Thanks!!
Reply With Quote

  #6  
Old 02-26-2011, 12:30 AM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by leavenfish View Post
You da man! Thanks!!
My pleasure.....enjoy the Clip+!
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #7  
Old 08-20-2012, 09:51 PM
johnny english johnny english is offline
Junior Member
 
Join Date: Aug 2012
Posts: 3
Default

Hi there, apologies for necroing a thread with my first post but I have this same problem with my Sansa Clip. I've followed the instructions in the thread but the albums still appear in the Music menu of the Clip - when I connect it to my PC, the Music folder shows as empty. Any suggestions as to how I delete entire albums from the device and make them actually disappear, please?
Reply With Quote

  #8  
Old 08-20-2012, 10:29 PM
Syndrome's Avatar
Syndrome Syndrome is offline
Redneck Moderator
 
Join Date: Dec 2007
Posts: 1,278
Default

Did you check the music folder in MTP mode? When you switch you have to go in to MTP mode and get all your music then switch and paste in MSC mode.
__________________

Ruger M77 , Howa 1500 , Czech Republic 452-2E
Ruger .22 Single Six, Springfield Armory XD-9 , Springfield Armory XD45ACP
2007 Elite Archery Synergy

Gamo CFX, Gamo PT80
Large Rock


Need your headphones fixed or something soldered? Syndrome's Soldering Service
Reply With Quote

  #9  
Old 08-20-2012, 10:48 PM
johnny english johnny english is offline
Junior Member
 
Join Date: Aug 2012
Posts: 3
Default

Not sure what you mean. I tried switching between MTP and MSC mode, regardless of the setting in the USB menu the deleted albums still appeared on the player although they didn't show in the folder when it was connected to the PC, and Properties on the folder still showed the albums taking memory space.

Edit: my scenario is ever so slightly different to the OP's, although probably not different at all. I am using a Linux machine, when I connect the Clip it launches a folder view which shows me the folders on the device - Music, Audiobooks, Podcasts etc. I have been copying albums and podcasts into the respective folders, if I delete them using the menu on the device then they disappear for good but if I do it via the PC, the PC stops seeing their presence but they're still available to me using the device menus and the Properties view shows them taking up the space. I've just formatted the device to get rid of them all, but I'm going to have the same problem again once I get it filled up. The only way I can actually delete the music is going song by song via the device.
Reply With Quote

  #10  
Old 08-21-2012, 05:04 AM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,201
Default

"Linux" covers a lot of territory and I'm no Linux expert so take this in that context.
I noticed folders that start with "." are hidden by default in Ubuntu Linux. When I delete a file on the Clip+ it isn't permanently deleted from the player immediately. It goes to a folder named ".Trash". I can no longer see that folder or it's contents as the leading "." causes it to be hidden in the file browser.

The Clip+ locates all recognized music files during it's database refresh. The leading "." doesn't hide it from the internal database refresh. Once the refresh is over it displays the contents of the folder I can't see in the Linux file browser.

If that's what's happening here files you should see that folder if you enable hidden viewing hidden files. Once you delete that folder permanently the files are fully deleted from the file system and you shouldn't see them anymore.
Reply With Quote

  #11  
Old 08-21-2012, 05:17 AM
TackyTiger's Avatar
TackyTiger TackyTiger is offline
Member
 
Join Date: Mar 2009
Location: Airstrip One
Posts: 161
Default

Also, if you hold shift while deleting, the files will be permanently deleted.

Ctrl+H shows hidden entries (prefixed with a dot) in Nautilus (Gnome).
Reply With Quote

  #12  
Old 08-21-2012, 07:52 AM
johnny english johnny english is offline
Junior Member
 
Join Date: Aug 2012
Posts: 3
Default

Gentlemen, you are both every kind of awesome. That resolves the issue perfectly.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:56 AM.