android
  #1  
Old 06-22-2012, 01:36 AM
suffer1989's Avatar
suffer1989 suffer1989 is offline
Junior Member
 
Join Date: Nov 2006
Posts: 52
Unhappy Installrd rockbox, Wont go past samsung logo

Hey, I just installed rockbox, but when I turn my MP3 player on (after installing rockbox) it loads up the initial samsung screen, but then goes blank .... Nothing.


Im trying not to panic, but it doesnt seem to be able to boot into the OF or Rockbox.


EDIT : Safemode seems to be working, but, Im still incredibly aprehensive.

Last edited by suffer1989; 06-22-2012 at 01:48 AM.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 06-22-2012, 02:46 AM
Lorenz092 Lorenz092 is offline
Member
 
Join Date: Jan 2011
Location: Italy
Posts: 449
Default

Okay if safe mode is working, then simply double check the rockbox folder and scripts
Don't panic, if safe mode works, there is no problem at all !
And, DON'T never ever reinstall the old firmware for any reason => doesn't have safe mode.
__________________
Check out my modded firmware both for YP-R0 and YP-R1!!!
** DONATE ** -> https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=K658CHJKX2X8C
NOTE: if you want to donate for Rockbox itself and not my work, go to their website!!
Reply With Quote

  #3  
Old 06-22-2012, 02:52 AM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,599
Default

There is the Rockbox thread here: http://anythingbutipod.com/forum/showthread.php?t=58642
Why do you open a new thread?

Did you get the blank screen whether you load the OF or Rockbox? No difference?

I would say try a new fresh install and make sure you read carefully my installation instructions.

edit: lorenzo is faster
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

  #4  
Old 06-22-2012, 02:58 AM
suffer1989's Avatar
suffer1989 suffer1989 is offline
Junior Member
 
Join Date: Nov 2006
Posts: 52
Default

I think I solved it myself. I went to the the root of R0 (in safe mode) and removed the rockbox auto booter file. Then, I unmounted, and rebooted. To my absolute relief, the original firmware did boot up.

I tried to boot into rockbox, but that didnt work. I went back into the OF, rebooted, and mounted the flash drive. I tried to delete and re-extract rockbox, but came up with a bunch of corruption errors. I then ran the disk checking tool on the drive, found that some files had been corrupted, deleted them, and then Re-Installed rockbox.

Woohoo, turns out that worked


TL,DR:
Long story short : the .rockbox folder got corrupted. Did a scan to repair broken files/sectors. Re-extracted rockbox. That seemed to do the work.


One thing though, whats the 'complete' way to shut down from the OF ? I dont feel comfortable prodding the little reset hole.
Reply With Quote

  #5  
Old 06-23-2012, 03:03 AM
Lorenz092 Lorenz092 is offline
Member
 
Join Date: Jan 2011
Location: Italy
Posts: 449
Default

Just keeping the power button pressed for at least 5 seconds does the trick!
__________________
Check out my modded firmware both for YP-R0 and YP-R1!!!
** DONATE ** -> https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=K658CHJKX2X8C
NOTE: if you want to donate for Rockbox itself and not my work, go to their website!!
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:56 PM.