android
  #1  
Old 01-05-2012, 03:17 AM
Sykes Sykes is offline
Junior Member
 
Join Date: Dec 2011
Posts: 97
Default Clip+ Dodgy battery indicator and charging

I've bought my C+ shortly before X-mas, so it's about 3 weeks old. I find the battery indicator to be really crap. It's all over the place, sometimes dropping, then recovering. I thought it's an aspect of a new battery, but that should be sorted out by now.

Last night, I gave a shot at 'reformatting' the battery (shouldn't hurt, since it's still new). I gave the player a full charge, let it play until it turned off. Then I connected it to a PC on standby (USB is still powered, so it registers as a charger, but not as a computer). Immediately I check the battery on the C+ - it shows 21%. WTF? I expected less than 5%. I turn on the PC, 2 hours later, C+ shows full battery icon. I disconnect the C+ and check the battery - it's just at 81%. I reconnect the C+ and it keeps charging.

Is it the usual C+ behavior or is it fit for RMA? The battery life seems okay, it gives me some 10+ hours on OGG and FLAC files, so that's fine I guess. But the indicator is really weird.

Using latest firmware, 16 or something.

Second, unrelated question/problem: on about two occasions so far, the music didn't start to play - playback was on, time was advancing, but there was no sound. All it needed is restarting the playback (<< button) and suddenly the sound was back. On both occasions, this was right after turning the player on. Did this happen to anyone?

Thanks for advice.

Last edited by Sykes; 01-05-2012 at 03:24 AM.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 01-07-2012, 03:44 AM
Sykes Sykes is offline
Junior Member
 
Join Date: Dec 2011
Posts: 97
Default

Nobody? I could use at least the information whether yours behaves the same, or the indicator is reliable.
Reply With Quote

  #3  
Old 01-07-2012, 10:35 AM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,142
Default

The few times I checked I didn't find the indicator info in the system settings to be very accurate. The indicator bar and the info in the system settings sometimes agreed and sometimes didn't. There were times I knew it was fully charged and the system info said it was 88%. Other times when the Properties in Window Explorer while connected in MTP said it had less than 20% charge it showed as being over 60% on the player. I tried to reset the battery indicator by doing a full drain and things stayed pretty much the same. That was with one of the earlier firmwares.

For the heck of it I just put it into MTP and checked. I'm using a firmware patched for Rockbox, 01.01.18, but I've always found the OF behavior to be the same on several other Rockboxed players. The system settings report 88%, the indicator bar says it's fully charged. The properties in MTP and MusicBee says 98%. Rockbox says 97%. I've done a battery benchmark using Rockbox and it seemed accurate in it's battery indications so I'm going with that.

My use pattern isn't the average so I can't say if my results are average. Someone that uses just the OF may have different results, IDK.

What I can say is that when I did the drain in both the OF and the Rockbox battery bench the battery life was what was expected. It lasted a good long time. It was just the amount of charge the OF indicated that was erratic.
Reply With Quote

  #4  
Old 01-11-2012, 03:27 PM
Sykes Sykes is offline
Junior Member
 
Join Date: Dec 2011
Posts: 97
Default

It seems to have sorted itself out now. I've made a few full charge/discharge cycles and now it shuts down at <10% and charges to full 100%. The discharge pattern seems to be quite steady too.

Well it took longer than in most Lithium battery powered devices. Probably just a cheapo dealextremish battery and circuit. I sure hope it doesn't overcharge.
Reply With Quote

  #5  
Old 01-12-2012, 03:11 PM
Mikerman Mikerman is offline
Ultra Senior Member
 
Join Date: Dec 2007
Posts: 2,424
Default

Rare to hear of any overcharging--you likely are set. Congratulations!
Reply With Quote

  #6  
Old 01-22-2012, 09:51 PM
Sykes Sykes is offline
Junior Member
 
Join Date: Dec 2011
Posts: 97
Default

Now it's back at it The battery is definitely nuked somehow. Battery life is down to maybe 5 hours and it lasts like 15 minutes on the last 65%.

That's why I hate non-replaceable batteries. If this happens 6 months down the road, I'll have no choice but to throw the player out. Now I can only hope they'll honor the warranty on a 4 weeks old player.

Anyway... What's the battery indicator supposed to do during charging? Mine blink at cca 90%, then drops to the current charge value for 2 secs, than blinks back at almost full... Is this how it's showing it's charging properly or that it can't decide what the charge actually is?
Reply With Quote

  #7  
Old 01-23-2012, 03:50 PM
Mikerman Mikerman is offline
Ultra Senior Member
 
Join Date: Dec 2007
Posts: 2,424
Default

If you are exchanging via SanDisk, they have a good track record in customer service in that regard.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:09 PM.