Go Back   abi>>forums > General Audio > Headphones

Thread Tools Search this Thread Display Modes
Old 01-29-2011, 03:25 PM
steinburger1109's Avatar
steinburger1109 steinburger1109 is offline
Ultra Senior Member
Join Date: Feb 2009
Location: Naperville, Illinois
Posts: 2,456

Originally Posted by The DarkSide View Post
I had an E280, was a great little player - and solidly built at that.
Lol except that the headphone jacks were too loose and broke off at the soldering too much. Happened to me twice (although the second time was probably due to a VERY rookie solder job repair attempt on my part). I've gotten better though haha
- Justin
Glossary for Newbies Everybody
Babble. On.
Reply With Quote

Advertisement [Remove Advertisement]

Old 02-14-2011, 11:46 AM
priell3's Avatar
priell3 priell3 is offline
Join Date: Jan 2007
Location: Philadelphia, PA
Posts: 174

So after 3 weeks how are the headphones holding up and performing?
2GB e250 V1, 2GB Fuze V1, 8GB Fuze V2, 4GB Clip+, Acer Iconia Tab A110, LG Optimus L9
Reply With Quote

Old 02-14-2011, 01:18 PM
The DarkSide's Avatar
The DarkSide The DarkSide is offline
Ultra Senior Member
Join Date: Feb 2008
Location: Qns Vlg, NYC
Posts: 16,197

I'm enjoying them, but I'm looking to get a short cable to clip my Sansa clip+ to the headband.

The included cable is also bad in one area - microphonics. It's cloth-covered, and when it rubs on your skin or clothing it's annoying as hell. It sounds like it's coming from directly INSIDE the headphones. When I use another cable this is a non-issue.

Still, I'm gonna do the "dfkt" and attatch a clip+ to 'em and enjoy for the coming warm weather.
Reply With Quote


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 09:47 AM.