android
  #81  
Old 02-11-2011, 07:15 AM
NEET NEET is offline
Junior Member
 
Join Date: Feb 2011
Posts: 7
Default

I have here 2 Sansa Clips+ due to an issue with the earbuds.
One goes back.

But i noticed that the firmware versions are different?

One is V.01.02.15P and the other one is V.01.02.15A

Which one is the more recent one?

Also, tried it with both, no way to record FM-tune due to the signal getting weaker and there is always the background noise "tick tick tick tick".

I hope Sansa will fix this....
Reply With Quote

Advertisement [Remove Advertisement]

  #82  
Old 02-11-2011, 07:20 AM
dfkt's Avatar
dfkt dfkt is offline
Ultra Senior Member
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

They're basically the same firmware. Read here about the suffixes: http://anythingbutipod.com/forum/showthread.php?t=25408
Reply With Quote

  #83  
Old 02-11-2011, 07:36 AM
NEET NEET is offline
Junior Member
 
Join Date: Feb 2011
Posts: 7
Default

Oh i see.
Well, atleast there are clear differences in the quality of manufacturing.

The new one i got today has a very spongy volume control.
I thought the older one was bad...
Well, but the middle button is the exact opposite with both devices.

Hm, i guess i will test which battery lasts longer to detect which one to send back.
Reply With Quote

  #84  
Old 05-04-2011, 03:37 PM
xDownSetx xDownSetx is offline
Junior Member
 
Join Date: Feb 2009
Location: Corona, CA. USA
Posts: 7
Default

I just bought a Clip+ 4gb and it shipped with 1.02.16a. Isn't even on Sansa's site yet. If there is a reliable way to get it to a .bin and if it is wanted I can do that.

I can use dd as described here if that is known to work reliably.
Reply With Quote

  #85  
Old 05-04-2011, 04:41 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,628
Default

Quote:
Originally Posted by xDownSetx View Post
I can use dd as described here if that is known to work reliably.
I think if you do that, the first 32MB of the recovery mode disk should be the bin and some other things. If you could download that you'd have the binary, although installing it on another player may take some effort (i don't remember if the firmware part of the flash stores the headers for the bin or just the code).
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #86  
Old 06-21-2011, 08:23 PM
C E Jones C E Jones is offline
Junior Member
 
Join Date: Apr 2009
Posts: 13
Default

I'm having trouble following the instructions in the OP for how to install the firmware. It says to drag the 2 files to the root directory on the Clip+, but I can't find any such directory. Is this supposed to be a folder called "root"? I my computer set to show hidden folders, still can't find the directory.
Reply With Quote

  #87  
Old 06-21-2011, 08:43 PM
dfkt's Avatar
dfkt dfkt is offline
Ultra Senior Member
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Root is the uppermost directory of the player's file system, i.e. no folder. Just drop the firmware onto the directory with the drive letter.
Reply With Quote

  #88  
Old 06-21-2011, 10:07 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,628
Default

Quote:
Originally Posted by C E Jones View Post
Is this supposed to be a folder called "root"?
Also good to look at:

http://en.wikipedia.org/wiki/Root_directory
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #89  
Old 07-08-2011, 01:47 PM
a2z a2z is offline
Junior Member
 
Join Date: Jul 2011
Posts: 25
Default

Quote:
Originally Posted by xDownSetx View Post
I just bought a Clip+ 4gb and it shipped with 1.02.16a. Isn't even on Sansa's site yet.
Is that the latest firmware? I just bought mine this morning and would like to update it before I go ahead and upload music. I've checked the site and the Sansa updater and it shows nothing new as far as firmware.
Reply With Quote

  #90  
Old 07-08-2011, 01:51 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by a2z View Post
Is that the latest firmware? I just bought mine this morning and would like to update it before I go ahead and upload music. I've checked the site and the Sansa updater and it shows nothing new as far as firmware.
What firmware is on your player now?
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #91  
Old 07-08-2011, 01:57 PM
a2z a2z is offline
Junior Member
 
Join Date: Jul 2011
Posts: 25
Default

Quote:
Originally Posted by Marvin the Martian View Post
What firmware is on your player now?
1.02.16a
Reply With Quote

  #92  
Old 07-08-2011, 02:11 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by a2z View Post
1.02.16a
Then you have no need to update. And I would uninstall the Sansa updater from your computer.....you don't need it. On the off chance that there are any more firmware updates for the Clip+, a manual FW update is preferred.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #93  
Old 07-08-2011, 02:22 PM
a2z a2z is offline
Junior Member
 
Join Date: Jul 2011
Posts: 25
Default

Quote:
Originally Posted by Marvin the Martian View Post
Then you have no need to update. And I would uninstall the Sansa updater from your computer.....you don't need it. On the off chance that there are any more firmware updates for the Clip+, a manual FW update is preferred.
Great! Thanks again
Reply With Quote

  #94  
Old 09-30-2011, 12:50 PM
nimicitor's Avatar
nimicitor nimicitor is offline
Junior Member
 
Join Date: Apr 2008
Location: England
Posts: 71
Default

So is V1.02.16 newer then V1.01.35 and if so why the skip in numbers?
Reply With Quote

  #95  
Old 09-30-2011, 01:01 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,409
Default

There was never any firmware issued for the Clip+ with that designation. There was one for the original Clip with that number. That wouldn't make a difference to the Clip+ numbering as they aren't interchangable.
Reply With Quote

  #96  
Old 10-07-2011, 07:15 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

First post updated. Seems to be a very minor update.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #97  
Old 10-08-2011, 04:09 AM
dfkt's Avatar
dfkt dfkt is offline
Ultra Senior Member
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Quote:
Supports newer memory configuration
Hmm, that sounds like some hardware changed in newer Clip+ models?
Reply With Quote

  #98  
Old 11-15-2011, 10:33 AM
jackhamma_e jackhamma_e is offline
Junior Member
 
Join Date: Nov 2011
Posts: 2
Default

Quote:
Originally Posted by C E Jones View Post
I'm having trouble following the instructions in the OP for how to install the firmware. It says to drag the 2 files to the root directory on the Clip+, but I can't find any such directory. Is this supposed to be a folder called "root"? I my computer set to show hidden folders, still can't find the directory.
i'm having the same problem as CE. there's only one file in the zip, which is a .bin. when i drag and drop the .bin into the sansa clip root, i unplug and let it refresh, but it does not change the firmware.

i'm wanting to reverse the firmware because since it upgraded to the current version .16, i can no longer veiw or access the music files in the root menu when plugged into the computer. the music files are in there and play when not plugged in to the computer.

i have a 16Gb card in it as well, that i can access on the computer just fine.

anybody else have this problem? this was a great player until this happened.

new to this forum, hope you guys can help
Reply With Quote

  #99  
Old 11-15-2011, 10:39 AM
dfkt's Avatar
dfkt dfkt is offline
Ultra Senior Member
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

The problem is that you connect in MTP mode instead of MSC (or vice versa). That's why the firmware doesn't update and you don't see the files on the player. Sandisk players are weird like that. Just select the other mode in the Clip's settings.
Reply With Quote

  #100  
Old 11-15-2011, 07:43 PM
jackhamma_e jackhamma_e is offline
Junior Member
 
Join Date: Nov 2011
Posts: 2
Default

THANK YOU DFKT !
i can't tell you how long i'v been banging my head against the wall trying to figure this out. made my day!
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 11:18 PM.