android
Go Back   abi>>forums > MP3 Players By Brand > iRiver > iriver clix (U10)

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-23-2011, 11:23 AM
ira ira is offline
Junior Member
 
Join Date: Jan 2011
Posts: 2
Default neither xp nor windows media player 11 recognize clix 4GB N73

Hi

After a long time of not using my clix, I'm trying to add music to it, but neither windows xp sp3 nor windows media player 11 will recognize my clix when it's plugged in

I believe it's because I need a driver, since under device manager, 'other devices > iriver clix' there's a yellow question mark and exclamation mark, and when I click on 'iriver clix' I 'm told that 'the drivers for this device are not installed'

Where can I find the appropriate drivers ? (I never installed any drivers to begin with, and the unit worked perfectly fine)

Th iriver site is very confusing, as there are no drivers for the clix. In fact I'm confused between the designations 'clix', 'clix2', and 'U10'. My model says 'iriver clix' and below '4GB N73'

Some other info:

1) When I plug in the clix to one of the usb ports I hear the characteristic three little beeps but there's no recognition of the device under 'my computer', nor is there any recognition of the device in windows media player 11

2) I can recharge the clix battery by plugging it into my pc

One other question: is it possible to sync the iriver with mediamonkey ?

Thanks in advance for any help.

Be well,
Ira
Reply With Quote

Advertisement [Remove Advertisement]

 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 03:37 AM.