android
  #1  
Old 09-16-2010, 08:50 PM
k5r2an k5r2an is offline
Member
 
Join Date: Apr 2009
Posts: 131
Default PFE Right Monitor Dead?

The right monitor of my PFE's has been acting up lately. I took it out to listen one day and I noticed that the right monitor didn't play any music, so I left it on my desk for a couple of days. I used them again just 4 days ago and I found that the right monitor came back to life. I took them on a trip to Chicago today and they worked fine, but I noticed that the right monitor was decreasing in volume over time. On the way back, I plugged them in again and I noticed that the right monitor wasn't playing music again. How do I save my PFE's?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 09-17-2010, 12:22 AM
Orange Orange is offline
Member
 
Join Date: Apr 2007
Location: Houston, Tx
Posts: 205
Default

Theres a pretty high chance that it's the cable falling apart. You can do some soldering work yourself to repair the wire, or send it to the manufacture for a replacement if its within the first year.

Cant guarantee that this is the issue, but its highly likely.
Reply With Quote

  #3  
Old 09-18-2010, 11:30 AM
buzzo buzzo is offline
Junior Member
 
Join Date: Aug 2010
Posts: 23
Default

It looks like a filter problem to me. They tend to act up like that sometimes, happened to me several times, too. The filters seem to be sensitive to humidity or something and it sucks that it usually happens when out without a chance to change them. The only flaw I found on these overall great IEMs in almost three months of heavy use.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:18 PM.