android
  #1  
Old 03-18-2010, 10:59 AM
BigGeoff BigGeoff is offline
Junior Member
 
Join Date: Mar 2010
Posts: 2
Default Is this upload speed normal for P7???

Hi all

I just got my 16gb P7 from a guy on eBay (UK) and all appears to work ok and I am well pleased with it, well everything except the speed of transfer to the player. I have firmware version 1.40 and I am using the device under Linux (Ubuntu) as an external drive. the system sees the player fine and I can copy to and delete things but the actual transfer speed seems to be diabolical - 1.5gb of music files reports as taking about 5 hours to transfer which fits with a couple of trial avi videos I transfered first thst took about an hour to shift 300+mb across. Are these speeds what other people get? I culd load the iRiver software on a windows sysem if I realy have to but would prefer not.

Thanks all

Geoff
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 03-19-2010, 12:25 PM
Redblade20XX Redblade20XX is offline
Junior Member
 
Join Date: Mar 2010
Posts: 11
Default Some help...

BigGeoff, I'm also using Ubuntu to transfer music files from the P7 to my netbook and I'm not getting those load times. Maybe its your firmware because several posts about 1.4 says that its glitched a bit. But I wouldn't know because I've kept mine on 1.37. Hopes this helps a bit.
Reply With Quote

  #3  
Old 03-20-2010, 01:02 PM
BigGeoff BigGeoff is offline
Junior Member
 
Join Date: Mar 2010
Posts: 2
Default

Thanks redblade20XX, I must admit to having some doubts about 1.40 after reading the forums but relatively few people have posted about it. At some stage I will have to tackle this head on by trying to switch back to 1.37 which appears to work well. I have also noticed that unbelievably, when the P7 is transferring (which for films takes hours) there is the distinct possibility of the OS crashing if you try to swap to another person logged in. This is the only time I have ever had a Linux system crash in the 3 years I have been using it. It flags up a problem with trying to write to the P7 which seems to go if you unplug the device (not really recommended).

I would still be glad to hear from any others using 1.40 as to their times for trasnsferring music or video to this device.

Geoff
Reply With Quote

  #4  
Old 03-20-2010, 03:48 PM
ha14 ha14 is offline
Junior Member
 
Join Date: Mar 2010
Posts: 27
Default

Well I use windows vista 32bits and get also slow upload load to P7 in USB and MTP mode. I think it should because the writing speed is not big on the iriver p7 chipsets, plus I think the firmware version cannot be of help to solve this problem; Also notice that the pc configuration can play also a good role, but for the same ^c configuration writting on Sansa View is faster than writting on iriver P7;
Reply With Quote

  #5  
Old 07-16-2010, 12:41 AM
QuantumKnot QuantumKnot is offline
Junior Member
 
Join Date: Jan 2010
Posts: 3
Default

This doesn't seem to be needed in newer kernels/distro's but to fix the slow transfer speed problem, run the following as root:

Code:
echo 64 > /sys/block/sdb/device/max_sectors
Replace 'sdb' with whatever your device is. Made a huge difference (3 MB/s instead of 300 kB/s)
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:44 AM.