android
  #1  
Old 12-09-2008, 04:33 PM
tmcarson1 tmcarson1 is offline
Junior Member
 
Join Date: Oct 2008
Posts: 55
Help Anyway for Rockbox not to play a podcast during shuffling all?

I have lots of music and a few podcasts, is there anyway to flag the podcast to not be played during shuffling?

I know there are workarounds, but I like the variety I get when I go to genre, play all....

Perhaps there is not a way, but was just wondering if anyone knew of one.

Thanks!
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 12-09-2008, 09:08 PM
Mainiak Blaniak Mainiak Blaniak is offline
Junior Member
 
Join Date: Jan 2008
Location: A small town in Maine
Posts: 16
Default

I just create a playlist called "all music". I like more generalized genre tags (i.e. rock, pop, country, etc.) rather than being specific, so it only takes me about 5 or 6 clicks to add all genre's except podcast and audiobook to a playlist to get all of them. I use that playlist more than any others actually.
Reply With Quote

  #3  
Old 06-21-2010, 10:01 AM
hajenkatt hajenkatt is offline
Junior Member
 
Join Date: Mar 2009
Posts: 5
Default

Has anyone found another solution to this? I add/remove too much music to constantly have to update an All Music playlist. I've got several comedy albums on my player that I want to keep out of the rotation when young ears are nearby. Has someone come up with a way to flag files to keep them out of shuffle as the OP asked?
Reply With Quote

  #4  
Old 06-21-2010, 10:39 AM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,617
Default

Couple ways I can think of:

Use file browser and put your music in one folder and podcasts in another, then just shuffle the music folder.

Use the database and put the podcasts in a folder thats not included in the database.
Reply With Quote

  #5  
Old 06-21-2010, 11:53 AM
hajenkatt hajenkatt is offline
Junior Member
 
Join Date: Mar 2009
Posts: 5
Default

Thanks, Saratoga. Your post gave me a few more keyword search ideas.

The solution I am trying out today is to add the the empty database.ignore file to the folders I don't want included. I've been trying to get it to work, but it appears to still list the files in the database. Many of the wiki pages on the subject are no longer available (404), so I'm going to dig a little deeper.
Reply With Quote

  #6  
Old 06-22-2010, 09:51 AM
hajenkatt hajenkatt is offline
Junior Member
 
Join Date: Mar 2009
Posts: 5
Default Solution to issue

I've found one solution that works, and I am very pleased with it.

Internet references say to create an empty file titled database.ignore and place this file into whichever directory/file/subfile you wish to exclude from the database. Creating the file myself did not work; however, there is an ignore.database file already in the .rockbox folder. So, if you want to flag or exclude podcasts, songs, or any other file from your database simply copy the database.ignore file from the .rockbox folder and paste it into the folder you wish to exclude. Refresh your database, and you're good to go.

If you want to get fancy, the one thing I have not tried is if you want a directory ignored but a subdirectory scanned. If a subdirectory of an 'ignored' directory should still be scanned, place a file named database.unignore in it. That will ignore the main directory but include the subfolder.

Hope this helps someone. I know I am very relieved that Dennis Leary will not be making an unexpected appearance when innocent ears are nearby.
Reply With Quote

  #7  
Old 06-22-2010, 10:25 AM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Quote:
Originally Posted by hajenkatt View Post
Creating the file myself did not work
Maybe you have file extensions hidden on your Windows system, and your self-created file was named database.ignore.txt or something similar?

The database.ignore file is just an empty file, and a wrong (hidden) extension would be the only issue I could think of.
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #8  
Old 06-22-2010, 12:01 PM
hajenkatt hajenkatt is offline
Junior Member
 
Join Date: Mar 2009
Posts: 5
Default

Quote:
Originally Posted by dfkt View Post
Maybe you have file extensions hidden on your Windows system, and your self-created file was named database.ignore.txt or something similar?

The database.ignore file is just an empty file, and a wrong (hidden) extension would be the only issue I could think of.
I'm sure you're right, and it is something very simple that I overlooked. Once I realized the file was already in the .rockbox folder, I thought I'd post that info here. That way, less technical folks can just cut and paste and not have to ask how to create the database.ignore file ad nauseum.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 11:53 AM.