android
  #1  
Old 11-16-2007, 04:27 AM
Fart Master X Fart Master X is offline
Junior Member
 
Join Date: Nov 2007
Posts: 7
Default

Quote:
Originally Posted by Llorean View Post
You don't use an i2c.bin to recover. You should never, EVER EVER need an i2c.bin unless your player no longer boots to anything except a pure black screen
well, such is my current situation. black screen, blue ring, that's it. no recovery mode. shows as 'PortalPlayer device' under PuppyLinux when placed in manufacturing mode -- and yes, 'libusb' is installed. tried running e200tool from root to no avail. yes i have the SD...rom file. so, that said... does anyone have the i2c for an e270 or any other suggestions? honestly, i'm not even exactly sure what that might do, but from these forums i've gleaned that to be the solution. thanks in advance.

FMX

okay... finally found the device (had to set Permissions to executable/searchable), but is now timing out

...
Initializing USB stub (4780 bytes)
Bulk write error (-110, Connection timed out)
....

gonna keep crackin away at it.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 11-16-2007, 01:03 PM
advcomp2019's Avatar
advcomp2019 advcomp2019 is offline
Ultra Senior Member
 
Join Date: Jun 2007
Posts: 4,838
Default

You might want to look here: http://daniel.haxx.se/sansa/e200tool.html or http://daniel.haxx.se/sansa/mi4.html

If those will not work, you might have to look on Rockbox's site (www.rockbox.org) for a little more help. You even might want to get on their IRC channel to see if they can help.
Reply With Quote

  #3  
Old 11-19-2007, 03:09 PM
chrisjs162216 chrisjs162216 is offline
Ultra Senior Member
 
Join Date: Oct 2006
Location: Somewhere
Posts: 1,515
Default

Quote:
Originally Posted by Fart Master X View Post
'PortalPlayer device'
Yup - welcome to preboot mode

Quote:
does anyone have the i2c for an e270 or any other suggestions?
http://daniel.haxx.se/sansa/e200tool/i2c-e280.bin should be the same for all the e200 series, as they all use the same I2C. Dumping the I2C from my Sansa showed that the md5sum was the same, so it should work for your e270 as well.


Quote:
honestly, i'm not even exactly sure what that might do, but from these forums i've gleaned that to be the solution. thanks in advance.
The I2C tells the Sansa where to look for the bootloader. The bootloader tells where to look for the firmware. The firmware, boots, and is what you see It might be easier to think of it as a computer. I suppose the I2C could be considered the BIOS, the bootloader the...bootloader, and the firmware the OS. Even if the bootloader and firmware are working, without the I2C, you can't do anything.


Quote:
Initializing USB stub (4780 bytes)
Bulk write error (-110, Connection timed out)
This "occasionally" happens - just turn off the Sansa (hold power for 20 seconds) and try it again.

./e200tool i2cprogram i2c-e280.bin
[reboot Sansa, and it should now go to Manufacturing mode (should not appear as PortalPlayer device)]
./e200tool recover BL_SD_boardSupportSD.rom
[while holding the REC button, and continue holding until it goes into Recovery mode. If the Sandisk logo doesn't appear, there's a problem.]

That should get you into Recovery mode, where you need to save both the firmware AND the bootloader (BL_SD_boardSupport.rom - unless filename changed) onto the Recovery partition.
Reply With Quote

  #4  
Old 05-24-2010, 10:44 AM
tehnodruma tehnodruma is offline
Junior Member
 
Join Date: May 2010
Posts: 1
Default

10x man my sansa e250 is still working after i low level format it .All my trouble is comin from i2c.bin, when i reprogram i2c rom my sansa return to life 10x again
Reply With Quote

  #5  
Old 05-24-2010, 10:51 AM
WalkGood's Avatar
WalkGood WalkGood is offline
Moderator
 
Join Date: Aug 2006
Location: FL
Posts: 12,579
Default

tehnodruma did you look at the date of this thread? Please don't revive old threads unless it's relevant to an issue at hand.
__________________
WalkGood,
Ramón

abi >> | Forum Rules | Glossary | Why Rockbox | FLAC or MP3? | irc
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:57 AM.