android
Go Back   abi>>forums > MP3 Players By Brand > Microsoft Zune > Zune HD

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-18-2010, 11:23 AM
Zendude Zendude is offline
Junior Member
 
Join Date: Nov 2006
Posts: 26
Lightbulb How To on Supporting mp3 resume - simple audio bookmarking

Since the Zune HD Team is either having a hard time implementing simple mp3 audio resume (regardless of how they are tagged), or they just don't care, I've figured out at the technical level on how to get your mp3s to resume to where they left off. It's a simple form of bookmarks where you really just want to resume where you left off in the audio stream. I did not want to try to use Overdrive to "convert" mp3s into audiobooks which is stupid to require the user to do. It's a matter of tagging the mp3s via the id3 tag properly and putting it in the Zune music dir (or if you define a separate podcast dir.. I set my podcast dir to my music dir). This method may have been discussed before but maybe not in this fashion. Read on if you care for this feature.. if not, move onto the next thread of your interest.

As of today, there are 2 types of tags in mp3s: id3v1 and id3v2. The older id3v1 used a numeric value from 0-255 to identify the type of genre. Even players like WinAmp only associate 148 genres types to values for id3v1. However, there is no official value of "podcast" for id3v1 (that I've seen). So, if for some reason you are using an id3 tag editor which only supports id3v1, set the value to 255 if possible. This usually means "unknown" or "other". I haven't tested to see if this works but it should. Most users will use the id3v2 tagging method discussed next.

For the vast majority of the rest of us, we should all have id3 tag editors which support id3v2. This genre data is now in string form. You can put whatever you want there. You should put in "podcast". Do not make it plural by adding an "s". This should actually tag the id3v1 with a value of 255 (both id3v1 and id3v2 tag data can co-exist in mp3s). At the technical level, the id3v2 tag name/frame is "TCON" which means "content type".

If you are running any modern version of Windows, you do not need an mp3 tag editor. You can simply right-click on properties in Windows Explorer on the actual mp3 file and choose "Properties". Then select the "Summary" tab. You want the "Advanced" view, so if you see an "Advanced >>" button, click on it. Now, under the "Genre" Music Property, change it to "podcast". Windows will properly update the id3v2 tag. Players like WinAmp will also let you set the genre string under id3v2. The Genre field will show as a combobox list, but you can manually enter "podcast" as a string in the combobox.

If you are a linux guy like me, you can use a command line tool like id3v2 and issue this command: id3v2 --TCON "podcast" your.mp3

Forgot to mention, if you did this id3 tag modification while the mp3 file is in your Zune software music/podcast path, you will simply need to move it out of that path into a non-music path and move it back in. This will trigger the Zune software to sense the update.

Now, in the Zune software, you should be able to see the mp3 under "PODCASTS" instead of under "MUSIC". Sync it up to your Zune (if you use manual syncing like me), and you are good to go. The mp3 will show under the Zune HD's main menu "PODCAST" item.

If this helps at least one other person, it was worth writing.

Last edited by Zendude; 03-18-2010 at 11:31 AM.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 03-18-2010, 11:31 AM
ItsLasher's Avatar
ItsLasher ItsLasher is offline
Member
 
Join Date: Mar 2010
Location: The Net
Posts: 204
Default

Why not just use the "PAUSE" button?
Reply With Quote

  #3  
Old 03-18-2010, 11:43 AM
Zendude Zendude is offline
Junior Member
 
Join Date: Nov 2006
Posts: 26
Default

Quote:
Originally Posted by ItsLasher View Post
Why not just use the "PAUSE" button?
It doesn't work. If you are a multi-use Zune HD person like me, I will listen to an mp3 audio stream for 1 hour. Then later, I may just want to listen to some music or possibly watch a simple video episode of whatever show. Then, when I go back to the original mp3 and resume from that 1 hour mark, it starts back from the beginning.

Basically, you can't resume an mp3 file once you start another mp3 or video or whatever. I think even just switching to the radio makes it lose its place in the last mp3 played.
Reply With Quote

  #4  
Old 03-18-2010, 12:33 PM
Mq1991 Mq1991 is offline
Member
 
Join Date: Jan 2007
Posts: 131
Default

Zendude you are my hero!!

I have about 20 Audiobooks that are all in MP3. And it worked beautifully!

thanks again!
__________________
"The Bitterness Of Poor Quality Lingers Long After The Happiness Of Low Price Is Forgotten"
16GB Zune HD, Sansa Fuze V1, Sansa e260 ROCKBOXED.

Add Me on Zune Social! my name is: mq1991
Reply With Quote

  #5  
Old 03-18-2010, 02:03 PM
poisonousjuice's Avatar
poisonousjuice poisonousjuice is offline
Member
 
Join Date: Mar 2010
Posts: 128
Default

Thank you very much! Great info. I'm going to try this when I get home today. I have some very long mp3 tracks (4+ hours each) but sometimes want to switch to some different music and then go back later to where I left off. So just pressing pause isn't an option :-P

This sounds like the easy way I was looking for. Thanks again!
Reply With Quote

  #6  
Old 03-30-2010, 04:43 PM
Zendude Zendude is offline
Junior Member
 
Join Date: Nov 2006
Posts: 26
Default

I must have done something wrong because this process stopped working for me. I've been tagging the genre as "podcast" and it does show up under Podcasts. Then, when I manually sync'd my last huge mp3 audio file, it deleted the existing files in my podcast directory. On top of that, the resume feature no longer works. It's going back to the beginning again... Argh! I'll have to try to figure out what happened. I wish I could view the internal file directory structure on my ZHD to help see what's going on.

Edit: There may be an issue with the Zune sw/fw. It may deal with the "manual sync" not working as intended with podcasts. I had only 1 file in my podcast "collection" and did a manual sync to my ZHD. That worked.. However, if I disconnect the ZHD, delete the podcast from my collection, and then re-connect the ZHD, it appears to auto-sync with my collection. Since the podcast file no longer exists in my collection, it appears to delete the podcast from my ZHD (upon re-connecting the ZHD). I did verify that the podcast was showing up on my ZHD after the first disconnect.

Edit 2: So, my Zune software settings says I'm set for manually sync'ing for everything (including podcasts). However, it's behaving as though I have auto-syncing on. I have no idea how it has triggered back into this state. It's a little frustrating. I really hope the Zune team fixes all these bugs. I still do not know why my ZHD stopped being able to resume podcasts. I may have to reset everything *sigh*.

Last edited by Zendude; 04-01-2010 at 04:38 PM.
Reply With Quote

  #7  
Old 04-02-2010, 02:26 PM
Machiventa's Avatar
Machiventa Machiventa is offline
Moderator
 
Join Date: Dec 2006
Posts: 886
Default

Quote:
Originally Posted by Zendude View Post
Edit: There may be an issue with the Zune sw/fw. It may deal with the "manual sync" not working as intended with podcasts. I had only 1 file in my podcast "collection" and did a manual sync to my ZHD. That worked.. However, if I disconnect the ZHD, delete the podcast from my collection, and then re-connect the ZHD, it appears to auto-sync with my collection. Since the podcast file no longer exists in my collection, it appears to delete the podcast from my ZHD (upon re-connecting the ZHD). I did verify that the podcast was showing up on my ZHD after the first disconnect.

Edit 2: So, my Zune software settings says I'm set for manually sync'ing for everything (including podcasts). However, it's behaving as though I have auto-syncing on. I have no idea how it has triggered back into this state. It's a little frustrating. I really hope the Zune team fixes all these bugs. I still do not know why my ZHD stopped being able to resume podcasts. I may have to reset everything *sigh*.
That isn't a bug, it's how the software is designed. With Manual Sync the software creates Sync Groups upon syncing. And when you delete something from the software that is associated with a Sync Group it will remove it from the device also. What I do is sync something, then click "forget this device" which removes the association with the Sync Group, then remove the file(s) from your collection. Even though they gave us our Manual Sync back it's still not true manual sync if we have to continue to use workarounds.
__________________
DILLA BANGED MY WIFE
Reply With Quote

  #8  
Old 04-05-2010, 10:57 AM
Zendude Zendude is offline
Junior Member
 
Join Date: Nov 2006
Posts: 26
Default

Thanks for the tip. On my latest huge mp3 file, I was able to get it to resume again. It might be related to what method I used to mark the genre as "podcast". I'll have to play around with it more.

Can the product just "work" nicely? The sad thing is, the longest the "spring update" takes, the more people expect to be in that update (bug fixes and features). I'm starting to hope for a lot from this upcoming update now, too.

Edit: bookmarking mp3s tagged as genre "podcast" appears to be working again; I'll monitor if it starts messing up again.

Last edited by Zendude; 04-06-2010 at 12:58 PM.
Reply With Quote

Reply

Tags
audio, bookmark, mp3, podcast, resume

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 02:49 AM.